summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/mantisbt/mantisbt-1.0.1.ebuild')
-rw-r--r--www-apps/mantisbt/mantisbt-1.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-apps/mantisbt/mantisbt-1.0.1.ebuild b/www-apps/mantisbt/mantisbt-1.0.1.ebuild
new file mode 100644
index 000000000000..925507179830
--- /dev/null
+++ b/www-apps/mantisbt/mantisbt-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.0.1.ebuild,v 1.1 2006/02/23 20:48:07 rl03 Exp $
+
+inherit webapp
+
+IUSE="mysql postgres"
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/mantis-${PV}.tar.gz"
+
+S=${WORKDIR}/mantis-${PV}
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ mysql? ( >=dev-db/mysql-3.23.32 )
+ postgres? ( >=dev-db/postgresql-7 )
+ net-www/apache
+ virtual/httpd-php
+"
+
+LICENSE="GPL-2"
+
+src_install() {
+ webapp_src_preinst
+ dodoc doc/*
+
+ cp -R . ${D}/${MY_HTDOCSDIR}
+ rm -rf ${D}/${MY_HTDOCSDIR}/doc
+
+ mv ${D}/${MY_HTDOCSDIR}/config_inc.php.sample ${D}/${MY_HTDOCSDIR}/config_inc.php
+
+ webapp_configfile ${MY_HTDOCSDIR}/config_inc.php
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-1.0.0.txt
+ webapp_src_install
+}