summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/cherokee/cherokee-0.4.29.ebuild')
-rw-r--r--www-servers/cherokee/cherokee-0.4.29.ebuild82
1 files changed, 61 insertions, 21 deletions
diff --git a/www-servers/cherokee/cherokee-0.4.29.ebuild b/www-servers/cherokee/cherokee-0.4.29.ebuild
index bab71f77e0fa..a6c019fc4190 100644
--- a/www-servers/cherokee/cherokee-0.4.29.ebuild
+++ b/www-servers/cherokee/cherokee-0.4.29.ebuild
@@ -1,59 +1,99 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/cherokee-0.4.29.ebuild,v 1.1 2005/11/13 23:22:09 bass Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/cherokee-0.4.29.ebuild,v 1.2 2005/12/27 09:19:48 bass Exp $
-inherit eutils
+inherit eutils pam
DESCRIPTION="An extremely fast and tiny web server."
SRC_URI="http://www.0x50.org/download/${PV%.*}/${PV}/${P}.tar.gz"
HOMEPAGE="http://www.0x50.org/"
-LICENSE="GPL-2"
-RDEPEND="virtual/libc
- >=sys-libs/zlib-1.1.4-r1"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="ipv6 ssl gnutls static doc pam"
-DEPEND=">=sys-devel/automake-1.7.5
+RDEPEND=">=sys-libs/zlib-1.1.4-r1
gnutls? ( net-libs/gnutls )
ssl? ( dev-libs/openssl )
- ${RDEPEND}"
+ pam? ( virtual/pam )"
-KEYWORDS="~x86 ~ppc ~sparc"
-SLOT="0"
-IUSE="ipv6 ssl gnutls static"
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.7.5"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+# if use static ; then
+# epatch ${FILESDIR}/${P}-fix-static.diff
+
+# einfo "Regenerating automake/autoconf files"
+# libtoolize --copy --force --automake || die "libtoolize failed"
+# aclocal -I ${S}/m4 || die "aclocal failed"
+# autoheader || die "autoheader failed"
+# automake -a || die "automake failed"
+# autoconf || die "autoconf failed"
+# fi
+
+ # remove "doc" from SUBDIRS so that html docs don't get installed
+ # to the wrong place (/usr/share/doc/cherokee) and we can install
+ # them conditionally via dohtml in src_install.
+ sed -i -e 's|\(SUBDIRS =.*\)doc\(.*\)$|\1\2|' Makefile.in || \
+ die "sed Makefile.in failed"
+
+ # use cherokee user/group
+ sed -i -e 's|^#\(User \).*$|\1cherokee|' \
+ -e 's|^#\(Group \).*$|\1cherokee|' cherokee.conf.sample.pre || \
+ die "sed cherokee.conf failed"
+}
src_compile() {
local myconf
if use ssl && use gnutls ; then
- myconf="${myconf} --enable-ssl=gnutls"
+ myconf="${myconf} --enable-tls=gnutls"
elif use ssl && ! use gnutls ; then
- myconf="${myconf} --enable-ssl=openssl"
+ myconf="${myconf} --enable-tls=openssl"
else
- myconf="${myconf} --disable-ssl"
- fi
- if ! use ipv6 ; then
- myconf="${myconf} --disable-ipv6"
+ myconf="${myconf} --disable-tls"
fi
+
if use static ; then
- myconf="${myconf} --enable-static --enable-static-module=all --disable-shared"
+ myconf="${myconf} --enable-static --enable-static-module=all"
else
myconf="${myconf} --disable-static"
fi
econf \
${myconf} \
+ $(use_enable pam) \
+ $(use_enable ipv6) \
--enable-os-string="Gentoo Linux" \
+ --with-wwwroot=/var/www/localhost/htdocs \
|| die "configure failed"
emake || die "emake failed"
}
src_install () {
- dodir /var/www/localhost/htdocs
- dodir /var/www/localhost/cgi-bin
-
make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog COPYING INSTALL README
+ dodoc AUTHORS ChangeLog INSTALL README TODO
+ use doc && dohtml -r doc/*
+ newpamd pam.d_cherokee ${PN} || die "newpamd failed"
newinitd ${FILESDIR}/${PN}-0.4.17-init.d ${PN} || die "newinitd failed"
+
+ # be nice and don't overwrite a user's pre-existing index.html
+ # (unless they're the same).
+ if [[ -f ${ROOT}/var/www/localhost/htdocs/index.html ]] ; then
+ diff ${ROOT}/var/www/localhost/htdocs/index.html \
+ ${D}/var/www/localhost/htdocs/index.html &>/dev/null || \
+ mv ${D}/var/www/localhost/htdocs/{,cherokee-}index.html
+ fi
+}
+
+pkg_postinst() {
+ enewgroup cherokee
+ enewuser cherokee -1 -1 /var/www/localhost cherokee
}