summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/motif-config/ChangeLog10
-rw-r--r--x11-libs/motif-config/Manifest5
-rw-r--r--x11-libs/motif-config/files/digest-motif-config-0.10
-rwxr-xr-xx11-libs/motif-config/files/motif-config-0.1102
-rw-r--r--x11-libs/motif-config/metadata.xml9
-rw-r--r--x11-libs/motif-config/motif-config-0.1.ebuild43
6 files changed, 169 insertions, 0 deletions
diff --git a/x11-libs/motif-config/ChangeLog b/x11-libs/motif-config/ChangeLog
new file mode 100644
index 000000000000..36a5e314036b
--- /dev/null
+++ b/x11-libs/motif-config/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-libs/motif-config
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/motif-config/ChangeLog,v 1.1 2005/02/14 19:04:43 lanius Exp $
+
+*motif-config-0.1 (14 Feb 2005)
+
+ 14 Feb 2005; Heinrich Wendel <lanius@gentoo.org> +metadata.xml,
+ +files/motif-config-0.1, +motif-config-0.1.ebuild:
+ intial revision
+
diff --git a/x11-libs/motif-config/Manifest b/x11-libs/motif-config/Manifest
new file mode 100644
index 000000000000..237a788f3faa
--- /dev/null
+++ b/x11-libs/motif-config/Manifest
@@ -0,0 +1,5 @@
+MD5 33288344780949a173a46b4132f68e03 motif-config-0.1.ebuild 934
+MD5 7d70d9fe42eb317221f10ba1d8a9a06e ChangeLog 386
+MD5 503ccb1138f9c49f0855884d830988a6 metadata.xml 253
+MD5 274cc5c8c80dd3058a96ea0b9ad340b2 files/motif-config-0.1 1760
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-motif-config-0.1 0
diff --git a/x11-libs/motif-config/files/digest-motif-config-0.1 b/x11-libs/motif-config/files/digest-motif-config-0.1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/x11-libs/motif-config/files/digest-motif-config-0.1
diff --git a/x11-libs/motif-config/files/motif-config-0.1 b/x11-libs/motif-config/files/motif-config-0.1
new file mode 100755
index 000000000000..eea80b9fca3f
--- /dev/null
+++ b/x11-libs/motif-config/files/motif-config-0.1
@@ -0,0 +1,102 @@
+#!/bin/bash
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# based on gcc-config by Martin Schlemmer <azarah@gentoo.org
+# Author: Heinrich Wendel <lanius@gentoo.org>
+
+source /etc/init.d/functions.sh || {
+ echo "$0: Could not source /etc/init.d/functions.sh!"
+ exit 1
+}
+umask 022
+
+PROFILE_PATH=/usr/$(get_libdir)/motif
+CONFIG_FILE=${PROFILE_PATH}/current
+
+usage() {
+cat << "USAGE_END"
+Usage: motif-config [options] [Profile]
+Change the current motif profile, or give info about profiles.
+
+Options:
+
+ -c, --get-current-profile Print current used motif profile.
+
+ -l, --list-profiles Print a list of available profiles.
+
+ -L, --get-lib-path Print path where libraries of the given/current
+ profile are located.
+
+ -I, --get-inc-path Print path where includes of the given/current
+ profile are located.
+
+ --libs Print link flags for the given/current
+ profile.
+
+ --cflags Print compilation flags for the given/current
+ profile.
+
+USAGE_END
+ exit $1
+}
+[[ $# -lt 1 ]] && usage 1
+
+
+get_current_profile() {
+ exit 0
+}
+
+switch_profile() {
+ exit 0
+}
+
+list_profiles() {
+ exit 0
+}
+
+get_lib_path() {
+ exit 0
+}
+
+get_inc_path() {
+ exit 0
+}
+
+for x in "$@"; do
+ case "${x}" in
+ -l|--list-profiles)
+ ;;
+
+ -L|--get-lib-path)
+ ;;
+
+ -I|--get-inc-path)
+ ;;
+
+ --clfags)
+ ;;
+
+ --ldflags)
+ ;;
+
+ -h|--help)
+ usage 0
+ exit 0
+ ;;
+
+ -v|--version)
+ echo "motif-config-1.0"
+ exit 0
+ ;;
+
+ -*)
+ eerror "$0: Invalid switch! Run $0 without parameters for help."
+ exit 1
+ ;;
+
+
+ *)
+ # switch profile
+ ;;
+ esac
+done
diff --git a/x11-libs/motif-config/metadata.xml b/x11-libs/motif-config/metadata.xml
new file mode 100644
index 000000000000..c3504b40c506
--- /dev/null
+++ b/x11-libs/motif-config/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>lanius@gentoo.org</email>
+ <name>Heinrich Wendel</name>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-libs/motif-config/motif-config-0.1.ebuild b/x11-libs/motif-config/motif-config-0.1.ebuild
new file mode 100644
index 000000000000..e0733561ea91
--- /dev/null
+++ b/x11-libs/motif-config/motif-config-0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/motif-config/motif-config-0.1.ebuild,v 1.1 2005/02/14 19:04:43 lanius Exp $
+
+inherit multilib
+
+DESCRIPTION="Utility to change the default Motif library"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+RDEPEND="app-shells/bash"
+
+src_unpack(){
+ einfo "nothing to unpack"
+}
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install () {
+ exeinto /usr/bin
+ newexe ${FILESDIR}/motif-config-1.0 motif-config
+
+ dodir /usr/$(get_libdir)/motif
+
+ insinto /etc/X11/app-defaults
+ # Mwm
+ insinto /etc/X11/mwm
+ # system.mwmrc
+ dosym /etc/X11/mwm /usr/$(get_libdir)/X11/mwm
+ dodir /usr/include/X11/bitmaps
+ # bitmaps
+ dodir /usr/$(get_libdir)/X11/bindings
+ # bindings
+}