summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/alltray/alltray-0.62.ebuild')
-rw-r--r--x11-misc/alltray/alltray-0.62.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/alltray/alltray-0.62.ebuild b/x11-misc/alltray/alltray-0.62.ebuild
new file mode 100644
index 000000000000..fd60e3c318e2
--- /dev/null
+++ b/x11-misc/alltray/alltray-0.62.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alltray/alltray-0.62.ebuild,v 1.1 2005/09/24 00:15:38 swegener Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Dock any application into the system tray/notification area"
+HOMEPAGE="http://alltray.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ append-flags -DLIBDIR="'\"/usr/$(get_libdir)\"'"
+
+ econf || die "econf failed"
+ emake X_CFLAGS="-fPIC" || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README || die "dodoc failed"
+}