summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/openbox/openbox-3.0_beta1.ebuild')
-rw-r--r--x11-wm/openbox/openbox-3.0_beta1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-wm/openbox/openbox-3.0_beta1.ebuild b/x11-wm/openbox/openbox-3.0_beta1.ebuild
new file mode 100644
index 000000000000..18992e8e9072
--- /dev/null
+++ b/x11-wm/openbox/openbox-3.0_beta1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.0_beta1.ebuild,v 1.1 2003/09/04 03:48:47 tseng Exp $
+
+S=${WORKDIR}/${P/_/-}
+DESCRIPTION="Openbox is a standards compliant, fast, light-weight, extensible window manager."
+SRC_URI="http://icculus.org/openbox/releases/${P/_/-}.tar.gz"
+HOMEPAGE="http://icculus.org/openbox/"
+IUSE="nls"
+SLOT="3"
+
+DEPEND="virtual/xft
+ virtual/x11
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2"
+RDEPEND=${DEPEND}
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+src_compile() {
+
+ econf \
+ `use_enable nls` \
+ --program-suffix="3" || die
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc README AUTHORS ChangeLog TODO
+}
+
+pkg_postinst () {
+ einfo "A few more small changes to the configs and themes."
+ einfo "Your rc3 and menu should move to rc.xml and menu.xml respectively."
+ einfo "Please check out the examples in /usr/share/openbox/ before running."
+}