summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/xfdesktop/xfdesktop-4.0.5.ebuild')
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.0.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/xfdesktop-4.0.5.ebuild b/xfce-base/xfdesktop/xfdesktop-4.0.5.ebuild
new file mode 100644
index 000000000000..0ee5e1cf55ab
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-4.0.5.ebuild,v 1.1 2004/04/18 05:22:11 bcowan Exp $
+
+IUSE="X"
+
+DESCRIPTION="Xfce4 desktop"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://hannelore.f1.fhtw-berlin.de/mirrors/xfce4/xfce-${PV}/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ia64 ~x86 ~ppc ~alpha ~sparc ~amd64 ~hppa ~mips"
+
+RDEPEND=">=x11-libs/gtk+-2.0.6
+ dev-libs/libxml2
+ =xfce-base/libxfce4util-${PV}
+ =xfce-base/libxfcegui4-${PV}
+ =xfce-base/libxfce4mcs-${PV}
+ =xfce-base/xfce-mcs-manager-${PV}"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ use X && myconf="${myconf} --with-x"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS INSTALL COPYING README ChangeLog TODO
+}