summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/xfdesktop/xfdesktop-4.8.0.ebuild')
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.8.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/xfdesktop-4.8.0.ebuild b/xfce-base/xfdesktop/xfdesktop-4.8.0.ebuild
new file mode 100644
index 000000000000..12a5d1311cf0
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-4.8.0.ebuild,v 1.1 2011/01/16 17:36:01 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Xfce's desktop manager"
+HOMEPAGE="http://www.xfce.org/projects/xfdesktop/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.8/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify thunar"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libSM
+ >=x11-libs/libwnck-2.22
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/garcon-0.1.5
+ >=xfce-base/xfconf-4.8
+ libnotify? ( >=x11-libs/libnotify-0.4 )
+ thunar? ( >=xfce-base/exo-0.6
+ >=xfce-base/thunar-1.2
+ >=dev-libs/dbus-glib-0.88 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ --disable-static
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable thunar exo)
+ $(use_enable libnotify notifications)
+ $(xfconf_use_debug)
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}