aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-05-14 00:39:13 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2015-05-14 00:39:13 -0700
commit43f20e55910882b3a8888d7c374548322f6ce42d (patch)
tree7a19c350e0f4fe63b155dd675157d023eae3916b /www-client
parentxorg and mesa updates for raspberrypi vc4 video support (diff)
downloadarm-43f20e55910882b3a8888d7c374548322f6ce42d.tar.gz
arm-43f20e55910882b3a8888d7c374548322f6ce42d.tar.bz2
arm-43f20e55910882b3a8888d7c374548322f6ce42d.zip
adjust for hardfloat without neon (tested on rpi)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-37.0.2.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/www-client/firefox/firefox-37.0.2.ebuild b/www-client/firefox/firefox-37.0.2.ebuild
index 5a4f057..8242da1 100644
--- a/www-client/firefox/firefox-37.0.2.ebuild
+++ b/www-client/firefox/firefox-37.0.2.ebuild
@@ -218,12 +218,13 @@ src_configure() {
mozconfig_annotate '' --with-fpu=neon
mozconfig_annotate '' --with-thumb=yes
mozconfig_annotate '' --with-thumb-interwork=no
- mozconfig_annotate '' --with-float-abi=hard
+ fi
- if ! use system-libvpx ; then
- sed -i -e "s|softfp|hard|" \
- "${S}"/media/libvpx/moz.build
- fi
+ mozconfig_annotate '' --with-float-abi=hard
+
+ if ! use system-libvpx ; then
+ sed -i -e "s|softfp|hard|" \
+ "${S}"/media/libvpx/moz.build
fi
use gtk3 && mozconfig_annotate 'Enable Cairo Gtk+3 support' --enable-default-toolkit=cairo-gtk3