aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-08-20 14:06:06 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-08-20 14:06:06 +0500
commit836341b36c601e29cacd57ce1d4a4ec8edd8aae4 (patch)
tree93a44e262fba4635e6234b0487a64a6944cacc64
parentphosh-base/phosh: add 0.41.0, drop 0.38.0 (diff)
downloadguru-836341b36c601e29cacd57ce1d4a4ec8edd8aae4.tar.gz
guru-836341b36c601e29cacd57ce1d4a4ec8edd8aae4.tar.bz2
guru-836341b36c601e29cacd57ce1d4a4ec8edd8aae4.zip
gui-apps/meteo-qt: add 3.4
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--gui-apps/meteo-qt/Manifest1
-rw-r--r--gui-apps/meteo-qt/meteo-qt-3.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/gui-apps/meteo-qt/Manifest b/gui-apps/meteo-qt/Manifest
index 7922ae828..f68e3054a 100644
--- a/gui-apps/meteo-qt/Manifest
+++ b/gui-apps/meteo-qt/Manifest
@@ -1 +1,2 @@
DIST meteo-qt-3.3.gh.tar.gz 931450 BLAKE2B 0f8128ba768510b278862e2dbe33267cb339cb6fb6299e6448f49a6d5efaf98db045bd07833695e2eea936ce78bece4bc62bb62322a1df43767438e72c26dc86 SHA512 e52d05b98b99ecc01b9d584cf15db495f5c1eaa6e3ac1f429542d9d43e3890b03d93e3c7a55059821a32ea614cce7bb104b9353c59da04f164b561c920cca415
+DIST meteo-qt-3.4.gh.tar.gz 970247 BLAKE2B 44980c54c4fd746b487192e621b84ec278db22fdea534646535f49535dc1937a815d79ede3870e49f14c95c051c73c90f4e1cdd25099ebf311bc3ecb540d727c SHA512 3e9221ba460a0be874c2e1edb8eac3d363bae68f7d333977196230e3d37f28b12ed1d02b3d729830fbcd68288994cc27d1d940989f36e44475bf8eb01529bbf1
diff --git a/gui-apps/meteo-qt/meteo-qt-3.4.ebuild b/gui-apps/meteo-qt/meteo-qt-3.4.ebuild
new file mode 100644
index 000000000..aa2f9f9ec
--- /dev/null
+++ b/gui-apps/meteo-qt/meteo-qt-3.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1 qmake-utils xdg
+
+DESCRIPTION="A system tray application for the weather status"
+HOMEPAGE="https://github.com/dglent/meteo-qt"
+SRC_URI="https://github.com/dglent/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ dev-python/PyQt5
+ dev-qt/linguist-tools
+"
+
+src_compile() {
+ local -x PATH="$(qt5_get_bindir):${PATH}"
+ distutils-r1_src_compile
+}
+
+python_install() {
+ mv "${BUILD_DIR}/install$(python_get_sitedir)/usr" "${ED}" || die
+ rm -r "${ED}/usr/share/doc" || die
+
+ distutils-r1_python_install
+}