aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2024-08-22 21:30:04 +0200
committerPascal Jäger <pascal.jaeger@leimstift.de>2024-08-22 21:30:04 +0200
commitd5854540fcb5136620b0fec7e979510a28ec1171 (patch)
treeea4f58b353428adcb681b0ec09dd4298c2b08f19
parentgui-apps/nwg-shell: add 0.5.38 (diff)
downloadguru-d5854540fcb5136620b0fec7e979510a28ec1171.tar.gz
guru-d5854540fcb5136620b0fec7e979510a28ec1171.tar.bz2
guru-d5854540fcb5136620b0fec7e979510a28ec1171.zip
gui-apps/nwg-shell-config: add 0.5.46
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
-rw-r--r--gui-apps/nwg-shell-config/Manifest1
-rw-r--r--gui-apps/nwg-shell-config/nwg-shell-config-0.5.46.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/gui-apps/nwg-shell-config/Manifest b/gui-apps/nwg-shell-config/Manifest
index d69499d5b..2db79b94b 100644
--- a/gui-apps/nwg-shell-config/Manifest
+++ b/gui-apps/nwg-shell-config/Manifest
@@ -1,2 +1,3 @@
DIST nwg-shell-config-0.5.41.tar.gz 117746 BLAKE2B dc7440e8da1ebd3124cf001941339daf2ba333d85f5eb0a07bbcff93c72377a4f82a9f3fed42a68dd7e4bc4e7099cff4c3c1bb11b5e0375ff69811597c78ca37 SHA512 6b38054b17ddf8220e105a56e9c10dd0fc58fd395d65eb45237fe7a5f2d4dbbd188e5672bebd0606b4eb59b613a10805b560406a0aa4bfa318ac237c9137bb99
DIST nwg-shell-config-0.5.42.tar.gz 118692 BLAKE2B 81fb613a6528e0675ed1635e4ade3132d9266dc9c0625ee4e5f772dab103cbc702a40a7ba08ffd0082342b9631a33c190152d68da2ab5ceb3dd21ea55f20a7a8 SHA512 9f816a3236cd91d5135f214bc691066215f453eb481b088577fb38c8d9b3b9a67a5c7edf1f6689f24d4fd45722c498034ccb3a1c5ed9542cc2572e303b0e6bde
+DIST nwg-shell-config-0.5.46.tar.gz 116709 BLAKE2B 6044602893541cdfa3f359310a87a1194f42f5d014a568f060a21be8c833122a1131c3fe7bc1d6ad57594958fd66e1b802b12067336ff1697a5c401224a297fa SHA512 219596e216ee04797bf1b176995fabcee82308b727fbfe0067a45364790780fc74c6afda3b6721226ae4fa0deca67d5d7c3765282da2f54c95d20f418794ab63
diff --git a/gui-apps/nwg-shell-config/nwg-shell-config-0.5.46.ebuild b/gui-apps/nwg-shell-config/nwg-shell-config-0.5.46.ebuild
new file mode 100644
index 000000000..18bb5419f
--- /dev/null
+++ b/gui-apps/nwg-shell-config/nwg-shell-config-0.5.46.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit desktop distutils-r1 xdg-utils
+
+DESCRIPTION="nwg-shell configuration utility"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-shell-config"
+SRC_URI="https://github.com/nwg-piotr/nwg-shell-config/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ gui-apps/nwg-shell
+ sci-geosciences/geopy
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu nwg-shell-config.desktop
+ doicon nwg-shell-config.svg
+ doicon nwg-shell-update.svg
+ doicon nwg-shell-translate.svg
+ doicon nwg-update-noupdate.svg
+ doicon nwg-update-available.svg
+ doicon nwg-update-checking.svg
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}