aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-11-28 21:05:55 +1300
committerTheo Anderson <telans@posteo.de>2020-11-28 21:05:55 +1300
commitf985280037cfd519f8bf8b0d74e3063c6eeb7d51 (patch)
tree5cc3b7e1114175661a4bca64986f3cdfc05db452 /app-accessibility
parentapp-misc/rdfind: add bdepend sys-devel/autoconf-archive (diff)
downloadguru-f985280037cfd519f8bf8b0d74e3063c6eeb7d51.tar.gz
guru-f985280037cfd519f8bf8b0d74e3063c6eeb7d51.tar.bz2
guru-f985280037cfd519f8bf8b0d74e3063c6eeb7d51.zip
app-accessibility/mimic1: fix GCC 10 building
multiple definition of `cst_rx_not_indic' Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/mimic1/files/mimic1-1.3.0.1-gcc10.patch25
-rw-r--r--app-accessibility/mimic1/mimic1-1.3.0.1.ebuild6
-rw-r--r--app-accessibility/mimic1/mimic1-9999.ebuild6
3 files changed, 31 insertions, 6 deletions
diff --git a/app-accessibility/mimic1/files/mimic1-1.3.0.1-gcc10.patch b/app-accessibility/mimic1/files/mimic1-1.3.0.1-gcc10.patch
new file mode 100644
index 000000000..e2b30f113
--- /dev/null
+++ b/app-accessibility/mimic1/files/mimic1-1.3.0.1-gcc10.patch
@@ -0,0 +1,25 @@
+From 55cbf5bc28c32cfe66cb746e00c10be4f2537a1d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 12 Aug 2020 16:47:27 -0700
+Subject: [PATCH] cmu_indic_lang: Make cst_rx_not_indic as extern declaration
+
+Fixes build with gcc-10 which has -fno-common turned on by default
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ lang/cmu_indic_lang/cmu_indic_lang.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lang/cmu_indic_lang/cmu_indic_lang.h b/lang/cmu_indic_lang/cmu_indic_lang.h
+index 75ee46c..83e2afa 100644
+--- a/lang/cmu_indic_lang/cmu_indic_lang.h
++++ b/lang/cmu_indic_lang/cmu_indic_lang.h
+@@ -51,7 +51,7 @@ void cmu_indic_lang_init(cst_voice *v);
+ extern const cst_phoneset cmu_indic_phoneset;
+ extern const cst_cart cmu_indic_phrasing_cart;
+
+-const cst_regex * const cst_rx_not_indic;
++extern const cst_regex * const cst_rx_not_indic;
+
+ #ifdef __cplusplus
+ } /* extern "C" */
diff --git a/app-accessibility/mimic1/mimic1-1.3.0.1.ebuild b/app-accessibility/mimic1/mimic1-1.3.0.1.ebuild
index 5d07fcc4f..b6c8eb159 100644
--- a/app-accessibility/mimic1/mimic1-1.3.0.1.ebuild
+++ b/app-accessibility/mimic1/mimic1-1.3.0.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit autotools
-if [[ ${PV} == *9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/MycroftAI/mimic1.git"
else
@@ -31,10 +31,10 @@ DEPEND="
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/${P}-gcc10.patch" )
+
src_prepare() {
default
-
sed -i 's/-Werror//' Makefile.am
-
eautoreconf
}
diff --git a/app-accessibility/mimic1/mimic1-9999.ebuild b/app-accessibility/mimic1/mimic1-9999.ebuild
index 5d07fcc4f..562221b11 100644
--- a/app-accessibility/mimic1/mimic1-9999.ebuild
+++ b/app-accessibility/mimic1/mimic1-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit autotools
-if [[ ${PV} == *9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/MycroftAI/mimic1.git"
else
@@ -31,10 +31,10 @@ DEPEND="
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/${PN}-1.3.0.1-gcc10.patch" )
+
src_prepare() {
default
-
sed -i 's/-Werror//' Makefile.am
-
eautoreconf
}