aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2024-06-04 14:55:53 -0400
committerWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2024-06-04 14:59:53 -0400
commit892e054f8c7ae80ac69c080eb54e72e0ecf8453e (patch)
tree1ffe93905eee02829539e1a897653997c8a63a6a /app-backup
parentmore tweaks to pkgbuild (diff)
downloadguru-892e054f8c7ae80ac69c080eb54e72e0ecf8453e.tar.gz
guru-892e054f8c7ae80ac69c080eb54e72e0ecf8453e.tar.bz2
guru-892e054f8c7ae80ac69c080eb54e72e0ecf8453e.zip
app-backup/b2-3.18.0: fix broken tests.
On the last version bump, the number of skipped tests was decreased in an attempt to improve test coverage. This was poorly tested resulting in failing tests. Signed-off-by: Wolfgang E. Sanyer <ezzieyguywuf@gmail.com> Closes: https://bugs.gentoo.org/932105
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/b2/b2-3.18.0.ebuild22
1 files changed, 18 insertions, 4 deletions
diff --git a/app-backup/b2/b2-3.18.0.ebuild b/app-backup/b2/b2-3.18.0.ebuild
index de51fe0a3d..d9cef16efb 100644
--- a/app-backup/b2/b2-3.18.0.ebuild
+++ b/app-backup/b2/b2-3.18.0.ebuild
@@ -48,11 +48,25 @@ DEPEND="
distutils_enable_tests pytest
-# - integration tests require an application key and id (which is reasonable)
-# - sync tests require network access
+EPYTEST_DESELECT=(
+ # fixture 'worker_id' not found
+ "test/integration/test_b2_command_line.py"
+ "test/integration/test_help.py::test_help"
+ "test/integration/test_autocomplete.py"
+
+ # Timeout exceeded
+ # I think this is trying to access files outside of the sandbox
+ "test/unit/console_tool/test_install_autocomplete.py::test_install_autocomplete"
+
+ # TypeError: super(type, obj): obj must be an instance or subtype of type
+ # This test itself does not fail, but running it causes subsequent test to
+ # fail, which otherwise pass. Not really sure why (I assume this test is
+ # somehow polluting the test fixture?) but disabling causes the other tests
+ # to pass
+ "test/unit/_cli/test_autocomplete_cache.py"
+)
python_test() {
- epytest --deselect test/unit/console_tool test/unit
- epytest test/unit/console_tool
+ epytest test
}
pkg_postinst() {