aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-04-15 20:48:22 +0200
committerMarco Scardovi <marco@scardovi.com>2021-04-15 20:48:22 +0200
commitbbeb1a680387e42c0e62046dc0ce89f62f8e8052 (patch)
treeb9bfe1178c8f977f301cb52d74c981a01fb7df56 /app-editors
parentapp-editors/vscodium-bin: drop old 1.53.1 (diff)
downloadguru-bbeb1a680387e42c0e62046dc0ce89f62f8e8052.tar.gz
guru-bbeb1a680387e42c0e62046dc0ce89f62f8e8052.tar.bz2
guru-bbeb1a680387e42c0e62046dc0ce89f62f8e8052.zip
app-editors/atom-bin: use optfeature for GLEP 62
Closes: https://bugs.gentoo.org/781020 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/atom-bin/atom-bin-1.56.0-r2.ebuild (renamed from app-editors/atom-bin/atom-bin-1.56.0-r1.ebuild)21
-rw-r--r--app-editors/atom-bin/metadata.xml3
2 files changed, 10 insertions, 14 deletions
diff --git a/app-editors/atom-bin/atom-bin-1.56.0-r1.ebuild b/app-editors/atom-bin/atom-bin-1.56.0-r2.ebuild
index 7569cec58..37324372b 100644
--- a/app-editors/atom-bin/atom-bin-1.56.0-r1.ebuild
+++ b/app-editors/atom-bin/atom-bin-1.56.0-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit desktop xdg
+inherit desktop optfeature xdg
DESCRIPTION="A hackable text editor for the 21st Century"
HOMEPAGE="https://atom.io/"
@@ -13,10 +13,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-# beautify contains packages used by atom-beautify.
-# If you want other plugins to be working please file
-# a bug on bugs.gentoo.org under GURU section.
-IUSE="alsa beautify cups ssl test X"
+IUSE="alsa cups ssl test X"
RESTRICT="!test? ( test )"
S="${WORKDIR}/atom-${PV}-amd64"
@@ -29,12 +26,6 @@ RDEPEND="
dev-libs/nss
dev-vcs/git
alsa? ( media-libs/alsa-lib )
- beautify? (
- dev-python/autopep8
- dev-python/black
- dev-util/beautysh
- dev-util/uncrustify
- )
cups? ( net-print/cups )
ssl? (
dev-libs/openssl
@@ -92,3 +83,11 @@ src_install(){
find "${ED}" -name '*.la' -delete || die
}
+
+pkg_postinst(){
+ optfeature_header "If you want to use atom-beautify please install following packages:"
+ optfeature "python code beautifier" dev-python/autopep8
+ optfeature "python code beautifier" dev-python/black
+ optfeature "shell code beautifier" dev-util/beautysh
+ optfeature "C, C++, Java code beautifier" dev-util/uncrustify
+}
diff --git a/app-editors/atom-bin/metadata.xml b/app-editors/atom-bin/metadata.xml
index 6d0088886..a0b29038e 100644
--- a/app-editors/atom-bin/metadata.xml
+++ b/app-editors/atom-bin/metadata.xml
@@ -8,7 +8,4 @@
<upstream>
<remote-id type="github">atom/atom</remote-id>
</upstream>
- <use>
- <flag name="beautify">Install packages for atom-beautify</flag>
- </use>
</pkgmetadata>