aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-10-31 13:11:20 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-01 14:05:20 +0500
commit7175612ab4ee8e71c15d9e1d5ec2bdbec01edc0b (patch)
tree38169c07ac1511cf1c02f05689f4de069d3aa7af /app-vim
parentdev-crystal: new category (diff)
downloadguru-7175612ab4ee8e71c15d9e1d5ec2bdbec01edc0b.tar.gz
guru-7175612ab4ee8e71c15d9e1d5ec2bdbec01edc0b.tar.bz2
guru-7175612ab4ee8e71c15d9e1d5ec2bdbec01edc0b.zip
app-vim/vim-crystal: new package, add 2022.09.04
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vim-crystal/Manifest1
-rw-r--r--app-vim/vim-crystal/metadata.xml11
-rw-r--r--app-vim/vim-crystal/vim-crystal-2022.09.04.ebuild23
3 files changed, 35 insertions, 0 deletions
diff --git a/app-vim/vim-crystal/Manifest b/app-vim/vim-crystal/Manifest
new file mode 100644
index 000000000..d05b4fedd
--- /dev/null
+++ b/app-vim/vim-crystal/Manifest
@@ -0,0 +1 @@
+DIST vim-crystal-2022.09.04.tar.gz 42137 BLAKE2B 141fb2351c49f5fecad5b7dc2eb15b3308302e99634f51051f8482a49863a4a4fa2a1a07c4beb99de667e6c65efa52a6e6a1812bd8c4cad40d749afe873ffb5e SHA512 cb772f2728a6a98c37d6698b198b9149d34d01b02121faf581ebacb46ba6e810e24efd48fe7b199e6b3736130010650944129c68d63d7e81ebfa84638bdc6a71
diff --git a/app-vim/vim-crystal/metadata.xml b/app-vim/vim-crystal/metadata.xml
new file mode 100644
index 000000000..032110ea0
--- /dev/null
+++ b/app-vim/vim-crystal/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vim-crystal/vim-crystal</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-crystal/vim-crystal-2022.09.04.ebuild b/app-vim/vim-crystal/vim-crystal-2022.09.04.ebuild
new file mode 100644
index 000000000..c626414f2
--- /dev/null
+++ b/app-vim/vim-crystal/vim-crystal-2022.09.04.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature vim-plugin
+
+COMMIT="43e4d89c5d29b3a0d17dda5bd57eadda6fc614d4"
+DESCRIPTION="vim plugin: Crystal language support"
+HOMEPAGE="https://github.com/vim-crystal/vim-crystal"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+src_install() {
+ vim-plugin_src_install syntax_checkers
+}
+
+pkg_postinst() {
+ optfeature "syntax checking support" app-vim/syntastic
+}