aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-06-22 22:15:38 +0200
committerOliver Freyermuth <o.freyermuth@googlemail.com>2022-06-22 22:15:38 +0200
commit0adf577bc2cca5743b5bfaade63ed7a1a96a6a0d (patch)
tree05c648b848aeafe5a584500967cdbc330500d8d7 /dev-cpp
parentsci-electronics/kactus2: drop 3.8.0 (diff)
downloadguru-0adf577bc2cca5743b5bfaade63ed7a1a96a6a0d.tar.gz
guru-0adf577bc2cca5743b5bfaade63ed7a1a96a6a0d.tar.bz2
guru-0adf577bc2cca5743b5bfaade63ed7a1a96a6a0d.zip
dev-cpp/scitokens-cpp: add 0.7.1
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/scitokens-cpp/Manifest1
-rw-r--r--dev-cpp/scitokens-cpp/files/scitokens-cpp-0.7.1-fix-external-gtest.patch20
-rw-r--r--dev-cpp/scitokens-cpp/scitokens-cpp-0.7.1.ebuild55
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-cpp/scitokens-cpp/Manifest b/dev-cpp/scitokens-cpp/Manifest
index c935ffbbe..76d04dd3c 100644
--- a/dev-cpp/scitokens-cpp/Manifest
+++ b/dev-cpp/scitokens-cpp/Manifest
@@ -1 +1,2 @@
DIST scitokens-cpp-0.7.0.tar.gz 98971 BLAKE2B 3429ff89b5a5202f9892fc68fc558c8b64276977a396981af845f05f8eb3f638602cedd30ea97f3ab5e6d188de7249247854dd6281aeb138d6e304b5aa006bb9 SHA512 1be8a84b7d88c10ab7336c3c6bc8d7e7be5feb3253ef618cba1f3ed908aad3fc480f30dd2a292aa2774ec88ceba370af3fa7d96f228cba3df8f78b6face6991b
+DIST scitokens-cpp-0.7.1.tar.gz 99411 BLAKE2B b89c63ad35105a064e6f8ecd7596ba51de43096828a756b7c64669a352784c56bcb9295638f173cdbeac833e9dfc14828daf775d60a6cd124abf639125cf5842 SHA512 5c73fcccfb2db92916caced118e2ab4e110f7a8331a9bd84d06bd059da5258d7e8423822356e1833bbce7b047d7f31e2cd20cf4c0eb064dc2d248d9febab35b5
diff --git a/dev-cpp/scitokens-cpp/files/scitokens-cpp-0.7.1-fix-external-gtest.patch b/dev-cpp/scitokens-cpp/files/scitokens-cpp-0.7.1-fix-external-gtest.patch
new file mode 100644
index 000000000..baa4a08f5
--- /dev/null
+++ b/dev-cpp/scitokens-cpp/files/scitokens-cpp-0.7.1-fix-external-gtest.patch
@@ -0,0 +1,20 @@
+Bug: https://github.com/scitokens/scitokens-cpp/pull/89
+
+---
+ test/CMakeLists.txt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index 22f86a6..2083bff 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -1,6 +1,8 @@
+
+ add_executable(scitokens-gtest main.cpp)
+-add_dependencies(scitokens-gtest gtest)
++if( NOT SCITOKENS_EXTERNAL_GTEST )
++ add_dependencies(scitokens-gtest gtest)
++endif()
+ include_directories("${PROJECT_SOURCE_DIR}/vendor/gtest/googletest/include")
+
+ if(SCITOKENS_EXTERNAL_GTEST)
diff --git a/dev-cpp/scitokens-cpp/scitokens-cpp-0.7.1.ebuild b/dev-cpp/scitokens-cpp/scitokens-cpp-0.7.1.ebuild
new file mode 100644
index 000000000..5d3e16ae9
--- /dev/null
+++ b/dev-cpp/scitokens-cpp/scitokens-cpp-0.7.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scitokens/scitokens-cpp"
+else
+ SRC_URI="https://github.com/scitokens/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION=" A C++ implementation of the SciTokens library with a C library interface"
+HOMEPAGE="https://scitokens.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+DEPEND="${RDEPEND}
+ <dev-cpp/jwt-cpp-0.5.0
+ dev-db/sqlite
+ dev-libs/openssl
+ net-misc/curl
+ sys-apps/util-linux
+ test? ( dev-cpp/gtest )"
+BDEPEND="virtual/pkgconfig"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/"${PN}"-0.7.1-fix-external-gtest.patch
+)
+
+src_prepare() {
+ # Unbundle dev-cpp/gtest, dev-cpp/jwt-cpp
+ rm -rvf vendor
+ # Fix include path for picojson.
+ find src/ \( -name '*.cpp' -o -name '*.h' \) -type f -print0 | xargs -0 sed -r -e "s:picojson/picojson\.h:picojson.h:g" -i || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSCITOKENS_BUILD_UNITTESTS="$(usex test)"
+ -DSCITOKENS_EXTERNAL_GTEST=YES
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_run_in "${BUILD_DIR}" ctest --verbose || die
+}