aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteffen Winter <steffen.winter@proton.me>2024-09-07 13:35:01 +0200
committerSteffen Winter <steffen.winter@proton.me>2024-09-07 13:35:01 +0200
commite8fd0ba29ddf94cd294818babc3be24168522323 (patch)
tree55a1c29ab09cb8456e33f015f67e15a5865c4dd5 /dev-cpp
parentdev-vcs/jj: Remove unused patch (diff)
downloadguru-e8fd0ba29ddf94cd294818babc3be24168522323.tar.gz
guru-e8fd0ba29ddf94cd294818babc3be24168522323.tar.bz2
guru-e8fd0ba29ddf94cd294818babc3be24168522323.zip
dev-cpp/fast_float: add 6.1.5
Signed-off-by: Steffen Winter <steffen.winter@proton.me>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/fast_float/Manifest1
-rw-r--r--dev-cpp/fast_float/fast_float-6.1.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-cpp/fast_float/Manifest b/dev-cpp/fast_float/Manifest
index 7cf4b29e8..133b156f8 100644
--- a/dev-cpp/fast_float/Manifest
+++ b/dev-cpp/fast_float/Manifest
@@ -1 +1,2 @@
DIST fast_float-6.1.4.tar.gz 100445 BLAKE2B fa200f622f155f371a2a743f19f7aa01175f64e845e03d35521faa5e256e0447cae317b39ef465e227b7910afd800191ac6d0b6a0fe0a4099c91a1bcce76c4d2 SHA512 b43ccdf1fc69d9bb07850f4ea40442e312107e7047d80cb57666ac4a4df4152c438ba6ffb8879824c691a6ce2e1d20c95a47724c5af8d10e5d787455e0a97efe
+DIST fast_float-6.1.5.tar.gz 101708 BLAKE2B 7d1b85dc01ab46c2e69c3920ed5b0fcda169607181bc5ac96b92fe4cfae99b3252de7d05885726549ad238caa5e33c1fa15c352f89812b9dbce215803b42563d SHA512 fb73c9f45cecc4fd318d2610a0e0cc58084cb494e32475ce129e742f41e1e02f5ed8f2fb2270b020c42bc4301267a49693ef731c8f08b1772fb1a78fd62099b8
diff --git a/dev-cpp/fast_float/fast_float-6.1.5.ebuild b/dev-cpp/fast_float/fast_float-6.1.5.ebuild
new file mode 100644
index 000000000..c3fa3bd78
--- /dev/null
+++ b/dev-cpp/fast_float/fast_float-6.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fast and exact implementation of the C++ from_chars functions for number types"
+HOMEPAGE="https://github.com/fastfloat/fast_float"
+SRC_URI="https://github.com/fastfloat/fast_float/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 Boost-1.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+BDEPEND="test? ( dev-cpp/doctest )"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=( -DFASTFLOAT_TEST=$(usex test ON OFF) )
+ use test && mycmakeargs+=(
+ -DSYSTEM_DOCTEST=ON
+ # Unconditionally calls FetchContent
+ -DFASTFLOAT_SUPPLEMENTAL_TESTS=OFF
+ )
+
+ sed -i 's/-Werror//' tests/CMakeLists.txt || die
+
+ cmake_src_configure
+}