aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-27 08:36:24 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-27 15:14:40 +0200
commita4ef26a73bf7716663c8feb62819c7ffc4d65a62 (patch)
tree5ba8b2a99e1417c2f1d2399baa57b9f69660239d /dev-php
parentguru/profiles/package.mask: kikoplay works, but masked for repoman check (diff)
downloadguru-a4ef26a73bf7716663c8feb62819c7ffc4d65a62.tar.gz
guru-a4ef26a73bf7716663c8feb62819c7ffc4d65a62.tar.bz2
guru-a4ef26a73bf7716663c8feb62819c7ffc4d65a62.zip
dev-php/pecl-inotify: new package
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-inotify/Manifest1
-rw-r--r--dev-php/pecl-inotify/metadata.xml12
-rw-r--r--dev-php/pecl-inotify/pecl-inotify-2.0.0.ebuild21
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-php/pecl-inotify/Manifest b/dev-php/pecl-inotify/Manifest
new file mode 100644
index 000000000..e69cbd2be
--- /dev/null
+++ b/dev-php/pecl-inotify/Manifest
@@ -0,0 +1 @@
+DIST inotify-2.0.0.tgz 8836 BLAKE2B ac0005f3f755bdb3ac1137f903ecf67b14adddf4895d02fcba42bd268eda8bdf2270b4183cf60d5b8ecc0078b6a660dda76a43cdb4f78352b805d0fdc4972ac8 SHA512 0547fdafd8177d41c2a92251cd85f046959ec8594236dc3d14396df0119a78cc6811973b641b95d1036b4325f9e97f0f9e9b181ae1dea79fc343f01777b6966d
diff --git a/dev-php/pecl-inotify/metadata.xml b/dev-php/pecl-inotify/metadata.xml
new file mode 100644
index 000000000..b8b33ab88
--- /dev/null
+++ b/dev-php/pecl-inotify/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <maintainer>
+ <email>arnaud.lb@gmail.com</email>
+ <name>Arnaud Le Blanc</name>
+ </maintainer>
+ <bugs-to>https://bugs.php.net/report.php?package=inotify</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/pecl-inotify/pecl-inotify-2.0.0.ebuild b/dev-php/pecl-inotify/pecl-inotify-2.0.0.ebuild
new file mode 100644
index 000000000..dca262b8e
--- /dev/null
+++ b/dev-php/pecl-inotify/pecl-inotify-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="inotify"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_PECL_FILENAME="inotify-${PV}.tgz"
+
+USE_PHP="php7-2 php7-3"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="Inotify binding for PHP"
+HOMEPAGE="https://pecl.php.net/package/inotify"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""