aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-07-30 15:11:22 +0200
committerDavid Roman <davidroman96@gmail.com>2024-07-30 15:11:22 +0200
commit7e6f7cc5afd05992a94dead5c3e3e0cf77d079c8 (patch)
tree933a3c794c36143695f9673fdd4fe35a3ac88195 /dev-python
parentdev-embedded/esp-idf: add patch for invalid type conversion error (diff)
downloadguru-7e6f7cc5afd05992a94dead5c3e3e0cf77d079c8.tar.gz
guru-7e6f7cc5afd05992a94dead5c3e3e0cf77d079c8.tar.bz2
guru-7e6f7cc5afd05992a94dead5c3e3e0cf77d079c8.zip
dev-python/python-socketio: add 5.11.3
Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-socketio/Manifest1
-rw-r--r--dev-python/python-socketio/python-socketio-5.11.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-socketio/Manifest b/dev-python/python-socketio/Manifest
index 49ae479545..fbb3d4d18d 100644
--- a/dev-python/python-socketio/Manifest
+++ b/dev-python/python-socketio/Manifest
@@ -1,2 +1,3 @@
DIST python-socketio-5.11.0.tar.gz 116482 BLAKE2B b55aec3c18d5313a82d6d430158fbe7e955295d36a363d4072c76cff71596e8b3e805e7a571fac343258a8576501f1f25fe92c5bf1aaffcc7272b4dea7cac2c2 SHA512 ed2068812cb7d2e74dcf9ff15a9c9b957ac07369f786a6db67d78286f0c49a7b860c5356040d405d50351c0ae49cf4f939f106d796a614c45743df1220a9b575
DIST python-socketio-5.11.1.tar.gz 116661 BLAKE2B baadab35001cb8b5b45af302787aef2eaf1b01f29590c91d0797ce597e0bd8e55ae1c7277bbd852157faa3677e10f0022245d1d1e75c859358fa6cf9ff9ae687 SHA512 95fbaac7040e53975c68b94cc47dad58bc4b5f19138560b3b48e5c44ddef66459a8fc2277958c738f7f85ba159c54ba4e2eea93d05f35e74a5a71c9901584dc8
+DIST python_socketio-5.11.3.tar.gz 117702 BLAKE2B 304747caec9933fc9b20287e049d4d964ad50efe6aeaf7cc5900892252d55ef20aebc92154f811f99304e775b8f90dc0e95726dc85cb6afc246969a1d37cbef2 SHA512 136e2e49eacb1b8ab2726487fd53a486fdb12f2803112b69017128dc3ecb6d1cbf9360da8e6b30fe1967a8d8a0c0d2fe0d305428a9e5b9bd3a0dc660406ae799
diff --git a/dev-python/python-socketio/python-socketio-5.11.3.ebuild b/dev-python/python-socketio/python-socketio-5.11.3.ebuild
new file mode 100644
index 0000000000..709d804706
--- /dev/null
+++ b/dev-python/python-socketio/python-socketio-5.11.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10,11,12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python implementation of the Socket.IO realtime server."
+HOMEPAGE="
+ https://python-socketio.readthedocs.org/
+ https://github.com/miguelgrinberg/python-socketio/
+ https://pypi.org/project/python-socketio"
+
+LICENSE="MIT"
+SLOT="0"
+#wait for dev-python/python-engineio
+KEYWORDS="~amd64"
+IUSE="client asyncio-client"
+
+RDEPEND="dev-python/bidict[${PYTHON_USEDEP}]
+ >=dev-python/python-engineio-4.0.0[${PYTHON_USEDEP}]
+ client? ( dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}] )
+ asyncio-client? ( dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# pypi tarball does not contain tests
+RESTRICT="test"