aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-05-21 17:27:07 -0400
committerJulien Roy <julien@jroy.ca>2024-05-21 17:29:23 -0400
commit5886ae85c96e0eadfc074ebd27fc65f52e887bf1 (patch)
tree8514ff03e088e4fc2a83f12c9e553acd4a1ce318 /games-emulation
parentdev-cpp/easyloggingpp: treeclean (diff)
downloadguru-5886ae85c96e0eadfc074ebd27fc65f52e887bf1.tar.gz
guru-5886ae85c96e0eadfc074ebd27fc65f52e887bf1.tar.bz2
guru-5886ae85c96e0eadfc074ebd27fc65f52e887bf1.zip
games-emulation/flycast: treeclean
Bug: https://bugs.gentoo.org/926271 Bug: https://bugs.gentoo.org/924444 Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/flycast/flycast-9999.ebuild112
-rw-r--r--games-emulation/flycast/metadata.xml14
2 files changed, 0 insertions, 126 deletions
diff --git a/games-emulation/flycast/flycast-9999.ebuild b/games-emulation/flycast/flycast-9999.ebuild
deleted file mode 100644
index 3cea66b7a..000000000
--- a/games-emulation/flycast/flycast-9999.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{3..4} )
-
-inherit cmake git-r3 lua-single xdg
-
-DESCRIPTION="Sega Dreamcast, Naomi and Atomiswave emulator"
-HOMEPAGE="https://github.com/flyinghead/flycast"
-EGIT_REPO_URI="https://github.com/flyinghead/flycast"
-EGIT_SUBMODULES=( 'core/deps/breakpad' 'core/deps/volk' 'core/deps/VulkanMemoryAllocator' )
-
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="alsa ao lua opengl +openmp pulseaudio vulkan"
-
-DEPEND="
- dev-libs/libchdr
- dev-libs/libzip
- dev-libs/xxhash
- media-libs/libsdl2
- net-libs/miniupnpc
- sys-libs/zlib
- alsa? ( media-libs/alsa-lib )
- ao? ( media-libs/libao )
- lua? ( ${LUA_DEPS} )
- opengl? ( virtual/opengl )
- openmp? ( sys-devel/gcc:*[openmp] )
- pulseaudio? ( media-libs/libpulse )
- vulkan? (
- >=dev-util/glslang-1.3.231
- dev-util/spirv-headers
- )
-"
-RDEPEND="${DEPEND}"
-
-REQUIRED_USE="|| ( opengl vulkan ) || ( ao alsa pulseaudio )"
-
-src_unpack() {
- use lua && EGIT_SUBMODULES+=( 'core/deps/luabridge' )
- git-r3_src_unpack
-}
-src_prepare() {
- # Ensure unneeded deps are not bundled
- for dep in chdr dirent glslang libretro-common libzip miniupnpc oboe patches SDL vixl xxHash; do
- rm -rf core/deps/${dep}
- done
-
- # Skip alsa if flag not enabled
- use !alsa && sed -i -e '/find_package(ALSA)/d' CMakeLists.txt
-
- # Skip ao if flag not enabled
- use !ao && sed -i -e '/pkg_check_modules(AO/d' CMakeLists.txt
-
- # Skip lua if flag not enabled
- use !lua && sed -i -e '/find_package(Lua)/d' CMakeLists.txt
-
- # Skip pulseaudio if flag not enabled
- use !pulseaudio && sed -i -e '/pkg_check_modules(LIBPULSE/d' CMakeLists.txt
-
- # Unbundle glslang
- sed -i -e '/add_subdirectory(core\/deps\/glslang/{N;s/.*/find_library(GLSLANG libglslang.so)\nfind_library(SPIRV libSPIRV.so)\ntarget_link_libraries(${PROJECT_NAME} PRIVATE ${GLSLANG} ${SPIRV})/}' CMakeLists.txt || die
- sed -i -e '/include.*SPIRV/{s:":<glslang/:;s/"/>/}' core/rend/vulkan/shaders.h \
- core/rend/vulkan/compiler.cpp || die
- # Crazy commit fix: 8d0654c
- sed -i -e '/maxMeshViewCountNV/a256,256,128,128,128,128,128,128,4,' \
- core/rend/vulkan/compiler.cpp || die
-
- # Unbundle xxHash
- sed -i -e '/XXHASH_BUILD_XXHSUM/{N;N;s/.*/target_link_libraries(${PROJECT_NAME} PRIVATE xxhash)/}' \
- CMakeLists.txt || die
-
- # Unbundle chdr
- sed -i -e '/add_subdirectory.*chdr/d' -e 's/chdr-static/chdr/' \
- -e 's:core/deps/chdr/include:/usr/include/chdr:' CMakeLists.txt || die
-
- # Do not use ccache
- sed -i -e '/find_program(CCACHE_FOUND/d' CMakeLists.txt
-
- # Ensure static libs are not built
- sed -i -e '/BUILD_SHARED_LIBS/d' CMakeLists.txt
-
- # Vulkan-header
- sed -i -e '/add_subdirectory(core.*Vulkan-Headers)$/,/Vulkan::Headers/d' \
- -e '/core\/deps\/Vulkan-Headers\/include)/d' CMakeLists.txt
- sed -i -e 's:SPIRV/GlslangToSpv.h:glslang/&:' core/rend/vulkan/compiler.cpp
- if use vulkan; then
- sed -i -e '$atarget_link_libraries(${PROJECT_NAME} PRIVATE glslang-default-resource-limits)' CMakeLists.txt
- fi
-
- # Do not use ccache
- sed -i -e '/find_program(CCACHE_PROGRAM ccache)/d' CMakeLists.txt
-
- # Revert crazy commit: #4408aa7
- sed -i -e '/if(NOT APPLE AND (/s/.*/if( NOT APPLE )/' CMakeLists.txt
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_OPENGL=$(usex opengl)
- -DUSE_OPENMP=$(usex openmp)
- -DUSE_VULKAN=$(usex vulkan)
- -DUSE_HOST_LIBZIP=ON
- -DWITH_SYSTEM_ZLIB=ON
- )
- cmake_src_configure
-}
diff --git a/games-emulation/flycast/metadata.xml b/games-emulation/flycast/metadata.xml
deleted file mode 100644
index 524f53682..000000000
--- a/games-emulation/flycast/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
- <name>mazes-80</name>
- <email>samuel.bauer@yahoo.fr</email>
-</maintainer>
-<use>
- <flag name="vulkan">Compile vulkan backend</flag>
-</use>
-<upstream>
- <remote-id type="github">flyinghead/flycast</remote-id>
-</upstream>
-</pkgmetadata>