aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDale Showers <gentoo@fictx.com>2024-02-16 21:43:32 -0500
committerDale Showers <gentoo@fictx.com>2024-02-16 21:44:39 -0500
commit1626d08afc391835d5027686855e2e002d203d77 (patch)
tree7a203037edd45f2384853fc38498d251bd85d046 /net-voip
parentmpv-plugin/mpv_sponsorblock_minimal: update snapshot (diff)
downloadguru-1626d08afc391835d5027686855e2e002d203d77.tar.gz
guru-1626d08afc391835d5027686855e2e002d203d77.tar.bz2
guru-1626d08afc391835d5027686855e2e002d203d77.zip
net-voip/*: add baresip & re
Signed-off-by: Dale Showers <gentoo@fictx.com>
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/baresip/Manifest3
-rw-r--r--net-voip/baresip/baresip-3.7.0.ebuild53
-rw-r--r--net-voip/baresip/baresip-3.8.0.ebuild53
-rw-r--r--net-voip/baresip/baresip-3.9.0.ebuild53
-rw-r--r--net-voip/baresip/metadata.xml27
-rw-r--r--net-voip/re/Manifest3
-rw-r--r--net-voip/re/metadata.xml14
-rw-r--r--net-voip/re/re-3.7.0.ebuild14
-rw-r--r--net-voip/re/re-3.8.0.ebuild14
-rw-r--r--net-voip/re/re-3.9.0.ebuild14
10 files changed, 248 insertions, 0 deletions
diff --git a/net-voip/baresip/Manifest b/net-voip/baresip/Manifest
new file mode 100644
index 000000000..4564890f9
--- /dev/null
+++ b/net-voip/baresip/Manifest
@@ -0,0 +1,3 @@
+DIST baresip-3.7.0.tar.gz 1156270 BLAKE2B 48d9f2762739f023dfe8597921de1bfcd355ce4d6e403a77c6fd2f95a88970538208e5aae5f2cd2ed98767f5b1c17e0740f3298faaf7056cd7e89906e22d67b8 SHA512 f3497a903fa67c8ecfb90cd63f9f2bdc376d98ea28a71ea64b042b3641628126fac5ff8afe8539f98f51a54aa4ef1304d22c0b83edc3e91767f8bf35310621c3
+DIST baresip-3.8.0.tar.gz 1158645 BLAKE2B e7badad42dde5e0cbd0fa090654b6559f7cf2f6c1dcc458290a43c72b26b0aa2fe40c92f4335ed72c4a2f85ec20d9bfb45f8059bc179cbd47b26867bf7612ccf SHA512 12ff9aaedcc3bc19a38235f5abc955aa1a64db47827895b95ca55329cb29acef353ee0871e888f12f0a9ea5a2ac0b3a34c278115c05e9f55d055638b5e13f852
+DIST baresip-3.9.0.tar.gz 1163327 BLAKE2B c994a6ca16610936887f9bfbfb776e155ad9418fb46387af899044e8237e1e7662e62b697408c7c0a47849bbc8ce078122b9290afd868aa9974ad50c9a7b68dd SHA512 7e6bf2c68ae4dec60da7692527d511b7acf373e14c67c96591b7a5e02af7275ff7adde8a8c07af6ed98474b87357b734aae17fb337d4fad8353c253de56dc534
diff --git a/net-voip/baresip/baresip-3.7.0.ebuild b/net-voip/baresip/baresip-3.7.0.ebuild
new file mode 100644
index 000000000..d1e006f92
--- /dev/null
+++ b/net-voip/baresip/baresip-3.7.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Baresip is a portable and modular SIP User-Agent"
+HOMEPAGE="https://github.com/baresip/baresip"
+SRC_URI="https://github.com/baresip/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"
+
+IUSE="aac alsa amr aptx aom codec2 ffmpeg gst gtk3 jack mqtt mpa opus ssl png portaudio pulseaudio pipewire sdl sndfile spandsp vpx X"
+
+DEPEND="
+ ~net-voip/re-${PV}
+ aac? ( media-libs/fdk-aac )
+ alsa? ( media-libs/alsa-lib )
+ amr? ( media-libs/opencore-amr )
+ aptx? ( media-libs/libopenaptx )
+ aom? ( media-libs/libaom )
+ codec2? ( media-libs/codec2 )
+ ffmpeg? ( media-video/ffmpeg )
+ gst? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ )
+ gtk3? ( x11-libs/gtk+:3 )
+ jack? ( virtual/jack )
+ mqtt? ( app-misc/mosquitto )
+ mpa? (
+ media-sound/twolame
+ media-sound/mpg123
+ media-libs/speexdsp
+ )
+ ssl? ( dev-libs/openssl:0= )
+ opus? ( media-libs/opus )
+ png? ( media-libs/libpng )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-libs/libpulse )
+ pipewire? ( media-video/pipewire )
+ sdl? ( media-libs/libsdl2 )
+ sndfile? ( media-libs/libsndfile )
+ spandsp? ( media-libs/spandsp )
+ vpx? ( media-libs/libvpx )
+ X? ( x11-libs/libX11 )
+ "
+
+RDEPEND="${DEPEND}"
diff --git a/net-voip/baresip/baresip-3.8.0.ebuild b/net-voip/baresip/baresip-3.8.0.ebuild
new file mode 100644
index 000000000..d1e006f92
--- /dev/null
+++ b/net-voip/baresip/baresip-3.8.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Baresip is a portable and modular SIP User-Agent"
+HOMEPAGE="https://github.com/baresip/baresip"
+SRC_URI="https://github.com/baresip/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"
+
+IUSE="aac alsa amr aptx aom codec2 ffmpeg gst gtk3 jack mqtt mpa opus ssl png portaudio pulseaudio pipewire sdl sndfile spandsp vpx X"
+
+DEPEND="
+ ~net-voip/re-${PV}
+ aac? ( media-libs/fdk-aac )
+ alsa? ( media-libs/alsa-lib )
+ amr? ( media-libs/opencore-amr )
+ aptx? ( media-libs/libopenaptx )
+ aom? ( media-libs/libaom )
+ codec2? ( media-libs/codec2 )
+ ffmpeg? ( media-video/ffmpeg )
+ gst? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ )
+ gtk3? ( x11-libs/gtk+:3 )
+ jack? ( virtual/jack )
+ mqtt? ( app-misc/mosquitto )
+ mpa? (
+ media-sound/twolame
+ media-sound/mpg123
+ media-libs/speexdsp
+ )
+ ssl? ( dev-libs/openssl:0= )
+ opus? ( media-libs/opus )
+ png? ( media-libs/libpng )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-libs/libpulse )
+ pipewire? ( media-video/pipewire )
+ sdl? ( media-libs/libsdl2 )
+ sndfile? ( media-libs/libsndfile )
+ spandsp? ( media-libs/spandsp )
+ vpx? ( media-libs/libvpx )
+ X? ( x11-libs/libX11 )
+ "
+
+RDEPEND="${DEPEND}"
diff --git a/net-voip/baresip/baresip-3.9.0.ebuild b/net-voip/baresip/baresip-3.9.0.ebuild
new file mode 100644
index 000000000..d1e006f92
--- /dev/null
+++ b/net-voip/baresip/baresip-3.9.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Baresip is a portable and modular SIP User-Agent"
+HOMEPAGE="https://github.com/baresip/baresip"
+SRC_URI="https://github.com/baresip/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"
+
+IUSE="aac alsa amr aptx aom codec2 ffmpeg gst gtk3 jack mqtt mpa opus ssl png portaudio pulseaudio pipewire sdl sndfile spandsp vpx X"
+
+DEPEND="
+ ~net-voip/re-${PV}
+ aac? ( media-libs/fdk-aac )
+ alsa? ( media-libs/alsa-lib )
+ amr? ( media-libs/opencore-amr )
+ aptx? ( media-libs/libopenaptx )
+ aom? ( media-libs/libaom )
+ codec2? ( media-libs/codec2 )
+ ffmpeg? ( media-video/ffmpeg )
+ gst? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ )
+ gtk3? ( x11-libs/gtk+:3 )
+ jack? ( virtual/jack )
+ mqtt? ( app-misc/mosquitto )
+ mpa? (
+ media-sound/twolame
+ media-sound/mpg123
+ media-libs/speexdsp
+ )
+ ssl? ( dev-libs/openssl:0= )
+ opus? ( media-libs/opus )
+ png? ( media-libs/libpng )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-libs/libpulse )
+ pipewire? ( media-video/pipewire )
+ sdl? ( media-libs/libsdl2 )
+ sndfile? ( media-libs/libsndfile )
+ spandsp? ( media-libs/spandsp )
+ vpx? ( media-libs/libvpx )
+ X? ( x11-libs/libX11 )
+ "
+
+RDEPEND="${DEPEND}"
diff --git a/net-voip/baresip/metadata.xml b/net-voip/baresip/metadata.xml
new file mode 100644
index 000000000..8dfef061a
--- /dev/null
+++ b/net-voip/baresip/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@fictx.com</email>
+ <name>Dale Showers</name>
+ </maintainer>
+ <use>
+ <flag name="amr">Enables Adaptive Multi-Rate Audio support</flag>
+ <flag name="aptx">Audio Processing Technology codec (aptX)</flag>
+ <flag name="aom">av1 module</flag>
+ <flag name="codec2">CODEC2 low-bitrate speech audio codec</flag>
+ <flag name="gst">Support for video (media-libs/gstreamer)</flag>
+ <flag name="gtk3">gtk+ user interface</flag>
+ <flag name="mqtt">Enable mqtt support via <pkg>app-misc/mosquitto</pkg></flag>
+ <flag name="mpa">MPA Speech and Audio Codec</flag>
+ <flag name="pipewire">Enable pipewire audio support</flag>
+ <flag name="spandsp">Use <pkg>media-libs/spandsp</pkg> for for G.722 and G.726 codec support</flag>
+ <flag name="vpx">Enables VP8 and VP9 codec support using libvpx</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">baresip/baresip</remote-id>
+ <bugs-to>https://github.com/baresip/baresip/issues</bugs-to>
+ <doc>https://github.com/baresip/baresip/wiki</doc>
+ <changelog>https://github.com/baresip/baresip/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/net-voip/re/Manifest b/net-voip/re/Manifest
new file mode 100644
index 000000000..f467f3591
--- /dev/null
+++ b/net-voip/re/Manifest
@@ -0,0 +1,3 @@
+DIST re-3.7.0.tar.gz 594129 BLAKE2B 8ca8656013505fe1c72a042e1070e60b923764eafc97089776bef9a4f37f545a320354681f734da57334e30b1a49c77595c142ae947eb3b35708a8d19109d5ac SHA512 95bfc11d73e8eda76ece51b0e91550e3cb45fc91927d01d024318e74bb0c3893b5bb0716582672490e0131be0314abd1bf2dfd815960b00741e78a55b2a0bbd4
+DIST re-3.8.0.tar.gz 595601 BLAKE2B 1df140f712e4fdcaae2cb6cb6e9050af58c1f2cb8dbebcdc5ee808b3b2f23d6b40c6f9070b2c96308ad5d4cfa3cd1c0f04b952623351a874a8c092ab0b101a65 SHA512 7c03502aae0424bb05e03320c2497de0ec534d872334fe16ec0a688efbc1cc493ad1774e9802e0dc58bb396b4b8a065f3e338deeff4dd1ddd87cb76793e82306
+DIST re-3.9.0.tar.gz 598561 BLAKE2B 785b91f5f87d6d4dd4a4a4856a1f6e45d1a741d185d47c27375a3c22c8f7dc0e71271556e88af9865b005cb1ab08d1c87a8c2b081f65729dfcadc29ec9a5d4e9 SHA512 d19fc5c48399ad4942c27d86c47350f579f8ebeaf8dc04b13a930b930c13a20e5e7dd5f0fe05d11b6b365667d8306f2499f5cb925850f4484049ba853d36b0b1
diff --git a/net-voip/re/metadata.xml b/net-voip/re/metadata.xml
new file mode 100644
index 000000000..e5a024ce5
--- /dev/null
+++ b/net-voip/re/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@fictx.com</email>
+ <name>Dale Showers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">baresip/re</remote-id>
+ <bugs-to>https://github.com/baresip/re/issues</bugs-to>
+ <doc>https://github.com/baresip/re/wiki</doc>
+ <changelog>https://github.com/baresip/re/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/net-voip/re/re-3.7.0.ebuild b/net-voip/re/re-3.7.0.ebuild
new file mode 100644
index 000000000..dd6abc01c
--- /dev/null
+++ b/net-voip/re/re-3.7.0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Generic library for real-time communications with async IO support"
+HOMEPAGE="https://github.com/baresip/re"
+SRC_URI="https://github.com/baresip/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"
diff --git a/net-voip/re/re-3.8.0.ebuild b/net-voip/re/re-3.8.0.ebuild
new file mode 100644
index 000000000..dd6abc01c
--- /dev/null
+++ b/net-voip/re/re-3.8.0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Generic library for real-time communications with async IO support"
+HOMEPAGE="https://github.com/baresip/re"
+SRC_URI="https://github.com/baresip/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"
diff --git a/net-voip/re/re-3.9.0.ebuild b/net-voip/re/re-3.9.0.ebuild
new file mode 100644
index 000000000..dd6abc01c
--- /dev/null
+++ b/net-voip/re/re-3.9.0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Generic library for real-time communications with async IO support"
+HOMEPAGE="https://github.com/baresip/re"
+SRC_URI="https://github.com/baresip/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"