aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-10-11 02:02:56 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-10-11 02:02:56 +0500
commit4e094406d554b1c8240a662ed0e8afa1f09cd9d1 (patch)
treec772f6a119d0a3d60dd79f9b32be7c8337a26ef5 /sci-misc
parentmedia-plugins/gst-plugins-qt6: fix deps (diff)
downloadguru-4e094406d554b1c8240a662ed0e8afa1f09cd9d1.tar.gz
guru-4e094406d554b1c8240a662ed0e8afa1f09cd9d1.tar.bz2
guru-4e094406d554b1c8240a662ed0e8afa1f09cd9d1.zip
sci-misc/boinc-wrapper: fix cflags
Also don't link C++ stdlib statically and mark implicit decls. Closes: https://bugs.gentoo.org/887995 Closes: https://bugs.gentoo.org/904138 Closes: https://bugs.gentoo.org/922046 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc-wrapper/boinc-wrapper-26018-r3.ebuild (renamed from sci-misc/boinc-wrapper/boinc-wrapper-26018-r1.ebuild)36
-rw-r--r--sci-misc/boinc-wrapper/files/boinc-wrapper-26018-makefile.patch13
2 files changed, 39 insertions, 10 deletions
diff --git a/sci-misc/boinc-wrapper/boinc-wrapper-26018-r1.ebuild b/sci-misc/boinc-wrapper/boinc-wrapper-26018-r3.ebuild
index e388e52a2..f065fe7a5 100644
--- a/sci-misc/boinc-wrapper/boinc-wrapper-26018-r1.ebuild
+++ b/sci-misc/boinc-wrapper/boinc-wrapper-26018-r3.ebuild
@@ -13,16 +13,18 @@ LICENSE="Info-ZIP LGPL-3+ regexp-UofT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
-# libboinc-api dependencies
-# no subslot, because "-Wl,--as-needed" removes them
-DEPEND="
- dev-libs/openssl
- media-libs/freeglut
- media-libs/libjpeg-turbo
-"
-
DOCS=( job.xml )
+PATCHES=(
+ "${FILESDIR}"/${PN}-26018-makefile.patch
+ "${FILESDIR}"/${PN}-26018-sigstop.patch
+)
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # https://bugs.gentoo.org/922046
+ "_mm*"
+)
+
src_prepare() {
default
eautoreconf
@@ -30,12 +32,26 @@ src_prepare() {
src_configure() {
edo bash generate_svn_version.sh
- econf --enable-static --enable-pkg-devel --disable-fcgi
+
+ local myeconfargs=(
+ # build libraries only
+ --enable-pkg-devel
+ --disable-fcgi
+
+ # link with libboinc_api statically
+ --disable-shared
+ --enable-static
+
+ # do not build libboinc_graphics
+ --without-x
+ ax_cv_check_gl_libgl=no
+ )
+ econf "${myeconfargs[@]}"
}
src_compile() {
emake
- emake -C samples/wrapper
+ emake -C samples/wrapper MAKEFILE_LDFLAGS="-lpthread" MAKEFILE_STDLIB=
}
src_install() {
diff --git a/sci-misc/boinc-wrapper/files/boinc-wrapper-26018-makefile.patch b/sci-misc/boinc-wrapper/files/boinc-wrapper-26018-makefile.patch
new file mode 100644
index 000000000..c1329d6b1
--- /dev/null
+++ b/sci-misc/boinc-wrapper/files/boinc-wrapper-26018-makefile.patch
@@ -0,0 +1,13 @@
+Bug: https://bugs.gentoo.org/904138
+
+--- a/samples/wrapper/Makefile
++++ b/samples/wrapper/Makefile
+@@ -22,7 +22,7 @@ else
+ MAKEFILE_STDLIB = libstdc++.a
+ endif
+
+-CXXFLAGS += -g -O0 \
++CXXFLAGS += \
+ -Wall -W -Wshadow -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -fno-common \
+ -I$(BOINC_DIR) \
+ -I$(BOINC_LIB_DIR) \