aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-10 06:42:48 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-10 06:42:48 +0200
commite301fd9bf24d85f34d3371178ed682ab036a9d37 (patch)
treee5db1c9d9f12771d2ab707801017165550b5c879 /sci-misc
parentsys-cluster/OpenHPC-meta: add scorep (diff)
downloadguru-e301fd9bf24d85f34d3371178ed682ab036a9d37.tar.gz
guru-e301fd9bf24d85f34d3371178ed682ab036a9d37.tar.bz2
guru-e301fd9bf24d85f34d3371178ed682ab036a9d37.zip
sci-misc/linuxcnc: update EAPI 7 -> 8
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/linuxcnc/linuxcnc-9999.ebuild141
-rw-r--r--sci-misc/linuxcnc/metadata.xml21
2 files changed, 81 insertions, 81 deletions
diff --git a/sci-misc/linuxcnc/linuxcnc-9999.ebuild b/sci-misc/linuxcnc/linuxcnc-9999.ebuild
index 00d229f69..6166db984 100644
--- a/sci-misc/linuxcnc/linuxcnc-9999.ebuild
+++ b/sci-misc/linuxcnc/linuxcnc-9999.ebuild
@@ -1,101 +1,101 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-# Thanks to the original author's code, slis@gentoo.org's code, because the original code is outdated, this ebuild has been modified portably
-EAPI="7"
+EAPI=8
PYTHON_COMPAT=( python3_10 )
+PYTHON_REQUIRED_USE="tk"
-inherit autotools eutils flag-o-matic multilib python-single-r1 git-r3
+inherit autotools desktop git-r3 python-single-r1
-DESCRIPTION="LinuxCNC "
+DESCRIPTION="LinuxCNC"
HOMEPAGE="http://linuxcnc.org/"
#SRC_URI="mirror://sourceforge/gentoocnc/distfiles/${P}.tar.gz"
#SRC_URI="https://github.com/LinuxCNC/linuxcnc/archive/2.7.zip"
EGIT_REPO_URI="https://github.com/LinuxCNC/linuxcnc.git https://gitclone.com/github.com/LinuxCNC/linuxcnc.git"
-
S="${WORKDIR}"/linuxcnc-9999/src
LICENSE="LGPL-3"
-SLOT="linuxcnc-9999"
-KEYWORDS="~amd64 ~x86"
-IUSE="+python +uspace +X +gtk -rt gstreamer modbus simulator usb"
+SLOT="9999"
+KEYWORDS=""
+IUSE="+gtk modbus rt simulator usb +X"
# TODO: add shmdrv use flag
-# --disable-python uses python anyways and fails so python is a required use flag
-REQUIRED_USE="
- python
- python? ( ${PYTHON_REQUIRED_USE} )
- rt? ( !simulator )
- "
+DEPEND="
+ ${PYTHON_DEPS}
-DEPEND="dev-lang/tcl
+ dev-lang/tcl
dev-lang/tk
- dev-tcltk/tkimg
+ dev-tcltk/bwidget
dev-tcltk/tclx
- dev-libs/boost[python]
+ dev-tcltk/tkimg
+ media-gfx/graphviz
+ media-libs/mesa
+ net-firewall/iptables
+ sys-devel/gettext
+ sys-process/procps
+ sys-process/psmisc
+ x11-libs/libXinerama
+ x11-apps/mesa-progs
+ virtual/glu
+ virtual/opengl
+
+ $(python_gen_cond_dep '
+ dev-libs/boost[python,${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[tk,${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ ')
+
+ || (
+ net-analyzer/openbsd-netcat
+ net-analyzer/netcat
+ )
+
modbus? ( <dev-libs/libmodbus-3.1 )
- dev-tcltk/bwidget
gtk? ( x11-libs/gtk+ )
- gstreamer? (
- dev-python/gst-python:0.10
- media-libs/gst-plugins-base:0.10
- )
- || (
- net-analyzer/openbsd-netcat
- net-analyzer/netcat6
- )
- x11-libs/libXinerama
+ rt? ( sys-kernel/rt-sources )
usb? ( virtual/libusb )
- dev-lang/python:3.10[tk]
- $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]')
- $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]')
- $(python_gen_cond_dep 'dev-python/configobj[${PYTHON_USEDEP}]')
- $(python_gen_cond_dep 'dev-python/pillow[tk,${PYTHON_USEDEP}]')
- media-libs/mesa
- x11-apps/mesa-progs
X? (
- x11-libs/libXaw
- $(python_gen_cond_dep 'dev-python/python-xlib[${PYTHON_USEDEP}]')
- )
- rt? ( sys-kernel/rt-sources )
- virtual/opengl
- virtual/glu
- ${PYTHON_DEPS}
- sys-devel/gettext
- sys-process/procps
- sys-process/psmisc
- net-firewall/iptables
- media-gfx/graphviz
- $(python_gen_cond_dep 'dev-python/pyopengl[${PYTHON_USEDEP}]')
- $(python_gen_cond_dep 'dev-python/pygobject[${PYTHON_USEDEP}]')
- x11-libs/gtksourceview:3.0
+ x11-libs/libXaw
+ $(python_gen_cond_dep 'dev-python/python-xlib[${PYTHON_USEDEP}]')
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep 'dev-python/yapps[${PYTHON_USEDEP}]')
+"
+
+RESTRICT="bindist"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ rt? ( !simulator )
"
-RDEPEND="${DEPEND}
- python? ( dev-python/yapps )"
src_prepare() {
- default
- eautoreconf
+ default
+ eautoreconf
}
src_configure() {
- #myconf="--prefix=${EPREFIX}/usr --with-kernel-headers=/usr/src/linux/ $(use_with modbus libmodbus)"
- myconf="--prefix=${EPREFIX}/usr --enable-non-distributable=yes --with-boost-python=boost_python310 $(use_with modbus libmodbus)"
-
- use !gtk && myconf="${myconf} --disable-gtk"
- use rt && myconf="${myconf} --with-realtime=uspace"
- use simulator && myconf="${myconf} --with-realtime=uspace"
- use !usb && myconf="${myconf} --without-libusb-1.0"
-# use rtai && myconf="${myconf} --with-realtime=${EPREFIX}/usr/realtime --with-module-dir=${EPREFIX}/usr/lib/linuxcnc/rtai/"
- use X && myconf="${myconf} --with-x"
-
- # TODO: fix that - get python version
- #use python && myconf="${myconf} --with-python=/usr/bin/python3.10"
- use !python && myconf="${myconf} --disable-python"
-
- econf ${myconf}
+ local myconf=(
+ --enable-non-distributable=yes
+ --with-boost-python=boost_python310
+ --with-kernel-headers=/usr/src/linux/
+ --with-python="${PYTHON}"
+ $(use_with modbus libmodbus)
+ )
+ use gtk || myconf+=( "--disable-gtk" )
+ use rt && myconf+=( "--with-rt-preempt" )
+ use simulator && myconf+=( "--with-realtime=uspace" )
+ use usb || myconf+=( "--without-libusb-1.0" )
+# use rtai && myconf+=( "--with-realtime=${EPREFIX}/usr/realtime" "--with-module-dir=${EPREFIX}/usr/$(get_libdir)/linuxcnc/rtai/" )
+ use X && myconf+=( "--with-x" )
+
+ econf "${myconf[@]}"
}
src_install() {
@@ -121,7 +121,6 @@ src_install() {
}
pkg_postinst() {
- elog "The compiled software may not be redistributed due to use of packages with incompatible licenses."
elog "Opening machine configuration files from older Versions can crash the application as it cannot load old named modules, e.g. probe_parport.so not found"
elog "This is not a Gentoo- or build related error. It looks like linuxcnc 2.8 will have some kind of converter for them."
elog "If you created them with stepconf. You can just open the stepconf file and create them new. Don't forget to backup any manual changes (e.g. backlash!) from the .hal and .ini files and make them again."
diff --git a/sci-misc/linuxcnc/metadata.xml b/sci-misc/linuxcnc/metadata.xml
index 49ea295fe..f993765d6 100644
--- a/sci-misc/linuxcnc/metadata.xml
+++ b/sci-misc/linuxcnc/metadata.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>jack9603301@163.com</email>
- </maintainer>
- <use>
- <flag name="rt">Build with RT_PREEMPT threads modules</flag>
- <flag name="simulator">Build with posix threads (no realtime)</flag>
- <flag name="modbus">Build modbus libraries</flag>
- <flag name="xenomai">Build with xenomai userland threads</flag>
- <flag name="rtai">Build with realtime threads support</flag>
- </use>
+ <maintainer type="person">
+ <email>jack9603301@163.com</email>
+ <name>Chunhui Ouyang</name>
+ </maintainer>
+ <use>
+ <flag name="rt">Build with RT_PREEMPT threads modules</flag>
+ <flag name="simulator">Build with posix threads (no realtime)</flag>
+ <flag name="modbus">Build modbus libraries</flag>
+ <!--<flag name="xenomai">Build with xenomai userland threads</flag>-->
+ <!--<flag name="rtai">Build with realtime threads support</flag>-->
+ </use>
</pkgmetadata>