aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZen <z@pyl.onl>2024-04-29 20:32:05 -0500
committerZen <z@pyl.onl>2024-04-29 20:32:05 -0500
commit239efc4602ff69f5e2ccb788b49967fbf53821cd (patch)
tree407ed11b74aa53087436d4f06432b6b90554f07c /sys-kernel
parentdev-python/zenlib: Bump to 2.0.4 (diff)
downloadguru-239efc4602ff69f5e2ccb788b49967fbf53821cd.tar.gz
guru-239efc4602ff69f5e2ccb788b49967fbf53821cd.tar.bz2
guru-239efc4602ff69f5e2ccb788b49967fbf53821cd.zip
sys-kernel/ugrd: Add 1.2.0
Signed-off-by: Zen <z@pyl.onl>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ugrd/Manifest1
-rw-r--r--sys-kernel/ugrd/ugrd-1.2.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-kernel/ugrd/Manifest b/sys-kernel/ugrd/Manifest
index 86271c44c..803c2156f 100644
--- a/sys-kernel/ugrd/Manifest
+++ b/sys-kernel/ugrd/Manifest
@@ -6,3 +6,4 @@ DIST ugrd-0.21.2.tar.gz 44149 BLAKE2B 62d093a9ffcef8a963e6de81f630853d11c9e448fd
DIST ugrd-0.22.0.tar.gz 44444 BLAKE2B 01c4cc36ea778c12478b3b2f6db76180f9b7ef8d214b7cb2ab7579826f67d9166ac889ba17ae59819a3870cd2847b6ba4f8fff373dc670a4cde2a85dc60e2b67 SHA512 498b65070a83a810ec2c84bb58ca380f0836654f5ac2676bc358b5e80ea48057156102b3e1983695decdcffa64bd5bfe05df963d98342171c3e9c2906d9370da
DIST ugrd-1.0.0.tar.gz 46125 BLAKE2B 8f941f8cadcbfb92ad4be02ca5763779bcd57bdd3545a5526b642d288591ea76e6ffcd4e0962c9ac36ff31f177b4fd2ee7b5b3351147e9f1e0a1dc478da399e0 SHA512 f7629acdffb952f8b8c79969043574420cff821523c38627c4234d4ca0f93a38349f8acdf3a473bd5fd3f4854fd0b82bb4367e57b999674b8a550609a76330d3
DIST ugrd-1.1.5.tar.gz 47005 BLAKE2B 278831157c3f8b5d731f3acbdf41c19b1c6485b46acf7d2b75df40a9d9f542365514e814d1972a03bd4b53dad2d39a27098e4cfc97d526afdf4d45ccf5778691 SHA512 c198c592af40d2f126a333a03c74c638260ea8125f4a4da6f97d3489d2ddcf7edb5dce785eb236d309853dac6a3e7993186e4c6b775c4eccc121e95d308641dc
+DIST ugrd-1.2.0.tar.gz 48323 BLAKE2B 8df44c91dd56da6d27eaf2c769b40ad7a008a71a87f2f33d1ab91d96e16cf680bb046af27d0b50ae79d48ad8d5b046d899e246ca44c18e62dae8f54fff9cace6 SHA512 a3ddd95abd30441013c9a11074052629dfdbcd2cfffd6a754c6d9c3b719b1861abcd613228fa613b6f566ca1cdca5fa881c9a302391c594b53096428d35e37bf
diff --git a/sys-kernel/ugrd/ugrd-1.2.0.ebuild b/sys-kernel/ugrd/ugrd-1.2.0.ebuild
new file mode 100644
index 000000000..a474bbc7a
--- /dev/null
+++ b/sys-kernel/ugrd/ugrd-1.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python based initramfs generator with TOML defintions"
+HOMEPAGE="https://github.com/desultory/ugrd"
+SRC_URI="https://github.com/desultory/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-misc/pax-utils
+>=dev-python/zenlib-2.0.4[${PYTHON_USEDEP}]
+>=dev-python/pycpio-1.0.0[${PYTHON_USEDEP}]
+sys-apps/pciutils"
+
+src_install() {
+ # Call the distutils-r1_src_install function to install the package
+ distutils-r1_src_install
+ # Create the ugrd config directory
+ keepdir /etc/ugrd
+ # Install the example config into /etc/ugrd/config.toml
+ # Do not overwrite an existing config
+ insinto /etc/ugrd
+ newins examples/example.toml config.toml
+ # Create the kernel preinst.d directory if it doesn't exist
+ # Install the kernel preinst.d hook
+ keepdir /etc/kernel/preinst.d
+ exeinto /etc/kernel/preinst.d
+ doexe hooks/51-ugrd.install
+}
+
+pkg_postinst() {
+ optfeature "ugrd.crypto.cryptsetup support" sys-fs/cryptsetup
+ optfeature "ugrd.fs.btrfs support" sys-fs/btrfs-progs
+ optfeature "ugrd.crypto.gpg support" app-crypt/gnupg
+}