aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMazunki Hoksaas <rolferen@gmail.com>2024-08-01 04:43:27 +0200
committerMazunki Hoksaas <rolferen@gmail.com>2024-08-01 04:43:43 +0200
commit618d7043f476c4f758e26dd71435ab5e7e8a39ee (patch)
treeeec8d7f9772e4bad20540437f6433f6015aad0c2 /sys-power
parentsys-power/amdfan: drop 0.2.1-r2 (diff)
downloadguru-618d7043f476c4f758e26dd71435ab5e7e8a39ee.tar.gz
guru-618d7043f476c4f758e26dd71435ab5e7e8a39ee.tar.bz2
guru-618d7043f476c4f758e26dd71435ab5e7e8a39ee.zip
sys-power/amdfan: add 0.2.3
sorry for the delay Signed-off-by: Mazunki Hoksaas <rolferen@gmail.com>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/amdfan/Manifest1
-rw-r--r--sys-power/amdfan/amdfan-0.2.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-power/amdfan/Manifest b/sys-power/amdfan/Manifest
index dae0c403f..083226e29 100644
--- a/sys-power/amdfan/Manifest
+++ b/sys-power/amdfan/Manifest
@@ -1 +1,2 @@
DIST amdfan-0.1.28.tar.gz 81901 BLAKE2B 84e461a2f230e560c80badd99ec658774e5b46785a78387d6906d8ebe8a855f1e421a33872246af2a96ff06790615ad47a7d3d248e97a615c78a4ff9de8f641e SHA512 214b4940e747a8c8c0083d1cd90e78a3080e6b6b56031fff42f6bdca867e47ba81defb490e7704786f6e2a2c9634d990d53cbcfbc24c2c43d4ec9691023c06d8
+DIST amdfan-0.2.3.tar.gz 85434 BLAKE2B 092a0f4123bb6e81688855ec868ddad3c55eee543fd9b5c81f4e0363c3e244b16fc8f2c82d1461a8471fa3074dc6cb47a6220d6740aabfa514f849e9075dfcf2 SHA512 fa46e89df1ea26b5fc6eec7596c8fec3c7d41e602210fb1544ca468f958739a97010616f3cefc30134199d9355281a7b572252b5b360b79f0f0029d3a825d970
diff --git a/sys-power/amdfan/amdfan-0.2.3.ebuild b/sys-power/amdfan/amdfan-0.2.3.ebuild
new file mode 100644
index 000000000..ff0e02ac7
--- /dev/null
+++ b/sys-power/amdfan/amdfan-0.2.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+# shellcheck disable=2034
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1 systemd autotools
+
+DESCRIPTION="Updated AMD Fan control utility forked from amdgpu-fan and updated."
+HOMEPAGE="https://mcgillij.dev/pages/amdfan.html"
+SRC_URI="https://github.com/mcgillij/amdfan/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+"
+DEPEND="${PYTHON_DEPS}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DOCS=( README.md )
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # this sed isn't clean. i haven't used PATCHES for this, since we're
+ # hoping to find a better fix upstream. suggestions are welcome
+ #
+ # relevant discussion:
+ # https://github.com/mcgillij/amdfan/commit/529fd3d4#r144705633
+ sed -i '/^include = \["dist\/systemd\/amdfan.service"\]$/d' pyproject.toml || die
+
+ eautoreconf -vfi
+}
+
+src_configure() {
+ # i don't like hardcoding --bindir like this, but
+ # if i don't, i get ${exec_prefix}/bin instead of /usr/bin
+ #
+ # is there a better approach?
+ econf --bindir="${EPREFIX}"/usr/bin
+}
+
+src_install() {
+ newinitd dist/openrc/amdfan amdfan
+ systemd_dounit dist/systemd/amdfan.service
+
+ distutils-r1_src_install
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover tests || die
+}