aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-13 22:02:20 +0100
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-13 22:02:20 +0100
commitdbc963a54a2a269a523dbcad3e0b76b3703a3cf4 (patch)
tree8127e3287678b07da8c4f3be03152f8e98d2711a /sys-power
parentsys-power/nvidia-exec: add 0.1.1 (diff)
downloadguru-dbc963a54a2a269a523dbcad3e0b76b3703a3cf4.tar.gz
guru-dbc963a54a2a269a523dbcad3e0b76b3703a3cf4.tar.bz2
guru-dbc963a54a2a269a523dbcad3e0b76b3703a3cf4.zip
sys-power/envycontrol: new package, add 3.2.0, 9999
Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/envycontrol/Manifest1
-rw-r--r--sys-power/envycontrol/envycontrol-3.2.0.ebuild26
-rw-r--r--sys-power/envycontrol/envycontrol-9999.ebuild24
-rw-r--r--sys-power/envycontrol/metadata.xml7
4 files changed, 58 insertions, 0 deletions
diff --git a/sys-power/envycontrol/Manifest b/sys-power/envycontrol/Manifest
new file mode 100644
index 000000000..26d10a3c5
--- /dev/null
+++ b/sys-power/envycontrol/Manifest
@@ -0,0 +1 @@
+DIST v3.2.0.tar.gz 75600 BLAKE2B 8a6cd9c5a08299285a1994bca8a745fe070b4eebd11ebcf70566e797aad66c484918e93f39cad7a8411452ea125a5d5f6812c70c0adf201cf1b50c1e6d2ba91a SHA512 e54e297cc5bf4b3c63143c5aafd05fe9d80ebbec275cb671e0692bb855ab0312196ff74bb789e1902208251640f3a9c35e46dfb7354769169e4363e97e390c08
diff --git a/sys-power/envycontrol/envycontrol-3.2.0.ebuild b/sys-power/envycontrol/envycontrol-3.2.0.ebuild
new file mode 100644
index 000000000..2988f7496
--- /dev/null
+++ b/sys-power/envycontrol/envycontrol-3.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+SRC_URI="https://github.com/bayasdev/envycontrol/archive/refs/tags/v${PV}.tar.gz"
+DESCRIPTION="Easy GPU switching for Nvidia Optimus laptops under Linux "
+HOMEPAGE="https://github.com/bayasdev/envycontrol"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+}
diff --git a/sys-power/envycontrol/envycontrol-9999.ebuild b/sys-power/envycontrol/envycontrol-9999.ebuild
new file mode 100644
index 000000000..23f9d4b9d
--- /dev/null
+++ b/sys-power/envycontrol/envycontrol-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit git-r3 distutils-r1
+
+EGIT_REPO_URI="https://github.com/bayasdev/envycontrol.git"
+DESCRIPTION="Easy GPU switching for Nvidia Optimus laptops under Linux"
+HOMEPAGE="https://github.com/bayasdev/envycontrol"
+
+LICENSE="MIT"
+SLOT="0"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+}
diff --git a/sys-power/envycontrol/metadata.xml b/sys-power/envycontrol/metadata.xml
new file mode 100644
index 000000000..383164ce5
--- /dev/null
+++ b/sys-power/envycontrol/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">bayasdev/envycontrol</remote-id>
+ </upstream>
+</pkgmetadata>