aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMazunki Hoksaas <rolferen@gmail.com>2024-07-26 23:07:59 +0200
committerMazunki Hoksaas <rolferen@gmail.com>2024-07-26 23:09:39 +0200
commit2f7a18df29c0082bfef1b745a51b92e1f02e308e (patch)
tree83d16404ab5740b3617d5e8376a3343b722f3307 /sys-process
parentdev-vcs/lazygit: add 0.43.1 (diff)
downloadguru-2f7a18df29c0082bfef1b745a51b92e1f02e308e.tar.gz
guru-2f7a18df29c0082bfef1b745a51b92e1f02e308e.tar.bz2
guru-2f7a18df29c0082bfef1b745a51b92e1f02e308e.zip
sys-process/pipectl: new package, add 0.5.0
Signed-off-by: Mazunki Hoksaas <rolferen@gmail.com>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/pipectl/Manifest1
-rw-r--r--sys-process/pipectl/metadata.xml11
-rw-r--r--sys-process/pipectl/pipectl-0.5.0.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/sys-process/pipectl/Manifest b/sys-process/pipectl/Manifest
new file mode 100644
index 000000000..1f58a26a8
--- /dev/null
+++ b/sys-process/pipectl/Manifest
@@ -0,0 +1 @@
+DIST pipectl-0.5.0.tar.gz 18417 BLAKE2B 751e33df920aca92c1d4831c836d16625d9980351416ce32ab2571b0366562ad3194a75f42753008f2cf74fab5d860a4e4b38abffa8e87b6cf4ffd3e0b6210b8 SHA512 84caad4bee1cf831b631a9e1ccbf648c98f3e3cc5e2e0bee9fad5046804172de29e54406eb9e56d3741890a1273bf8f6e1520ca0a7a7ad7183c30ab5bd90e21d
diff --git a/sys-process/pipectl/metadata.xml b/sys-process/pipectl/metadata.xml
new file mode 100644
index 000000000..711aadf3e
--- /dev/null
+++ b/sys-process/pipectl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rolferen@gmail.com</email>
+ <name>Mazunki Hoksaas</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Ferdi265/pipectl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-process/pipectl/pipectl-0.5.0.ebuild b/sys-process/pipectl/pipectl-0.5.0.ebuild
new file mode 100644
index 000000000..330ad1f94
--- /dev/null
+++ b/sys-process/pipectl/pipectl-0.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="a simple named pipe management utility"
+HOMEPAGE="https://github.com/Ferdi265/pipectl"
+SRC_URI="https://github.com/Ferdi265/pipectl/releases/download/v${PV}/pipectl-${PV}.tar.gz"
+
+LICENSE="GPL-3.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="man"
+
+DEPEND="
+ man? (
+ app-text/scdoc
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex man)
+ -DINSTALL_DOCUMENTATION=$(usex man)
+ )
+
+ cmake_src_configure
+}
+