aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDale Showers <gentoo@fictx.com>2024-10-20 14:28:04 -0400
committerDale Showers <gentoo@fictx.com>2024-10-20 14:28:04 -0400
commit4a961e6c8e6756084e5d3a6d39e87deb0453b9ec (patch)
tree268086b7bc446eed53deade7d35107753561bb54 /www-client
parentwww-client/nyxt: drop 3.11.7 (diff)
downloadguru-4a961e6c8e6756084e5d3a6d39e87deb0453b9ec.tar.gz
guru-4a961e6c8e6756084e5d3a6d39e87deb0453b9ec.tar.bz2
guru-4a961e6c8e6756084e5d3a6d39e87deb0453b9ec.zip
www-client/nyxt: add 3.12.0
Signed-off-by: Dale Showers <gentoo@fictx.com>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/nyxt/Manifest1
-rw-r--r--www-client/nyxt/nyxt-3.12.0.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/www-client/nyxt/Manifest b/www-client/nyxt/Manifest
index a726c4bc8..502241ffa 100644
--- a/www-client/nyxt/Manifest
+++ b/www-client/nyxt/Manifest
@@ -1 +1,2 @@
DIST nyxt-3.11.8.gh.tar.xz 18101916 BLAKE2B b90d7967367ce0628e1451a04cab1fde3608a8f2137d5907a1247379a711e19168b2b7d04852f831a5f0ecb5680a79b4a31a235b7002ffd4de4dc99f8c70f2b7 SHA512 f6b1fcbb4bc4436cc39b0766f7a6a4e57cee81b785e04b1897c04836c6f349a8b5149118869fe36c8cc4c89518c88df75a47118f422149149f25b606a192cdf2
+DIST nyxt-3.12.0.gh.tar.xz 18095860 BLAKE2B 873f06abfb5305fd795edf062957c4c5b61c770799bd01608c84371ca3433211a6654dc90157461edbbc5558d14a570175a7df6df8c456b1b66c55b03dda8c7e SHA512 186c040dd3b4bf8fedcb6c27c35ba13bca2693881c41211af368f6ca6463609f4ba7926eea77dbba63047264d209498afe1ab35737de6274d93cc15ea64a56db
diff --git a/www-client/nyxt/nyxt-3.12.0.ebuild b/www-client/nyxt/nyxt-3.12.0.ebuild
new file mode 100644
index 000000000..4123fec32
--- /dev/null
+++ b/www-client/nyxt/nyxt-3.12.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop optfeature xdg
+
+DESCRIPTION="Nyxt - the hacker's power-browser"
+HOMEPAGE="https://nyxt.atlas.engineer/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/atlas-engineer/${PN}.git"
+ EGIT_SUBMODULES=( '*' )
+ EGIT_BRANCH="master"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/atlas-engineer/${PN}/releases/download/${PV}/nyxt-${PV}-source-with-submodules.tar.xz -> ${PF}.gh.tar.xz"
+fi
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+IUSE="doc"
+
+# Portage replaces the nyxt binary with sbcl when stripping
+RESTRICT="mirror strip"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ gnome-base/gsettings-desktop-schemas
+ net-libs/glib-networking
+ net-libs/webkit-gtk:4.1
+ sys-libs/libfixposix
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-lisp/sbcl-2.0.0[threads,unicode]
+"
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+
+if [[ "${PV}" != 9999 ]]; then
+ src_unpack() {
+ mkdir "${WORKDIR}/${P}" || die
+ cd "${WORKDIR}/${P}"
+ default
+}
+
+fi
+
+src_compile() {
+ emake all
+ use doc && emake doc
+}
+
+src_install(){
+ dobin "${S}/nyxt"
+
+ if [ "$(use doc)" ]
+ then
+ docinto "/usr/share/doc/${P}"
+ dodoc "${S}/manual.html"
+ fi
+
+ for icon in 16x16 32x32 128x128 256x256 512x512; do
+ newicon -s ${icon} "${S}/assets/nyxt_${icon}.png" ${PN}.png
+ done
+
+ domenu "${S}/assets/nyxt.desktop"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "for Wayland clipboard support" "gui-apps/wl-clipboard"
+ optfeature "for X11 clipboard support" "x11-misc/xclip"
+ optfeature "for spellchecking" "app-text/enchant"
+ optfeature "for HTML5 audio/video" "media-libs/gstreamer"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-bad"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-base"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-good"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-ugly"
+ optfeature "for HTML5 audio/video" "media-plugins/gst-plugins-libav"
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}