aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-power/amdfan/Manifest1
-rw-r--r--sys-power/amdfan/amdfan-0.1.27.ebuild44
-rw-r--r--sys-power/amdfan/metadata.xml12
3 files changed, 57 insertions, 0 deletions
diff --git a/sys-power/amdfan/Manifest b/sys-power/amdfan/Manifest
new file mode 100644
index 000000000..69ef6c1a6
--- /dev/null
+++ b/sys-power/amdfan/Manifest
@@ -0,0 +1 @@
+DIST amdfan-0.1.27.tar.gz 81422 BLAKE2B ab910e8a051f5c8a976425c30c141bc025ecea551f2390e625a36ee767c6a9a106eb4aee9dee5177824d46a2608201888c26672b614972d96598513625db898e SHA512 0a58aea4e53d830470d051292fe966fcf2d5b5094adb9181bf847d7f4467f2fda1e6a87e501c873337b0720ba84a3f7966a92832ed156b96b416107e232b22b0
diff --git a/sys-power/amdfan/amdfan-0.1.27.ebuild b/sys-power/amdfan/amdfan-0.1.27.ebuild
new file mode 100644
index 000000000..85805d5f1
--- /dev/null
+++ b/sys-power/amdfan/amdfan-0.1.27.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Updated AMD Fan control utility forked from amdgpu-fan and updated. "
+HOMEPAGE="https://mcgillij.dev/pages/amdfan.html"
+SRC_URI="https://github.com/mcgillij/amdfan/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+"
+DEPEND="${PYTHON_DEPS}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DOCS=( README.md )
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ systemd_dounit src/amdfan/amdfan.service
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover tests || die
+}
diff --git a/sys-power/amdfan/metadata.xml b/sys-power/amdfan/metadata.xml
new file mode 100644
index 000000000..b6dc73fbf
--- /dev/null
+++ b/sys-power/amdfan/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rolferen@gmail.com</email>
+ <name>Mazunki Hoksaas</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/mcgillij/amdfan/issues</bugs-to>
+ <remote-id type="github">mcgillij/amdfan</remote-id>
+ </upstream>
+</pkgmetadata>