aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/jsonrpc/jsonrpc-1.19.0.ebuild')
-rw-r--r--dev-ml/jsonrpc/jsonrpc-1.19.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/jsonrpc/jsonrpc-1.19.0.ebuild b/dev-ml/jsonrpc/jsonrpc-1.19.0.ebuild
new file mode 100644
index 0000000000..f19cf34712
--- /dev/null
+++ b/dev-ml/jsonrpc/jsonrpc-1.19.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Jsonrpc protocol implementation"
+HOMEPAGE="
+ https://opam.ocaml.org/packages/jsonrpc/
+ https://github.com/ocaml/ocaml-lsp
+"
+SRC_URI="https://github.com/ocaml/ocaml-lsp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/ocaml-lsp-${PV}"
+
+LICENSE="ISC"
+
+SLOT="0/${PV}"
+
+KEYWORDS="~amd64"
+IUSE="ocamlopt"
+
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08:=
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ >=dev-ml/dune-3.0:=
+"
+
+src_compile() {
+ dune-compile jsonrpc
+}