aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/corepdf/corepdf-4.0.0.ebuild')
-rw-r--r--gui-apps/corepdf/corepdf-4.0.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/gui-apps/corepdf/corepdf-4.0.0.ebuild b/gui-apps/corepdf/corepdf-4.0.0.ebuild
deleted file mode 100644
index 7c4c75112..000000000
--- a/gui-apps/corepdf/corepdf-4.0.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit qmake-utils xdg
-
-DESCRIPTION="A PDF viewer for C Suite"
-HOMEPAGE="https://gitlab.com/cubocore/coreapps/corepdf"
-
-if [[ "${PV}" == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
-else
- SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-v${PV}"
-fi
-
-RESTRICT="test"
-LICENSE="GPL-3"
-SLOT="0"
-
-DEPEND="
- app-text/poppler[qt5]
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- gui-libs/libcprime
-"
-RDEPEND="
- ${DEPEND}
-"
-
-src_prepare() {
- default
-
- sed -i 's/CSuite/X-CSuite/' "${PN}.desktop" || die
-}
-
-src_configure() {
- eqmake5
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- einstalldocs
-
- emake INSTALL_ROOT="${D}" install
-}