aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/corepdf/corepdf-9999.ebuild')
-rw-r--r--gui-apps/corepdf/corepdf-9999.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/gui-apps/corepdf/corepdf-9999.ebuild b/gui-apps/corepdf/corepdf-9999.ebuild
index 0ebca7da3..1fe8d8246 100644
--- a/gui-apps/corepdf/corepdf-9999.ebuild
+++ b/gui-apps/corepdf/corepdf-9999.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-MY_PV="${PV/_/-}"
+EAPI=8
inherit xdg cmake
@@ -12,25 +10,22 @@ HOMEPAGE="https://gitlab.com/cubocore/coreapps/corepdf"
if [[ "${PV}" == *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/corepdf.git"
else
- SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://gitlab.com/cubocore/coreapps/corepdf/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-v${MY_PV}"
+ S="${WORKDIR}/${PN}-v${PV}"
fi
-RESTRICT="test"
LICENSE="GPL-3"
SLOT="0"
DEPEND="
app-text/poppler[qt5]
- dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
dev-qt/qtwidgets:5
gui-libs/libcprime
"
-RDEPEND="
- ${DEPEND}
-"
+RDEPEND="${DEPEND}"