aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/candy/candy-5.8.5.ebuild')
-rw-r--r--net-vpn/candy/candy-5.8.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-vpn/candy/candy-5.8.5.ebuild b/net-vpn/candy/candy-5.8.5.ebuild
new file mode 100644
index 000000000..599727dad
--- /dev/null
+++ b/net-vpn/candy/candy-5.8.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake systemd
+
+DESCRIPTION="A reliable, low-latency, and anti-censorship virtual private network"
+HOMEPAGE="https://github.com/lanthora/candy"
+SRC_URI="https://github.com/lanthora/candy/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/uriparser
+ dev-libs/libconfig
+ dev-libs/poco
+ dev-libs/openssl
+ dev-libs/spdlog
+"
+RDEPEND="${DEPEND}"
+
+src_install(){
+ cmake_src_install
+ default
+
+ insinto /etc
+ doins candy.cfg
+ fperms 0644 /etc/candy.cfg
+
+ systemd_dounit candy.service
+ systemd_dounit candy@.service
+}