aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/gromit-mpx/Manifest1
-rw-r--r--x11-misc/gromit-mpx/gromit-mpx-1.4.1.ebuild40
-rw-r--r--x11-misc/gromit-mpx/gromit-mpx-9999.ebuild4
3 files changed, 43 insertions, 2 deletions
diff --git a/x11-misc/gromit-mpx/Manifest b/x11-misc/gromit-mpx/Manifest
index 0fc816950..ccd2d989c 100644
--- a/x11-misc/gromit-mpx/Manifest
+++ b/x11-misc/gromit-mpx/Manifest
@@ -1 +1,2 @@
+DIST gromit-mpx-1.4.1.tar.gz 1860019 BLAKE2B e13668e0e96aaa41c0a7a32f58ba136a406d0c675ee9b494171ee0ae834891f7c3251b58cd0c7987c5241ae172f16f7d27ff9bf22c5ab737507738bf21353712 SHA512 762cb068331121c27de8ebd6e226a18fe2f67d80f574a9d9241ae1484038cd82165b3098be29fc2e00831cf40f52c0e8bd0ef78e493a9eb642405a18a48680d3
DIST gromit-mpx-1.4.tar.gz 1858578 BLAKE2B e7f8cd9f424422f7169b14f9780c64c317fecc9de421e6960f1926629423ddf1e9ac796b806d36cae884dd074e352cfca6084b9821cc74cdcabfbecf3d611c9c SHA512 5a2b81dcaef9b04e9d514c966b0b96dcb1b6b4a4cba1f26056ac3b758922d82e551397cf9c06a32a395e6a5b99a3d8c08fdd5ac875fdf7455efc2abe7eeb82f5
diff --git a/x11-misc/gromit-mpx/gromit-mpx-1.4.1.ebuild b/x11-misc/gromit-mpx/gromit-mpx-1.4.1.ebuild
new file mode 100644
index 000000000..95600ede0
--- /dev/null
+++ b/x11-misc/gromit-mpx/gromit-mpx-1.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Gromit-MPX is a multi-pointer GTK3 port of the Gromit desktop annotation tool"
+HOMEPAGE="https://github.com/bk138/gromit-mpx"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bk138/${PN}.git"
+else
+ SRC_URI="https://github.com/bk138/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND="
+ x11-libs/gtk+:3
+ dev-libs/libappindicator:3
+ x11-libs/libX11
+ >=x11-apps/xinput-1.3
+"
+DEPEND="${RDEPEND}"
+
+src_prepare () {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
+ )
+
+ cmake_src_configure
+}
diff --git a/x11-misc/gromit-mpx/gromit-mpx-9999.ebuild b/x11-misc/gromit-mpx/gromit-mpx-9999.ebuild
index 60db7a22e..95600ede0 100644
--- a/x11-misc/gromit-mpx/gromit-mpx-9999.ebuild
+++ b/x11-misc/gromit-mpx/gromit-mpx-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake xdg