aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-11-10 07:56:07 -0800
committerorbea <orbea@riseup.net>2024-11-10 07:56:07 -0800
commit6a21902b06f2d7913db8c6e392db43bdced76ff5 (patch)
tree4d74e67142f29c629cfbddf515eb98b586c06b4f
parentdev-util/maturin: drop 1.6.0, 1.7.1, 1.7.4 (diff)
downloadlibressl-6a21902b06f2d7913db8c6e392db43bdced76ff5.tar.gz
libressl-6a21902b06f2d7913db8c6e392db43bdced76ff5.tar.bz2
libressl-6a21902b06f2d7913db8c6e392db43bdced76ff5.zip
dev-util/cargo-ebuild: add 0.5.4-r2, drop 0.5.4-r1
Signed-off-by: orbea <orbea@riseup.net>
-rw-r--r--dev-util/cargo-ebuild/cargo-ebuild-0.5.4-r2.ebuild (renamed from dev-util/cargo-ebuild/cargo-ebuild-0.5.4-r1.ebuild)12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-util/cargo-ebuild/cargo-ebuild-0.5.4-r1.ebuild b/dev-util/cargo-ebuild/cargo-ebuild-0.5.4-r2.ebuild
index a19ea0f..b5ef400 100644
--- a/dev-util/cargo-ebuild/cargo-ebuild-0.5.4-r1.ebuild
+++ b/dev-util/cargo-ebuild/cargo-ebuild-0.5.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2017-2023 Gentoo Authors
+# Copyright 2017-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Auto-Generated by cargo-ebuild 0.5.4-r1
@@ -134,6 +134,9 @@ CRATES="
winapi-x86_64-pc-windows-gnu@0.4.0
"
+# https://github.com/rust-lang/rust/issues/113152#issuecomment-1612578376
+RUST_MAX_VER="1.71.1"
+
inherit cargo
DESCRIPTION="Generates an ebuild for a package using the in-tree eclasses."
@@ -156,7 +159,6 @@ DEPEND="
RDEPEND="
${DEPEND}
- virtual/rust
"
PATCHES=(
@@ -165,6 +167,12 @@ PATCHES=(
QA_FLAGS_IGNORED="usr/bin/cargo-ebuild"
+pkg_setup() {
+ rust_pkg_setup
+ # Requires nightly feature proc-macro2
+ export RUSTC_BOOTSTRAP=1
+}
+
src_prepare() {
default
pushd "${ECARGO_HOME}"/gentoo > /dev/null || die