aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-11-19 08:19:27 -0800
committerorbea <orbea@riseup.net>2024-11-19 08:19:27 -0800
commit3c78680ffb4b9633adf22890d4de6fd63ccae551 (patch)
tree10b96c0c0f61808bfb461b7d007714241c5e27cc /dev-lang
parentdev-lang/rust: sync ::gentoo (diff)
downloadlibressl-3c78680ffb4b9633adf22890d4de6fd63ccae551.tar.gz
libressl-3c78680ffb4b9633adf22890d4de6fd63ccae551.tar.bz2
libressl-3c78680ffb4b9633adf22890d4de6fd63ccae551.zip
dev-lang/rust: sync ::gentoo
Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/rust-1.74.1-r100.ebuild5
-rw-r--r--dev-lang/rust/rust-1.75.0-r100.ebuild5
-rw-r--r--dev-lang/rust/rust-1.77.1-r100.ebuild5
-rw-r--r--dev-lang/rust/rust-1.79.0-r100.ebuild5
-rw-r--r--dev-lang/rust/rust-1.80.1-r100.ebuild7
-rw-r--r--dev-lang/rust/rust-1.81.0-r100.ebuild5
-rw-r--r--dev-lang/rust/rust-1.82.0-r100.ebuild4
7 files changed, 14 insertions, 22 deletions
diff --git a/dev-lang/rust/rust-1.74.1-r100.ebuild b/dev-lang/rust/rust-1.74.1-r100.ebuild
index 52a09d7..75c2e32 100644
--- a/dev-lang/rust/rust-1.74.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.74.1-r100.ebuild
@@ -611,7 +611,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -635,7 +635,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -653,9 +652,9 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi
-
insinto /etc/env.d/rust
doins "${T}/provider-${P}"
diff --git a/dev-lang/rust/rust-1.75.0-r100.ebuild b/dev-lang/rust/rust-1.75.0-r100.ebuild
index cdade59..3038ad0 100644
--- a/dev-lang/rust/rust-1.75.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.75.0-r100.ebuild
@@ -613,7 +613,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -637,7 +637,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -655,9 +654,9 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi
-
insinto /etc/env.d/rust
doins "${T}/provider-${P}"
diff --git a/dev-lang/rust/rust-1.77.1-r100.ebuild b/dev-lang/rust/rust-1.77.1-r100.ebuild
index 6bd99ee..8ecdb24 100644
--- a/dev-lang/rust/rust-1.77.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.77.1-r100.ebuild
@@ -613,7 +613,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -637,7 +637,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -655,9 +654,9 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi
-
insinto /etc/env.d/rust
doins "${T}/provider-${P}"
diff --git a/dev-lang/rust/rust-1.79.0-r100.ebuild b/dev-lang/rust/rust-1.79.0-r100.ebuild
index 502c120..80369af 100644
--- a/dev-lang/rust/rust-1.79.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.79.0-r100.ebuild
@@ -615,7 +615,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -639,7 +639,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -657,9 +656,9 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi
-
insinto /etc/env.d/rust
doins "${T}/provider-${P}"
diff --git a/dev-lang/rust/rust-1.80.1-r100.ebuild b/dev-lang/rust/rust-1.80.1-r100.ebuild
index 191c0bc..ceaa87c 100644
--- a/dev-lang/rust/rust-1.80.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.80.1-r100.ebuild
@@ -587,7 +587,6 @@ src_install() {
rust-gdb
rust-gdbgui
rust-lldb
- rust-demangler
)
use clippy && symlinks+=( clippy-driver cargo-clippy )
@@ -614,7 +613,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -632,13 +631,11 @@ src_install() {
cat <<-_EOF_ > "${T}/provider-${P}"
/usr/bin/cargo
/usr/bin/rustdoc
- /usr/bin/rust-demangler
/usr/bin/rust-gdb
/usr/bin/rust-gdbgui
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -656,9 +653,9 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi
-
insinto /etc/env.d/rust
doins "${T}/provider-${P}"
diff --git a/dev-lang/rust/rust-1.81.0-r100.ebuild b/dev-lang/rust/rust-1.81.0-r100.ebuild
index c4f157e..da785b2 100644
--- a/dev-lang/rust/rust-1.81.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.81.0-r100.ebuild
@@ -617,7 +617,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -640,7 +640,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -658,9 +657,9 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi
-
insinto /etc/env.d/rust
doins "${T}/provider-${P}"
diff --git a/dev-lang/rust/rust-1.82.0-r100.ebuild b/dev-lang/rust/rust-1.82.0-r100.ebuild
index 375be4d..a14e5d1 100644
--- a/dev-lang/rust/rust-1.82.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.82.0-r100.ebuild
@@ -624,7 +624,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -647,7 +647,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -665,6 +664,7 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi