aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-01-15 22:51:26 -0800
committerorbea <orbea@riseup.net>2024-01-15 22:56:28 -0800
commitd1527a72acabce55f0d3551121686164debde01d (patch)
tree0d4f75768605bc695f68ee4572216ff73dfd528d /dev-libs/libressl
parentdev-libs/libressl: drop 3.8.1 (diff)
downloadlibressl-d1527a72acabce55f0d3551121686164debde01d.tar.gz
libressl-d1527a72acabce55f0d3551121686164debde01d.tar.bz2
libressl-d1527a72acabce55f0d3551121686164debde01d.zip
dev-libs/libressl: fix variable scope QA notice
variable 'BROOT' used in 'global scope' Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'dev-libs/libressl')
-rw-r--r--dev-libs/libressl/libressl-3.6.3.ebuild3
-rw-r--r--dev-libs/libressl/libressl-3.7.3.ebuild3
-rw-r--r--dev-libs/libressl/libressl-3.8.0.ebuild3
-rw-r--r--dev-libs/libressl/libressl-3.8.2.ebuild3
4 files changed, 4 insertions, 8 deletions
diff --git a/dev-libs/libressl/libressl-3.6.3.ebuild b/dev-libs/libressl/libressl-3.6.3.ebuild
index f7236b7..dd85ed5 100644
--- a/dev-libs/libressl/libressl-3.6.3.ebuild
+++ b/dev-libs/libressl/libressl-3.6.3.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/libressl.asc
inherit autotools multilib-minimal verify-sig
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
@@ -24,8 +25,6 @@ RESTRICT="!test? ( test )"
PDEPEND="app-misc/ca-certificates"
BDEPEND="verify-sig? ( sec-keys/openpgp-keys-libressl )"
-VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libressl.asc
-
PATCHES=(
"${FILESDIR}"/${PN}-2.8.3-solaris10.patch
# Gentoo's ssl-cert.eclass uses 'openssl genrsa -rand'
diff --git a/dev-libs/libressl/libressl-3.7.3.ebuild b/dev-libs/libressl/libressl-3.7.3.ebuild
index edefb0f..cdbcbc2 100644
--- a/dev-libs/libressl/libressl-3.7.3.ebuild
+++ b/dev-libs/libressl/libressl-3.7.3.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/libressl.asc
inherit autotools multilib-minimal verify-sig
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
@@ -24,8 +25,6 @@ RESTRICT="!test? ( test )"
PDEPEND="app-misc/ca-certificates"
BDEPEND="verify-sig? ( sec-keys/openpgp-keys-libressl )"
-VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libressl.asc
-
MULTILIB_WRAPPED_HEADERS=( /usr/include/openssl/opensslconf.h )
PATCHES=(
diff --git a/dev-libs/libressl/libressl-3.8.0.ebuild b/dev-libs/libressl/libressl-3.8.0.ebuild
index 7ceb7e7..83b2734 100644
--- a/dev-libs/libressl/libressl-3.8.0.ebuild
+++ b/dev-libs/libressl/libressl-3.8.0.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/libressl.asc
inherit autotools multilib-minimal verify-sig
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
@@ -24,8 +25,6 @@ RESTRICT="!test? ( test )"
PDEPEND="app-misc/ca-certificates"
BDEPEND="verify-sig? ( sec-keys/openpgp-keys-libressl )"
-VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libressl.asc
-
MULTILIB_WRAPPED_HEADERS=( /usr/include/openssl/opensslconf.h )
PATCHES=(
diff --git a/dev-libs/libressl/libressl-3.8.2.ebuild b/dev-libs/libressl/libressl-3.8.2.ebuild
index 78f16c0..c18d6b2 100644
--- a/dev-libs/libressl/libressl-3.8.2.ebuild
+++ b/dev-libs/libressl/libressl-3.8.2.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/libressl.asc
inherit autotools multilib-minimal verify-sig
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
@@ -29,8 +30,6 @@ RDEPEND="netcat? (
!net-analyzer/openbsd-netcat
)"
-VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libressl.asc
-
MULTILIB_WRAPPED_HEADERS=( /usr/include/openssl/opensslconf.h )
# LibreSSL checks for libc features during configure