aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-10-11 13:50:47 +0200
committerJauhien Piatlicki <jauhien@gentoo.org>2014-10-11 13:50:47 +0200
commit261787f2b8cae48ecec45ed7b8e1cda9137d2d36 (patch)
tree0a74b05006466e7506b17718217c0a3ac10e5186 /app-shells
parent[app-vim/rust-mode] split from dev-lang/rust package (diff)
downloadrust-261787f2b8cae48ecec45ed7b8e1cda9137d2d36.tar.gz
rust-261787f2b8cae48ecec45ed7b8e1cda9137d2d36.tar.bz2
rust-261787f2b8cae48ecec45ed7b8e1cda9137d2d36.zip
[app-shells/rust-zshcomp] split from dev-lang/rust package
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/rust-zshcomp/Manifest1
-rw-r--r--app-shells/rust-zshcomp/metadata.xml8
-rw-r--r--app-shells/rust-zshcomp/rust-zshcomp-0.11.0.ebuild36
-rw-r--r--app-shells/rust-zshcomp/rust-zshcomp-9999.ebuild36
4 files changed, 81 insertions, 0 deletions
diff --git a/app-shells/rust-zshcomp/Manifest b/app-shells/rust-zshcomp/Manifest
new file mode 100644
index 0000000..2610a05
--- /dev/null
+++ b/app-shells/rust-zshcomp/Manifest
@@ -0,0 +1 @@
+DIST rust-0.11.0.tar.gz 21555837 SHA256 d1b3e36448bf12b8c9289024df416de10774b6d3235d7b1d22b248ef634411ba SHA512 a29e8a1c44097cc78d36d637d1ebf9b1b914d58a56d52f8112959a68916a2df9f5f63f93e596ba6db5be21a962912503e0fd678330a9dac6abe04a59d5af4584 WHIRLPOOL b7fb24920aca2a537af0c7e20925302a20fbd662209a1774a8ecc7c2cf9aaeb9b4fabfdd45620a0fda88b49122abc04882f7254a984b06df47212e537f8713f8
diff --git a/app-shells/rust-zshcomp/metadata.xml b/app-shells/rust-zshcomp/metadata.xml
new file mode 100644
index 0000000..0b7db93
--- /dev/null
+++ b/app-shells/rust-zshcomp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-shells/rust-zshcomp/rust-zshcomp-0.11.0.ebuild b/app-shells/rust-zshcomp/rust-zshcomp-0.11.0.ebuild
new file mode 100644
index 0000000..302e32a
--- /dev/null
+++ b/app-shells/rust-zshcomp/rust-zshcomp-0.11.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+DESCRIPTION="Rust zsh completions"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="http://static.rust-lang.org/dist/rust-${PV}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-shells/zsh
+ !!<=app-admin/eselect-rust-0.1_pre20140820
+ !<=dev-lang/rust-0.11.0-r1:0.11
+ !<=dev-lang/rust-999:nightly
+ !<=dev-lang/rust-9999-r2:git
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/rust-${PV}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/etc/zsh/_rust
+}
diff --git a/app-shells/rust-zshcomp/rust-zshcomp-9999.ebuild b/app-shells/rust-zshcomp/rust-zshcomp-9999.ebuild
new file mode 100644
index 0000000..3b7f0ca
--- /dev/null
+++ b/app-shells/rust-zshcomp/rust-zshcomp-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit git-r3
+
+DESCRIPTION="Rust zsh completions"
+HOMEPAGE="http://www.rust-lang.org/"
+EGIT_REPO_URI="git://github.com/rust-lang/rust.git"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="app-shells/zsh
+ !!<=app-admin/eselect-rust-0.1_pre20140820
+ !<=dev-lang/rust-0.11.0-r1:0.11
+ !<=dev-lang/rust-999:nightly
+ !<=dev-lang/rust-9999-r2:git
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/etc/zsh/_rust
+}