summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-02-26 10:36:50 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-02-26 10:36:50 +0000
commit0078197179c5a4eca7538ff00fadfda6f8650acf (patch)
tree1abb423d7c4c89ba583b26260e45124ff16eea33
parent2020-02-26 09:37:15 UTC (diff)
parentuser.eclass: enewgroup, allow -1 as gid (diff)
downloadgentoo-0078197179c5a4eca7538ff00fadfda6f8650acf.tar.gz
gentoo-0078197179c5a4eca7538ff00fadfda6f8650acf.tar.bz2
gentoo-0078197179c5a4eca7538ff00fadfda6f8650acf.zip
Merge updates from master
-rw-r--r--app-crypt/qca/Manifest1
-rw-r--r--app-crypt/qca/qca-2.2.90.ebuild84
-rw-r--r--eclass/user.eclass42
-rw-r--r--kde-frameworks/kirigami/kirigami-5.67.1.ebuild46
-rw-r--r--kde-frameworks/kitemmodels/kitemmodels-5.67.0.ebuild4
5 files changed, 25 insertions, 152 deletions
diff --git a/app-crypt/qca/Manifest b/app-crypt/qca/Manifest
index d518207a54db..b72a547ab01d 100644
--- a/app-crypt/qca/Manifest
+++ b/app-crypt/qca/Manifest
@@ -1,3 +1,2 @@
DIST qca-2.2.1.tar.xz 691676 BLAKE2B d5bcc0d6e791811e1efcdbf2e09916fe40ad682b0e59b2993c73a5bd79e09fc28facdec81259a982bee05223c8dfce78b9a6b729ca4e566c0901a13b91575379 SHA512 3a0e8aa7cf3ea9a7244facaf1d521ebca2753af37636e7bf5f21c57ae880ac9682ae7d6d9fa5ce41b73568ff9538214956b89cd41228c2cb828d9068c2031a9c
-DIST qca-2.2.90.tar.xz 729488 BLAKE2B bc061118afa7912d249317dd4af9d2f4619b339ec892e33d1c757dc11a4a8b06db96d2437f08abeb48e4a1277cb399d8b3d60d8e2645b2d81cf9d20735ac3cb4 SHA512 5c431b66f898786271881c1275883e332fbfecd62ee265cae2ad345a13ff74ca36fc9b3e93972dcf29c4333f1c8049488ca52ca809c977553b422b9a27b45b7c
DIST qca-2.3.0.tar.xz 729504 BLAKE2B 71cf9dfae00066c14e1055da1fa1a8e1210f538b1addfde1b99a9b26b1e8f7dd61e289d0f505b5ec04d5f4745216d4fd0f8be8f8de9e9cbf74123907ba703d0e SHA512 ca9251868e073834562fa62ffc64b3e7817c9ddadc6bc3fb99cf8b5c8d859969562170a98874be9590c617b2dd8e5590d2c83792554f54bb880c677902db22fe
diff --git a/app-crypt/qca/qca-2.2.90.ebuild b/app-crypt/qca/qca-2.2.90.ebuild
deleted file mode 100644
index 0531711ed4fa..000000000000
--- a/app-crypt/qca/qca-2.2.90.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit kde.org cmake qmake-utils
-
-DESCRIPTION="Qt Cryptographic Architecture (QCA)"
-HOMEPAGE="https://userbase.kde.org/QCA"
-SRC_URI="mirror://kde/unstable/${PN}/${PV}/${P}.tar.xz"
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS=""
-IUSE="botan debug doc examples gcrypt gpg logger nss pkcs11 sasl softstore +ssl test"
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- doc? ( app-doc/doxygen )
-"
-RDEPEND="
- dev-qt/qtcore:5
- botan? ( dev-libs/botan:= )
- gcrypt? ( dev-libs/libgcrypt:= )
- gpg? ( app-crypt/gnupg )
- nss? ( dev-libs/nss )
- pkcs11? (
- >=dev-libs/openssl-1.1
- dev-libs/pkcs11-helper
- )
- sasl? ( dev-libs/cyrus-sasl:2 )
- ssl? ( >=dev-libs/openssl-1.1:0= )
-"
-DEPEND="${RDEPEND}
- test? (
- dev-qt/qtnetwork:5
- dev-qt/qttest:5
- )
-"
-
-PATCHES=( "${FILESDIR}/${PN}-disable-pgp-test.patch" )
-
-qca_plugin_use() {
- echo -DWITH_${2:-$1}_PLUGIN=$(usex "$1")
-}
-
-src_configure() {
- local mycmakeargs=(
- -DQCA_FEATURE_INSTALL_DIR="${EPREFIX}$(qt5_get_mkspecsdir)/features"
- -DQCA_PLUGINS_INSTALL_DIR="${EPREFIX}$(qt5_get_plugindir)"
- $(qca_plugin_use botan)
- $(qca_plugin_use gcrypt)
- $(qca_plugin_use gpg gnupg)
- $(qca_plugin_use logger)
- $(qca_plugin_use nss)
- $(qca_plugin_use pkcs11)
- $(qca_plugin_use sasl cyrus-sasl)
- $(qca_plugin_use softstore)
- $(qca_plugin_use ssl ossl)
- -DBUILD_TESTS=$(usex test)
- )
- cmake_src_configure
-}
-
-src_test() {
- local -x QCA_PLUGIN_PATH="${BUILD_DIR}/lib/qca"
- cmake_src_test
-}
-
-src_install() {
- cmake_src_install
-
- if use doc; then
- pushd "${BUILD_DIR}" >/dev/null || die
- doxygen Doxyfile || die
- dodoc -r apidocs/html
- popd >/dev/null || die
- fi
-
- if use examples; then
- dodoc -r "${S}"/examples
- fi
-}
diff --git a/eclass/user.eclass b/eclass/user.eclass
index 9bd0b607eab8..b70698356a3a 100644
--- a/eclass/user.eclass
+++ b/eclass/user.eclass
@@ -68,7 +68,7 @@ user_get_nologin() {
# exist.
enewuser() {
if [[ ${EUID} != 0 ]] ; then
- einfo "Insufficient privileges to execute ${FUNCNAME[0]}"
+ ewarn "Insufficient privileges to execute ${FUNCNAME[0]}"
return 0
fi
_assert_pkg_ebuild_phase ${FUNCNAME}
@@ -94,7 +94,7 @@ enewuser() {
if [[ -n $(egetent passwd "${euser}") ]] ; then
return 0
fi
- einfo "Adding user '${euser}' to your system ..."
+ elog "Adding user '${euser}' to your system ..."
# options to pass to useradd
local opts=()
@@ -122,7 +122,7 @@ enewuser() {
[[ ${euid} -ge 101 ]] || die "${FUNCNAME}: no free UID found"
fi
opts+=( -u ${euid} )
- einfo " - Userid: ${euid}"
+ elog " - Userid: ${euid}"
# handle shell
local eshell=$1; shift
@@ -138,7 +138,7 @@ enewuser() {
else
eshell=$(user_get_nologin)
fi
- einfo " - Shell: ${eshell}"
+ elog " - Shell: ${eshell}"
opts+=( -s "${eshell}" )
# handle homedir
@@ -146,7 +146,7 @@ enewuser() {
if [[ -z ${ehome} ]] || [[ ${ehome} == "-1" ]] ; then
ehome="/dev/null"
fi
- einfo " - Home: ${ehome}"
+ elog " - Home: ${ehome}"
opts+=( -d "${ehome}" )
# handle groups
@@ -171,7 +171,7 @@ enewuser() {
opts+=( -G "${exgroups:1}" )
fi
fi
- einfo " - Groups: ${egroups:-(none)}"
+ elog " - Groups: ${egroups:-(none)}"
# handle extra args
if [[ $# -gt 0 ]] ; then
@@ -179,7 +179,7 @@ enewuser() {
else
local comment="added by portage for ${PN}"
opts+=( -c "${comment}" )
- einfo " - GECOS: ${comment}"
+ elog " - GECOS: ${comment}"
fi
# add the user
@@ -204,7 +204,7 @@ enewuser() {
esac
if [[ -n ${create_home} && ! -e ${ROOT}/${ehome} ]] ; then
- einfo " - Creating ${ehome} in ${ROOT}"
+ elog " - Creating ${ehome} in ${ROOT}"
mkdir -p "${ROOT}/${ehome}"
chown "${euser}" "${ROOT}/${ehome}"
chmod 755 "${ROOT}/${ehome}"
@@ -223,7 +223,7 @@ enewuser() {
# can not be assigned.
enewgroup() {
if [[ ${EUID} != 0 ]] ; then
- einfo "Insufficient privileges to execute ${FUNCNAME[0]}"
+ ewarn "Insufficient privileges to execute ${FUNCNAME[0]}"
return 0
fi
_assert_pkg_ebuild_phase ${FUNCNAME}
@@ -248,11 +248,11 @@ enewgroup() {
if [[ -n $(egetent group "${egroup}") ]] ; then
return 0
fi
- einfo "Adding group '${egroup}' to your system ..."
+ elog "Adding group '${egroup}' to your system ..."
# handle gid
local egid=$1; shift
- if [[ ! -z ${egid} ]] ; then
+ if [[ -n ${egid} && ${egid} != -1 ]] ; then
if [[ ${egid} -gt 0 ]] ; then
if [[ -n $(egetent group ${egid}) ]] ; then
[[ -n ${force_gid} ]] && die "${FUNCNAME}: GID ${egid} already taken"
@@ -266,7 +266,7 @@ enewgroup() {
[[ -n ${force_gid} ]] && die "${FUNCNAME}: -F with gid==-1 makes no sense"
egid="next available"
fi
- einfo " - Groupid: ${egid}"
+ elog " - Groupid: ${egid}"
# handle extra
if [[ $# -gt 0 ]] ; then
@@ -351,12 +351,12 @@ esethome() {
return 0
fi
- einfo "Updating home for user '${euser}' ..."
- einfo " - Home: ${ehome}"
+ elog "Updating home for user '${euser}' ..."
+ elog " - Home: ${ehome}"
# ensure home directory exists, otherwise update will fail
if [[ ! -e ${ROOT}/${ehome} ]] ; then
- einfo " - Creating ${ehome} in ${ROOT}"
+ elog " - Creating ${ehome} in ${ROOT}"
mkdir -p "${ROOT}/${ehome}"
chown "${euser}" "${ROOT}/${ehome}"
chmod 755 "${ROOT}/${ehome}"
@@ -420,8 +420,8 @@ esetshell() {
return 0
fi
- einfo "Updating shell for user '${euser}' ..."
- einfo " - Shell: ${eshell}"
+ elog "Updating shell for user '${euser}' ..."
+ elog " - Shell: ${eshell}"
# update the shell
case ${CHOST} in
@@ -476,8 +476,8 @@ esetcomment() {
return 0
fi
- einfo "Updating comment for user '${euser}' ..."
- einfo " - Comment: ${ecomment}"
+ elog "Updating comment for user '${euser}' ..."
+ elog " - Comment: ${ecomment}"
# update the comment
case ${CHOST} in
@@ -546,8 +546,8 @@ esetgroups() {
fi
local opts=( -g "${defgroup}" -G "${exgroups}" )
- einfo "Updating groups for user '${euser}' ..."
- einfo " - Groups: ${egroups}"
+ elog "Updating groups for user '${euser}' ..."
+ elog " - Groups: ${egroups}"
# update the group
case ${CHOST} in
diff --git a/kde-frameworks/kirigami/kirigami-5.67.1.ebuild b/kde-frameworks/kirigami/kirigami-5.67.1.ebuild
deleted file mode 100644
index e04c2eda8d22..000000000000
--- a/kde-frameworks/kirigami/kirigami-5.67.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_EXAMPLES="true"
-ECM_QTHELP="false"
-ECM_TEST="true"
-KDE_ORG_NAME="${PN}2"
-QTMIN=5.12.3
-inherit ecm kde.org
-
-DESCRIPTION="Lightweight user interface framework for mobile and convergent applications"
-HOMEPAGE="https://techbase.kde.org/Kirigami"
-EGIT_REPO_URI="${EGIT_REPO_URI/${PN}2/${PN}}"
-
-LICENSE="LGPL-2+"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE=""
-
-# drop qtgui subslot operator when QT_MINIMAL >= 5.14.0
-BDEPEND="
- >=dev-qt/linguist-tools-${QTMIN}:5
-"
-DEPEND="
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5=
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtquickcontrols2-${QTMIN}:5
- >=dev-qt/qtsvg-${QTMIN}:5
-"
-RDEPEND="${DEPEND}
- >=dev-qt/qtgraphicaleffects-${QTMIN}:5
-"
-
-# requires package to already be installed
-RESTRICT+=" test"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_EXAMPLES=$(usex examples)
- )
-
- ecm_src_configure
-}
diff --git a/kde-frameworks/kitemmodels/kitemmodels-5.67.0.ebuild b/kde-frameworks/kitemmodels/kitemmodels-5.67.0.ebuild
index f40fa593a684..7d904ac0fc56 100644
--- a/kde-frameworks/kitemmodels/kitemmodels-5.67.0.ebuild
+++ b/kde-frameworks/kitemmodels/kitemmodels-5.67.0.ebuild
@@ -26,3 +26,7 @@ src_configure() {
)
ecm_src_configure
}
+
+src_test() {
+ LC_NUMERIC="C" ecm_src_test # bug 708820
+}