summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-20 05:06:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-20 05:06:48 +0200
commit0bed03f1f41a2d29fd5e30e0b4f57eb05a1df9fb (patch)
tree1dd98a91b0718c3678a187c471e719edee1f42de
parentdev-libs/c-blosc2: Update the zlib-ng comment (diff)
downloadgentoo-0bed03f1f41a2d29fd5e30e0b4f57eb05a1df9fb.tar.gz
gentoo-0bed03f1f41a2d29fd5e30e0b4f57eb05a1df9fb.tar.bz2
gentoo-0bed03f1f41a2d29fd5e30e0b4f57eb05a1df9fb.zip
dev-python/fritzconnection: Bump to 1.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fritzconnection/Manifest1
-rw-r--r--dev-python/fritzconnection/fritzconnection-1.13.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/fritzconnection/Manifest b/dev-python/fritzconnection/Manifest
index 66e23e75dc70..de84719de25c 100644
--- a/dev-python/fritzconnection/Manifest
+++ b/dev-python/fritzconnection/Manifest
@@ -1 +1,2 @@
DIST fritzconnection-1.12.2.gh.tar.gz 157170 BLAKE2B 9d924ad3146361d9301f10154152cdf98987572880b79052bf9f2fa427fc8410bacae92e49219dd11372c2cce2d03fb0ffd4c732a45e210a05a0a561ba5fc155 SHA512 a9c62fdaa59f20e7661836888f49cadfc99d192c393f34d4cce59aa9b9a9eda162e25029933854e84de44e08190190f312bb3862d708e79d7cf1ee8496726eab
+DIST fritzconnection-1.13.0.gh.tar.gz 160654 BLAKE2B e3ed78640a015d2dc785b2e04f32f6d4e81ba88bf4d823cd643e0f4ebc2ec8396c79c8e368012944f5809512a05d6d4715cdf7d0d76e518479a0a77e20350fae SHA512 6776ba37b52a80eee57a77a75f7815491a575ab8a1c36d20633b39d61e8f0fc295c1ec1d20bb6620e43854b954d9fd044e88d0344a10c0b3707fffb3edc733a4
diff --git a/dev-python/fritzconnection/fritzconnection-1.13.0.ebuild b/dev-python/fritzconnection/fritzconnection-1.13.0.ebuild
new file mode 100644
index 000000000000..b1bee82fa217
--- /dev/null
+++ b/dev-python/fritzconnection/fritzconnection-1.13.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lib/tool to communicate with AVM FRITZ! devices using TR-064 protocol over UPnP"
+HOMEPAGE="
+ https://github.com/kbr/fritzconnection/
+ https://pypi.org/project/fritzconnection/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/kbr/fritzconnection"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/kbr/fritzconnection/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-python/requests-2.22[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # flaky (relies on time.sleep(0.01) magically being sufficient)
+ fritzconnection/tests/test_fritzmonitor.py::test_terminate_thread_on_failed_reconnection
+ )
+
+ # "routertest" marks tests against live hardware
+ epytest -m "not routertest"
+}