summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2019-03-19 09:25:59 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2019-03-19 09:25:59 +0000
commit0f80e2a4b8f60ee6b8713a5566513448fcc11fe0 (patch)
tree49c97636960b78933f7e9177febcfeed304a14b2
parent2019-03-19 08:46:18 UTC (diff)
parentmate-base/mate-session-manager: fix regression on non-systemd profiles (diff)
downloadgentoo-0f80e2a4b8f60ee6b8713a5566513448fcc11fe0.tar.gz
gentoo-0f80e2a4b8f60ee6b8713a5566513448fcc11fe0.tar.bz2
gentoo-0f80e2a4b8f60ee6b8713a5566513448fcc11fe0.zip
Merge updates from master
-rw-r--r--games-board/gnome-chess/gnome-chess-3.30.1.ebuild2
-rw-r--r--games-puzzle/lightsoff/lightsoff-3.28.0.ebuild2
-rw-r--r--games-puzzle/lightsoff/lightsoff-3.30.0.ebuild1
-rw-r--r--mate-base/mate-session-manager/files/mate-session-manager-1.22.0-fix-systemd-regression.patch65
-rw-r--r--mate-base/mate-session-manager/mate-session-manager-1.22.0.ebuild2
-rw-r--r--media-libs/libchamplain/libchamplain-0.12.19-r1.ebuild (renamed from media-libs/libchamplain/libchamplain-0.12.19.ebuild)42
-rw-r--r--media-libs/libchamplain/metadata.xml6
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.24.0.ebuild2
-rw-r--r--profiles/features/selinux/make.defaults2
9 files changed, 103 insertions, 21 deletions
diff --git a/games-board/gnome-chess/gnome-chess-3.30.1.ebuild b/games-board/gnome-chess/gnome-chess-3.30.1.ebuild
index f52f27cab4f1..c26dcdd86ac5 100644
--- a/games-board/gnome-chess/gnome-chess-3.30.1.ebuild
+++ b/games-board/gnome-chess/gnome-chess-3.30.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-VALA_MIN_API_VERSION="0.36"
+VALA_MIN_API_VERSION="0.40"
inherit gnome.org gnome2-utils meson readme.gentoo-r1 vala xdg
diff --git a/games-puzzle/lightsoff/lightsoff-3.28.0.ebuild b/games-puzzle/lightsoff/lightsoff-3.28.0.ebuild
index 9c0fb1be526d..4d3bd86e622c 100644
--- a/games-puzzle/lightsoff/lightsoff-3.28.0.ebuild
+++ b/games-puzzle/lightsoff/lightsoff-3.28.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
diff --git a/games-puzzle/lightsoff/lightsoff-3.30.0.ebuild b/games-puzzle/lightsoff/lightsoff-3.30.0.ebuild
index cfbafcc3f5cf..2fb0cb64a70d 100644
--- a/games-puzzle/lightsoff/lightsoff-3.30.0.ebuild
+++ b/games-puzzle/lightsoff/lightsoff-3.30.0.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+VALA_MIN_API_VERSION="0.40"
inherit gnome.org gnome2-utils meson xdg vala
DESCRIPTION="Turn off all the lights"
diff --git a/mate-base/mate-session-manager/files/mate-session-manager-1.22.0-fix-systemd-regression.patch b/mate-base/mate-session-manager/files/mate-session-manager-1.22.0-fix-systemd-regression.patch
new file mode 100644
index 000000000000..eccfe5b5b18e
--- /dev/null
+++ b/mate-base/mate-session-manager/files/mate-session-manager-1.22.0-fix-systemd-regression.patch
@@ -0,0 +1,65 @@
+From 7f0a938467e4e3d57c68af1caa146a664458a911 Mon Sep 17 00:00:00 2001
+From: Victor Kareh <vkareh@redhat.com>
+Date: Wed, 6 Mar 2019 09:20:36 -0500
+Subject: [PATCH] Guard against missing systemd
+
+---
+ mate-session/gsm-systemd.c | 19 +++++++++++++++++++
+ 1 file changed, 19 insertions(+)
+
+diff --git a/mate-session/gsm-systemd.c b/mate-session/gsm-systemd.c
+index da3f23b..d03cafd 100644
+--- a/mate-session/gsm-systemd.c
++++ b/mate-session/gsm-systemd.c
+@@ -429,16 +429,31 @@ gsm_systemd_is_last_session_for_user (GsmSystemd *manager)
+ gboolean is_last_session;
+ int ret, i;
+
++#ifdef HAVE_SYSTEMD
+ ret = sd_pid_get_session (getpid (), &session);
++#endif
++
++ if (session == NULL) {
++ return FALSE;
++ }
+
+ if (ret != 0) {
++ free (session);
+ return FALSE;
+ }
+
++#ifdef HAVE_SYSTEMD
+ ret = sd_uid_get_sessions (getuid (), FALSE, &sessions);
++#endif
++
++ if (sessions == NULL) {
++ free (session);
++ return FALSE;
++ }
+
+ if (ret <= 0) {
+ free (session);
++ free (sessions);
+ return FALSE;
+ }
+
+@@ -450,7 +465,9 @@ gsm_systemd_is_last_session_for_user (GsmSystemd *manager)
+ if (g_strcmp0 (sessions[i], session) == 0)
+ continue;
+
++#ifdef HAVE_SYSTEMD
+ ret = sd_session_get_state (sessions[i], &state);
++#endif
+
+ if (ret != 0)
+ continue;
+@@ -461,7 +478,9 @@ gsm_systemd_is_last_session_for_user (GsmSystemd *manager)
+ }
+ free (state);
+
++#ifdef HAVE_SYSTEMD
+ ret = sd_session_get_type (sessions[i], &type);
++#endif
+
+ if (ret != 0)
+ continue;
diff --git a/mate-base/mate-session-manager/mate-session-manager-1.22.0.ebuild b/mate-base/mate-session-manager/mate-session-manager-1.22.0.ebuild
index ed715c003091..9b948b230380 100644
--- a/mate-base/mate-session-manager/mate-session-manager-1.22.0.ebuild
+++ b/mate-base/mate-session-manager/mate-session-manager-1.22.0.ebuild
@@ -17,6 +17,8 @@ SLOT="0"
IUSE="debug elibc_FreeBSD gnome-keyring ipv6 systemd +xtrans"
+PATCHES=( "${FILESDIR}"/${P}-fix-systemd-regression.patch )
+
# x11-misc/xdg-user-dirs{,-gtk} are needed to create the various XDG_*_DIRs, and
# create .config/user-dirs.dirs which is read by glib to get G_USER_DIRECTORY_*
# xdg-user-dirs-update is run during login (see 10-user-dirs-update-gnome below).
diff --git a/media-libs/libchamplain/libchamplain-0.12.19.ebuild b/media-libs/libchamplain/libchamplain-0.12.19-r1.ebuild
index 9cecc17634ab..1240a3e7c15c 100644
--- a/media-libs/libchamplain/libchamplain-0.12.19.ebuild
+++ b/media-libs/libchamplain/libchamplain-0.12.19-r1.ebuild
@@ -10,44 +10,52 @@ DESCRIPTION="Clutter based world map renderer"
HOMEPAGE="https://wiki.gnome.org/Projects/libchamplain"
SLOT="0.12"
-LICENSE="LGPL-2"
+LICENSE="LGPL-2.1+"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="+gtk gtk-doc +introspection vala"
-REQUIRED_USE="vala? ( introspection )"
+REQUIRED_USE="
+ vala? ( introspection )
+ gtk-doc? ( gtk )
+" # gtk-doc build gets disabled in meson if gtk widgetry is disabled (no separate libchamplain-gtk gtk-docs anymore)
RDEPEND="
- dev-db/sqlite:3
>=dev-libs/glib-2.38:2
+ >=x11-libs/gtk+-3.0:3
>=media-libs/clutter-1.24:1.0[introspection?]
- media-libs/cogl:=
- >=net-libs/libsoup-2.42:2.4
- >=x11-libs/cairo-1.4
- x11-libs/gtk+:3
gtk? (
x11-libs/gtk+:3[introspection?]
media-libs/clutter-gtk:1.0 )
- introspection? ( dev-libs/gobject-introspection:= )
+ >=x11-libs/cairo-1.4
+ dev-db/sqlite:3
+ >=net-libs/libsoup-2.42:2.4
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ media-libs/cogl:=
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/glib-utils
+ >=dev-util/meson-0.49.0
virtual/pkgconfig
gtk-doc? ( >=dev-util/gtk-doc-1.15 )
vala? ( $(vala_depend) )
"
src_prepare() {
- use vala && vala_src_prepare
xdg_src_prepare
+ use vala && vala_src_prepare
+ # Fix showing inside devhelp (gtkdocdir subdir and name of the module need to match)
+ sed -i -e 's:package_name:package_string:' docs/reference/meson.build || die # https://gitlab.gnome.org/GNOME/libchamplain/merge_requests/7
}
src_configure() {
- # demos are only built, so just disable them
- meson_src_configure \
- -Dmemphis=false \
- -Ddemos=false \
- $(meson_use gtk widgetry) \
- $(meson_use gtk-doc gtk_doc) \
- $(meson_use introspection) \
+ local emesonargs=(
+ -Dmemphis=false # TODO: What's the state of this vector renderer?
+ $(meson_use introspection)
$(meson_use vala vapi)
+ $(meson_use gtk widgetry)
+ $(meson_use gtk-doc gtk_doc)
+ -Ddemos=false # only built, not installed
+ )
+ meson_src_configure
}
diff --git a/media-libs/libchamplain/metadata.xml b/media-libs/libchamplain/metadata.xml
index 996e7cacd217..c119093f59a9 100644
--- a/media-libs/libchamplain/metadata.xml
+++ b/media-libs/libchamplain/metadata.xml
@@ -5,4 +5,10 @@
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
+ <longdescription lang="en">
+ libchamplain is a Gtk widget displaying zoomable and pannable maps that can be
+ loaded from various network sources. It supports overlay layers, markers, and
+ custom elements displayed on top of the maps. The library is written in C but
+ other language mappings are also available thanks to GObject-introspection.
+ </longdescription>
</pkgmetadata>
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.24.0.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.24.0.ebuild
index be4ce15cf475..f77fdc38578f 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.24.0.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.24.0.ebuild
@@ -4,7 +4,7 @@
EAPI=6
CMAKE_MAKEFILE_GENERATOR="ninja"
PYTHON_COMPAT=( python2_7 )
-USE_RUBY="ruby23 ruby24 ruby25"
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
inherit check-reqs cmake-utils flag-o-matic gnome2 pax-utils python-any-r1 ruby-single toolchain-funcs virtualx
diff --git a/profiles/features/selinux/make.defaults b/profiles/features/selinux/make.defaults
index d3bbd2f25dfa..adbf945e3fe3 100644
--- a/profiles/features/selinux/make.defaults
+++ b/profiles/features/selinux/make.defaults
@@ -5,7 +5,7 @@
# selinux - Enable SELinux support
USE="selinux"
-FEATURES="selinux sesandbox sfperms"
+FEATURES="selinux sesandbox sfperms -pid-sandbox"
POLICY_TYPES="strict targeted"
PORTAGE_T="portage_t"