summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-15 11:46:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-15 12:51:07 +0200
commit10e0b56452624f755fbdd00afa892573a2e8e657 (patch)
tree93d5171ddcc3d950e6eac992ba5ed88efcff8722
parentgames-emulation/mupen64plus-ui-console: Bump to 2.6.0 (diff)
downloadgentoo-10e0b56452624f755fbdd00afa892573a2e8e657.tar.gz
gentoo-10e0b56452624f755fbdd00afa892573a2e8e657.tar.bz2
gentoo-10e0b56452624f755fbdd00afa892573a2e8e657.zip
games-emulation/mupen64plus-video-glide64mk2: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--games-emulation/mupen64plus-video-glide64mk2/Manifest1
-rw-r--r--games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.6.0.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-video-glide64mk2/Manifest b/games-emulation/mupen64plus-video-glide64mk2/Manifest
index 602ddf4e193a..1a9e37067d9e 100644
--- a/games-emulation/mupen64plus-video-glide64mk2/Manifest
+++ b/games-emulation/mupen64plus-video-glide64mk2/Manifest
@@ -1,2 +1,3 @@
DIST mupen64plus-video-glide64mk2-2.5.9-boost-1.85.patch 11979 BLAKE2B 5c8b8c839547f5e141a2a2def5b0afc3c69aba84cc7cf65cb447ccc29f91e6e02aa7fb2d30f635f8f7e36e21e4b8cbeffac2301aceb021b09064631dd42b94bd SHA512 239120ce13343bb4d0fe8031db893b873fccebfe60926a41b2d5af94b376ba4ef79292c645d14eba50ef433e33d4fea538a46ded6ef3c2c2017c4efe83d55fa6
DIST mupen64plus-video-glide64mk2-src-2.5.9.tar.gz 498350 BLAKE2B 8378cfc9fe624b3441e290d44d600e30a85393aca5a5a5867fb778a665ea0718ae15ba67ce5b62930cd4feffb7b1ddce88be6434de9791c82a979aa8f022ecd1 SHA512 cc4cce1a1f036cdda0748cf9eb758f21ba08dbe83a2844cf92d3e781102aaa3556934ca01dbae248a2d93c65209932b858988030beaa29395d79df70bf479bd4
+DIST mupen64plus-video-glide64mk2-src-2.6.0.tar.gz 503590 BLAKE2B ec07c4f699aa09a2b104a8aca169c900dc02ab546353d7f0a69e5b6a5af12999c8fd97fe8f6e1d2376e31402352b209a2da905aa54a635a0c728a025270a9d51 SHA512 40bd28e417f55ceefe370db5bb08d84cd588a955def2522a760545fd7e626e5301115b0072e88e5ad2960ede831ae6cb41ece1a65f86e9ce081e6753e60e161e
diff --git a/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.6.0.ebuild b/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.6.0.ebuild
new file mode 100644
index 000000000000..fb1e335c07ec
--- /dev/null
+++ b/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.6.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P=${PN}-src-${PV}
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, glide64mk2 video plugin"
+HOMEPAGE="https://www.mupen64plus.org/"
+SRC_URI="
+ https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+# TODO: 3dfx licenses
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gles2-only hires cpu_flags_x86_sse"
+
+DEPEND="
+ >=games-emulation/mupen64plus-core-2.5:0=[gles2-only=]
+ media-libs/libpng:0=
+ media-libs/libsdl2:0=[video]
+ sys-libs/zlib:0=
+ virtual/opengl:0=
+ gles2-only? ( media-libs/libsdl2:0[gles2] )
+ hires? ( dev-libs/boost:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+
+ NOSSE=$(usex cpu_flags_x86_sse 0 1)
+ HIRES=$(usex hires 1 0)
+ USE_FRAMESKIPPER=1
+ USE_GLES=$(usex gles2-only 1 0)
+ # use bundled lib
+ # https://bugs.gentoo.org/654470
+ TXCDXTN=0
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ dodoc RELEASE
+}