summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-04-15 18:29:53 +0000
committerJimi Huotari <chiitoo@gentoo.org>2023-04-18 01:05:03 +0300
commit19ad05fc5ae774a2f95604b2c2137b006b72111e (patch)
tree7f0e5ee682f56a41ec2165ce3fcaac3212b4f52d
parentapp-doc/eclass-manpages: drop 20230222 (diff)
downloadgentoo-19ad05fc5ae774a2f95604b2c2137b006b72111e.tar.gz
gentoo-19ad05fc5ae774a2f95604b2c2137b006b72111e.tar.bz2
gentoo-19ad05fc5ae774a2f95604b2c2137b006b72111e.zip
dev-util/lxqt-build-tools: add 0.13.0
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--dev-util/lxqt-build-tools/Manifest1
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.13.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
index 0e8d7a36b614..4c9cab7e1ce5 100644
--- a/dev-util/lxqt-build-tools/Manifest
+++ b/dev-util/lxqt-build-tools/Manifest
@@ -1 +1,2 @@
DIST lxqt-build-tools-0.12.0.tar.xz 25444 BLAKE2B a3e2d942467d1c2affb957052731f4e4edfa03ed7d84e4ff354b4d501a7f79999ff678538f1c90cff55b6f2f80c172820ed93f036f05cd80c6f982c4bf8bbe54 SHA512 6c8f0d8f04a2ba06c1cff935580a88312f18f87b5da99e53f46c053b842f179bf474b3637ddcb0e9a0007f1d03b9e7cfd92a6552e53082ce34348fcfb6436add
+DIST lxqt-build-tools-0.13.0.tar.xz 25480 BLAKE2B aebbcb55851b0acc00bf4d34e3846e12a3d503e4f7238ba57d7d6b3df44ccd8e6dbe5fc1986ed722dfd4384ad17f22be14fa0c6270b3ed385ae7cd4ff5711e3e SHA512 ffb300159d6bbbdbe9d43d261a5028342f24057c943cf8dab5093d53b72bf5700de8f545914d454993e949d64aba77e3d01cbe68e8a4b4f6ca9f9f9693de3e0b
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.13.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.13.0.ebuild
new file mode 100644
index 000000000000..8c41191e3c2a
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.13.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=dev-qt/qtcore-5.15:5
+"
+RDEPEND="${DEPEND}"