summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-20 02:47:32 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-20 03:29:14 +0200
commit225596132e1a98c8b5f038850b7cd61f65222d90 (patch)
tree5a465fbfab54885981de3ea69e2badbd9a8e1365
parentmedia-libs/noise-suppression-for-voice: drop 1.10-r1 (diff)
downloadgentoo-225596132e1a98c8b5f038850b7cd61f65222d90.tar.gz
gentoo-225596132e1a98c8b5f038850b7cd61f65222d90.tar.bz2
gentoo-225596132e1a98c8b5f038850b7cd61f65222d90.zip
dev-python/botocore: Bump to 1.35.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index d07d74e04fbc..7abb12fc65d7 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.34.153.gh.tar.gz 13269606 BLAKE2B 1b2ec1af3b699c18c5761fe72b8488361f843e1b2abc5f311736e7c93a52574738a8e72708791657d0d86586d64ee3c85804514779c6dc75c6c2e37035517be1 SHA512 9a7b3359f4304bcb4d3605e2516514360e8898d7b8b1fdee8fab5dc6026a7d8197b09199da4e9aefcf1ab0b094a2e0e336ad13942ce0364f7b5ac87d86fdc4fd
DIST botocore-1.34.158.gh.tar.gz 13282704 BLAKE2B c244a36093cdaf57ac82dc11a3e9d4268d7cce36b8119674530228825f6ec4053abbc909dd664a1ea10ec48e0c418b90803275aabc89a41a99eaba6e138a5a17 SHA512 b60c743bfd1a1f3806c6ae71158a998587b8e87f43bdbe88c960cee19bcef41a4b3fd2fe5f50408abc97b22200a689990f79cbb6e952347c747e4bc8c21ae368
DIST botocore-1.35.0.gh.tar.gz 13294975 BLAKE2B a0cbafd1b0da5cd7150ea7a2e21b1209b206b7afcb86ad3ff004ca1c96f47da34eff29a43568f0e9a2dca3443516fdb6adf7bd3778835b908fa5fb3a8d22f79a SHA512 7d0c9815703ef49a8958ed1a5159018320108ae86efe20e6dff182db24ceeb67968db7027ee75809a1ebd1c835709d0d758b0699742bca2e435888dbe5e15a97
+DIST botocore-1.35.1.gh.tar.gz 13301129 BLAKE2B 70c99036e54331a63107c5c031cd32c59150ef2aa6fd9bf90bb4fe2a8d7eaed38d0a7df96c0ac1b973a14490e061e63e04dba873382cb2d69cbe2bf8b312a765 SHA512 92e4e6081bb7ee491acdc92356a2e661af02bb4b1a73d372dcdb1de913d89adfe0a1b3b16b1d4754e79601f051b4d2fab54d7512f3ca9d972b2256811cc704f0
diff --git a/dev-python/botocore/botocore-1.35.1.ebuild b/dev-python/botocore/botocore-1.35.1.ebuild
new file mode 100644
index 000000000000..4f1ad852bdc1
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # memory use tests, probably fragile
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}