summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRolf Eike Beer <eike@sf-mail.de>2020-09-04 17:10:43 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-04 17:52:53 +0200
commit263e74d27b2f17fe2ed00b0fb4a66d0354ee0808 (patch)
tree89fd2f19c82c65210072e4411ee3ef31cced91ee
parentnet-mail/queue-repair: mark it allarches (diff)
downloadgentoo-263e74d27b2f17fe2ed00b0fb4a66d0354ee0808.tar.gz
gentoo-263e74d27b2f17fe2ed00b0fb4a66d0354ee0808.tar.bz2
gentoo-263e74d27b2f17fe2ed00b0fb4a66d0354ee0808.zip
net-mail/queue-repair: "port" it to python3
Closes: https://bugs.gentoo.org/723250 Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> Closes: https://github.com/gentoo/gentoo/pull/17414 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild b/net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild
new file mode 100644
index 000000000000..a67868c14c27
--- /dev/null
+++ b/net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1
+
+DESCRIPTION="A toolkit for dealing with the qmail queue directory structure"
+HOMEPAGE="http://pyropus.ca/software/queue-repair/"
+SRC_URI="http://pyropus.ca/software/queue-repair/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test" # no tests
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+DOCS=( BLURB TODO CHANGELOG )
+
+src_prepare() {
+ eapply_user
+
+ 2to3 -n -w --no-diffs queue_repair.py || die
+}
+
+src_install() {
+ python_newscript queue_repair.py queue-repair.py
+ dosym queue-repair.py /usr/bin/queue-repair
+ einstalldocs
+}