summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2025-01-03 12:02:22 +0100
committerAlfredo Tupone <tupone@gentoo.org>2025-01-03 12:04:50 +0100
commit2888c802648b5acd30e2c4c36f087238956e20da (patch)
treeec48406e03d21c68954bc402232dd64330bb07b3
parentsys-libs/musl: Stabilize 1.2.5-r1 ppc64, #947377 (diff)
downloadgentoo-2888c802648b5acd30e2c4c36f087238956e20da.tar.gz
gentoo-2888c802648b5acd30e2c4c36f087238956e20da.tar.bz2
gentoo-2888c802648b5acd30e2c4c36f087238956e20da.zip
dev-ada/aunit: add 25.0.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ada/aunit/Manifest1
-rw-r--r--dev-ada/aunit/aunit-25.0.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-ada/aunit/Manifest b/dev-ada/aunit/Manifest
index 97dfb1cebd19..3f2ef57d00ae 100644
--- a/dev-ada/aunit/Manifest
+++ b/dev-ada/aunit/Manifest
@@ -1 +1,2 @@
DIST aunit-24.0.0.tar.gz 131699 BLAKE2B e43e7a94b278597475767d93f28a95a586abeaf45d141ea7035df9cb45d1be67c189a5be3d0364943b4649270f8f96d7cfd20fcba7a28917b14266c9e9424815 SHA512 25b973d1eb35e9e15ed24abe9c4ad7165d684c0e72abe619dcb9bec04cef8b28c78c1994e96e4bc29fd3b06567e15360f47ac87f49e1fa9888f55675defc226f
+DIST aunit-25.0.0.tar.gz 137452 BLAKE2B 91672bbdd86cc502456b681e9418f04dfc7dfc380ed9f9f69af36afb5e3b5ce22852a4fa92049ee5d9fade1439a6a4508e3d6f63b1005ae6f0e1d5cbfaa70118 SHA512 080d61c1c3b0707c291dce476573e05a247c198c2bea4ae311677dcae826e7bf34571700711b28ac46bd021e93c252492bafcb4892b24b45c7396d6b7e7b5f2d
diff --git a/dev-ada/aunit/aunit-25.0.0.ebuild b/dev-ada/aunit/aunit-25.0.0.ebuild
new file mode 100644
index 000000000000..9d721fb12fb2
--- /dev/null
+++ b/dev-ada/aunit/aunit-25.0.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ADA_COMPAT=( gnat_2021 gcc_12 gcc_13 )
+inherit ada multiprocessing
+
+DESCRIPTION="Ada unit testing framework"
+HOMEPAGE="https://github.com/AdaCore/aunit"
+SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="${ADA_DEPS}"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild[${ADA_USEDEP}]"
+BDEPEND="doc? (
+ dev-tex/latexmk
+ dev-texlive/texlive-latexextra
+ dev-python/sphinx
+ dev-python/sphinx-rtd-theme
+)"
+
+REQUIRED_USE="${ADA_REQUIRED_USE}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s|@PF@|${PF}|g" \
+ lib/gnat/aunit.gpr \
+ || die
+}
+
+src_compile() {
+ emake GPROPTS_EXTRA="-j$(makeopts_jobs) -v -cargs ${ADAFLAGS}"
+ use doc && emake -C doc all
+}
+
+src_install() {
+ emake INSTALL="${D}"/usr install
+ DOCS="README"
+ if use doc; then
+ DOCS+=" doc/build/aunit_cb/pdf/aunit_cb.pdf"
+ DOCS+=" doc/build/aunit_cb/txt/aunit_cb.txt"
+ HTML_DOCS="doc/build/aunit_cb/html"
+ fi
+ einstalldocs
+ if use doc; then
+ insinto /usr/share/info
+ doins doc/build/aunit_cb/info/aunit_cb.info
+ docompress -x /usr/share/info
+ fi
+ mv "${D}"/usr/share/examples "${D}"/usr/share/doc/${PF}/
+ rm -r "${D}"/usr/share/gpr/manifests || die
+}
+
+src_test() {
+ emake PROJECT_PATH_ARG="ADA_PROJECT_PATH=$(pwd)/lib/gnat" -C test
+}