summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-19 08:06:32 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-19 10:42:47 +0100
commit3debf680824083c46bf81d046bd44883c40db151 (patch)
treeda2b79f37c2f2ebdd975eb3bc8fad6171b946109
parentdev-python/autocommand: Bump to 2.2.2 (diff)
downloadgentoo-3debf680824083c46bf81d046bd44883c40db151.tar.gz
gentoo-3debf680824083c46bf81d046bd44883c40db151.tar.bz2
gentoo-3debf680824083c46bf81d046bd44883c40db151.zip
dev-python/python-slugify: Bump to 7.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-slugify/Manifest1
-rw-r--r--dev-python/python-slugify/python-slugify-7.0.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index 962fe829659c..d8a7417dd4fd 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1 +1,2 @@
DIST python-slugify-6.1.2.tar.gz 13302 BLAKE2B 600ac1cc37cd0001ca3c08cdccb4655dd3754f7673596eada2dfb6adcb6c190f0e5644bd1cba4debf0fae42ae183b3d81acdcc09270e3ade94076d69ba25895a SHA512 3748c18d469032fc002318fbd5730b96a6f8430ff7b0b1a9afb4c19d4dd8e7528400682fa6b2fcc11ec4230917d7e7f61de290f5b199935d77d5335006af0ffb
+DIST python-slugify-7.0.0.gh.tar.gz 13257 BLAKE2B 6d50fd25ac89caed3a970f4cce786d9b61de68386fc183659c0d884877edc934e121ad07316259af08deb61a30ac33f0076a90b2d5a650dfb113e6b6416addfe SHA512 c22743a28ffb273546541eaf59d2a7beb9070a7f81e504acaf73d220c2be83a87d02012b5841076539ba6bae5778dd47309ee7ceef9f8479c993dda6b3e09837
diff --git a/dev-python/python-slugify/python-slugify-7.0.0.ebuild b/dev-python/python-slugify/python-slugify-7.0.0.ebuild
new file mode 100644
index 000000000000..a12154fd4646
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-7.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="
+ https://github.com/un33k/python-slugify/
+ https://pypi.org/project/python-slugify/
+"
+SRC_URI="
+ https://github.com/un33k/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/text-unidecode[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest