summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-14 17:56:15 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-14 17:58:28 +0200
commit42c8a9c6444e5fe26ba34a726351e9b38c90e267 (patch)
tree499efbfc6e2e54270ac950034233b38de419ec72
parentdev-python/pip-run: Enable py3.13 (diff)
downloadgentoo-42c8a9c6444e5fe26ba34a726351e9b38c90e267.tar.gz
gentoo-42c8a9c6444e5fe26ba34a726351e9b38c90e267.tar.bz2
gentoo-42c8a9c6444e5fe26ba34a726351e9b38c90e267.zip
dev-python/setuptools: Enable testing on py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools/files/setuptools-69.5.1-py313.patch30
-rw-r--r--dev-python/setuptools/setuptools-69.5.1-r1.ebuild8
2 files changed, 35 insertions, 3 deletions
diff --git a/dev-python/setuptools/files/setuptools-69.5.1-py313.patch b/dev-python/setuptools/files/setuptools-69.5.1-py313.patch
new file mode 100644
index 000000000000..7222d3dba266
--- /dev/null
+++ b/dev-python/setuptools/files/setuptools-69.5.1-py313.patch
@@ -0,0 +1,30 @@
+From c6266e423fa26aafa01f1df71de7c6613273155e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Tue, 14 May 2024 16:24:07 +0200
+Subject: [PATCH] Make the validation test for entry-points work with Python
+ 3.13+
+
+The exception in importlib.metadata has changed.
+See https://github.com/python/importlib_metadata/issues/488
+
+This makes an existing test pass with Python 3.13.
+
+Partially fixes https://github.com/pypa/setuptools/issues/4196
+---
+ setuptools/_entry_points.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/setuptools/_entry_points.py b/setuptools/_entry_points.py
+index 747a69067e..b244e78387 100644
+--- a/setuptools/_entry_points.py
++++ b/setuptools/_entry_points.py
+@@ -17,7 +17,8 @@ def ensure_valid(ep):
+ """
+ try:
+ ep.extras
+- except AttributeError as ex:
++ except (AttributeError, AssertionError) as ex:
++ # Why both? See https://github.com/python/importlib_metadata/issues/488
+ msg = (
+ f"Problems to parse {ep}.\nPlease ensure entry-point follows the spec: "
+ "https://packaging.python.org/en/latest/specifications/entry-points/"
diff --git a/dev-python/setuptools/setuptools-69.5.1-r1.ebuild b/dev-python/setuptools/setuptools-69.5.1-r1.ebuild
index dec59bb85752..80af914ad532 100644
--- a/dev-python/setuptools/setuptools-69.5.1-r1.ebuild
+++ b/dev-python/setuptools/setuptools-69.5.1-r1.ebuild
@@ -7,7 +7,7 @@ EAPI=8
# please bump dev-python/ensurepip-setuptools along with this package!
DISTUTILS_USE_PEP517=standalone
-PYTHON_TESTED=( python3_{10..12} pypy3 )
+PYTHON_TESTED=( python3_{10..13} pypy3 )
PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" python3_13 )
PYTHON_REQ_USE="xml(+)"
@@ -42,7 +42,6 @@ BDEPEND="
test? (
$(python_gen_cond_dep '
dev-python/build[${PYTHON_USEDEP}]
- dev-python/importlib-metadata[${PYTHON_USEDEP}]
>=dev-python/ini2toml-0.9[${PYTHON_USEDEP}]
>=dev-python/filelock-3.4.0[${PYTHON_USEDEP}]
>=dev-python/jaraco-envs-2.2[${PYTHON_USEDEP}]
@@ -70,7 +69,10 @@ PDEPEND="
src_prepare() {
local PATCHES=(
# TODO: remove this when we're 100% PEP517 mode
- "${FILESDIR}"/setuptools-62.4.0-py-compile.patch
+ "${FILESDIR}/setuptools-62.4.0-py-compile.patch"
+
+ # https://github.com/pypa/setuptools/pull/4357
+ "${FILESDIR}/${P}-py313.patch"
)
distutils-r1_src_prepare