summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-10-13 07:37:33 +0200
committerHans de Graaff <graaff@gentoo.org>2023-10-13 07:37:33 +0200
commit544e16bda6effaa920703635d2cef5ddd7fbad05 (patch)
treeb74a116234e2637bb85a94e34e3c3cff3134f121
parentdev-ruby/bigdecimal: fix gemspec (diff)
downloadgentoo-544e16bda6effaa920703635d2cef5ddd7fbad05.tar.gz
gentoo-544e16bda6effaa920703635d2cef5ddd7fbad05.tar.bz2
gentoo-544e16bda6effaa920703635d2cef5ddd7fbad05.zip
dev-ruby/bigdecimal: drop 3.1.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/bigdecimal/bigdecimal-3.1.4.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-ruby/bigdecimal/bigdecimal-3.1.4.ebuild b/dev-ruby/bigdecimal/bigdecimal-3.1.4.ebuild
deleted file mode 100644
index 4370cfc03906..000000000000
--- a/dev-ruby/bigdecimal/bigdecimal-3.1.4.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby31 ruby32"
-
-RUBY_FAKEGEM_BINWRAP=""
-RUBY_FAKEGEM_EXTENSIONS=(ext/bigdecimal/extconf.rb)
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-RUBY_FAKEGEM_GEMSPEC="bigdecimal.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Arbitrary-precision decimal floating-point number library for Ruby"
-HOMEPAGE="https://github.com/ruby/bigdecimal"
-SRC_URI="https://github.com/ruby/bigdecimal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( Ruby-BSD BSD-2 )"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-SLOT="0"
-IUSE="test"
-
-all_ruby_prepare() {
- sed -e '/^source_version/,/^end/ s:^:#:' \
- -e "/s.version/ s/= source_version/= '${PV}'/" \
- -i ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -rtest/lib/helper -e "Dir['test/**/test_*.rb'].each { require _1 }" || die
-}