summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2017-02-17 20:48:33 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2017-02-17 20:48:33 +0000
commit56552f9967090147203e6291d26f987bbc7db319 (patch)
tree6134a96b99eb62d1a4dcffa3f5e6fb17e7b0f16a
parent2017-02-17 20:22:45 UTC (diff)
parentapp-text/ghostscript-gpl: Rename and clarify idn useflag, bug 578862 (diff)
downloadgentoo-56552f9967090147203e6291d26f987bbc7db319.tar.gz
gentoo-56552f9967090147203e6291d26f987bbc7db319.tar.bz2
gentoo-56552f9967090147203e6291d26f987bbc7db319.zip
Merge updates from master
-rw-r--r--app-text/ghostscript-gpl/ghostscript-gpl-9.20-r2.ebuild247
-rw-r--r--app-text/ghostscript-gpl/metadata.xml3
-rw-r--r--eclass/distutils-r1.eclass4
-rw-r--r--eclass/python-r1.eclass16
-rw-r--r--eclass/python-single-r1.eclass22
-rw-r--r--media-libs/lv2/Manifest1
-rw-r--r--media-libs/lv2/lv2-1.10.0.ebuild44
-rw-r--r--media-libs/lv2/lv2-1.8.0.ebuild44
-rw-r--r--sys-apps/paludis/Manifest1
-rw-r--r--sys-apps/paludis/files/paludis-2.0.0-fix-format-security.patch66
-rw-r--r--sys-apps/paludis/paludis-2.0.0.ebuild162
-rw-r--r--www-apps/scgi/scgi-1.14-r1.ebuild (renamed from www-apps/scgi/scgi-1.14.ebuild)15
-rw-r--r--www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899-r1.ebuild (renamed from www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899.ebuild)16
-rw-r--r--www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild (renamed from www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206.ebuild)16
-rw-r--r--www-apps/trac-tags/trac-tags-0.6-r1.ebuild (renamed from www-apps/trac-tags/trac-tags-0.6.ebuild)16
15 files changed, 280 insertions, 393 deletions
diff --git a/app-text/ghostscript-gpl/ghostscript-gpl-9.20-r2.ebuild b/app-text/ghostscript-gpl/ghostscript-gpl-9.20-r2.ebuild
new file mode 100644
index 000000000000..c030a612360b
--- /dev/null
+++ b/app-text/ghostscript-gpl/ghostscript-gpl-9.20-r2.ebuild
@@ -0,0 +1,247 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools multilib versionator flag-o-matic toolchain-funcs
+
+DESCRIPTION="Ghostscript is an interpreter for the PostScript language and for PDF"
+HOMEPAGE="http://ghostscript.com/"
+
+# Maintainer notes about djvu support:
+# gsdjvu has not seen any commits since July 2016, which was also roughly the time
+# when ghostscript started rearranging internals. Issues I found so far:
+# * gs_state and gs_imager_state got unified into gs_gstate
+# * decode_glyph changed arguments and semantics (it doesnt give you the unicode now,
+# but the length of the required byte array, which you have to allocate and fill)
+# * gs_text_enum_t has lost its element pis (???)
+
+MY_P=${P/-gpl}
+# GSDJVU_PV=1.9
+PVM=$(get_version_component_range 1-2)
+PVM_S=$(replace_all_version_separators "" ${PVM})
+# SRC_URI="
+# https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${PVM_S}/${MY_P}.tar.xz
+# mirror://gentoo/${PN}-9.20-patchset-1.tar.xz
+# djvu? ( mirror://sourceforge/djvu/gsdjvu-${GSDJVU_PV}.tar.gz )"
+SRC_URI="
+ https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${PVM_S}/${MY_P}.tar.xz
+ https://dev.gentoo.org/~dilfridge/distfiles/${PN}-9.20-patchset-2.tar.xz
+"
+
+LICENSE="AGPL-3 CPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+# IUSE="cups dbus djvu gtk l10n_de static-libs tiff unicode X"
+IUSE="cups dbus gtk l10n_de static-libs tiff unicode X"
+# RESTRICT="djvu? ( bindist )"
+
+COMMON_DEPEND="
+ app-text/libpaper
+ media-libs/fontconfig
+ >=media-libs/freetype-2.4.9:2=
+ media-libs/jbig2dec
+ >=media-libs/lcms-2.6:2
+ >=media-libs/libpng-1.6.2:0=
+ >=media-libs/openjpeg-2.1.0:2=
+ >=sys-libs/zlib-1.2.7:=
+ virtual/jpeg:0
+ cups? ( >=net-print/cups-1.3.8 )
+ dbus? ( sys-apps/dbus )
+ gtk? ( || ( x11-libs/gtk+:3 x11-libs/gtk+:2 ) )
+ unicode? ( net-dns/libidn )
+ tiff? ( >=media-libs/tiff-4.0.1:0= )
+ X? ( x11-libs/libXt x11-libs/libXext )
+"
+# djvu? ( app-text/djvu )
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+RDEPEND="${COMMON_DEPEND}
+ >=app-text/poppler-data-0.4.5-r1
+ >=media-fonts/urw-fonts-2.4.9
+ l10n_ja? ( media-fonts/kochi-substitute )
+ l10n_ko? ( media-fonts/baekmuk-fonts )
+ l10n_zh-CN? ( media-fonts/arphicfonts )
+ l10n_zh-TW? ( media-fonts/arphicfonts )
+ !!media-fonts/gnu-gs-fonts-std
+ !!media-fonts/gnu-gs-fonts-other
+ !<net-print/cups-filters-1.0.36-r2
+"
+
+S="${WORKDIR}/${MY_P}"
+
+LANGS="ja ko zh-CN zh-TW"
+for X in ${LANGS} ; do
+ IUSE="${IUSE} l10n_${X}"
+done
+
+src_prepare() {
+ default
+
+ # remove internal copies of various libraries
+ rm -rf "${S}"/cups/libs || die
+ rm -rf "${S}"/expat || die
+ rm -rf "${S}"/freetype || die
+ rm -rf "${S}"/jbig2dec || die
+ rm -rf "${S}"/jpeg{,xr} || die
+ rm -rf "${S}"/lcms{,2} || die
+ rm -rf "${S}"/libpng || die
+ rm -rf "${S}"/tiff || die
+ rm -rf "${S}"/zlib || die
+ rm -rf "${S}"/openjpeg || die
+ # remove internal CMaps (CMaps from poppler-data are used instead)
+ rm -rf "${S}"/Resource/CMap || die
+
+ # apply various patches, many borrowed from Fedora
+ # http://pkgs.fedoraproject.org/cgit/ghostscript.git
+ eapply "${WORKDIR}/patches/"*.patch
+
+# if use djvu ; then
+# unpack gsdjvu-${GSDJVU_PV}.tar.gz
+#
+# local gsdjvu_base=devices
+# local gsdjvu_msed='-e s/@@djvu@@/DEV/g'
+#
+# cp gsdjvu-${GSDJVU_PV}/gdevdjvu.c "${S}"/${gsdjvu_base} || die
+#
+# cp gsdjvu-${GSDJVU_PV}/ps2utf8.ps "${S}"/lib || die
+#
+# cp gsdjvu-${GSDJVU_PV}/gsdjvu "${S}" || die
+# cp "${S}"/${gsdjvu_base}/contrib.mak "${S}"/${gsdjvu_base}/contrib.mak.gsdjvu || die
+# grep -q djvusep "${S}"/${gsdjvu_base}/contrib.mak || \
+# sed ${gsdjvu_msed} < gsdjvu-${GSDJVU_PV}/gsdjvu.mak >> "${S}"/${gsdjvu_base}/contrib.mak || die
+#
+## # install ps2utf8.ps, bug #197818
+## sed -i -e '/$(EXTRA_INIT_FILES)/ a\ps2utf8.ps \\' \
+## "${S}"/base/unixinst.mak || die "sed failed"
+# fi
+
+ if ! use gtk ; then
+ sed -i -e "s:\$(GSSOX)::" \
+ -e "s:.*\$(GSSOX_XENAME)$::" \
+ "${S}"/base/unix-dll.mak || die "sed failed"
+ fi
+
+ # Force the include dirs to a neutral location.
+ sed -i \
+ -e "/^ZLIBDIR=/s:=.*:=${T}:" \
+ configure.ac || die
+ # Some files depend on zlib.h directly. Redirect them. #573248
+ # Also make sure to not define OPJ_STATIC to avoid linker errors due to
+ # hidden symbols (https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203327#c1)
+ sed -i \
+ -e '/^zlib_h/s:=.*:=:' \
+ -e 's|-DOPJ_STATIC ||' \
+ base/lib.mak || die
+
+ # search path fix
+ # put LDFLAGS after BINDIR, bug #383447
+ sed -i -e "s:\$\(gsdatadir\)/lib:@datarootdir@/ghostscript/${PVM}/$(get_libdir):" \
+ -e "s:exdir=.*:exdir=@datarootdir@/doc/${PF}/examples:" \
+ -e "s:docdir=.*:docdir=@datarootdir@/doc/${PF}/html:" \
+ -e "s:GS_DOCDIR=.*:GS_DOCDIR=@datarootdir@/doc/${PF}/html:" \
+ -e 's:-L$(BINDIR):& $(LDFLAGS):g' \
+ "${S}"/Makefile.in "${S}"/base/*.mak || die "sed failed"
+
+ cd "${S}" || die
+ # remove incorrect symlink, bug 590384
+ rm -f ijs/ltmain.sh || die
+ eautoreconf
+
+ cd "${S}/ijs" || die
+ eautoreconf
+}
+
+src_configure() {
+ local FONTPATH
+ for path in \
+ /usr/share/fonts/urw-fonts \
+ /usr/share/fonts/Type1 \
+ /usr/share/fonts \
+ /usr/share/poppler/cMap/Adobe-CNS1 \
+ /usr/share/poppler/cMap/Adobe-GB1 \
+ /usr/share/poppler/cMap/Adobe-Japan1 \
+ /usr/share/poppler/cMap/Adobe-Japan2 \
+ /usr/share/poppler/cMap/Adobe-Korea1
+ do
+ FONTPATH="$FONTPATH${FONTPATH:+:}${EPREFIX}$path"
+ done
+
+ PKGCONFIG=$(type -P $(tc-getPKG_CONFIG)) \
+ econf \
+ --enable-dynamic \
+ --enable-freetype \
+ --enable-fontconfig \
+ --enable-openjpeg \
+ --disable-compile-inits \
+ --with-drivers=ALL \
+ --with-fontpath="$FONTPATH" \
+ --with-ijs \
+ --with-jbig2dec \
+ --with-libpaper \
+ --without-luratech \
+ $(use_enable cups) \
+ $(use_enable dbus) \
+ $(use_enable gtk) \
+ $(use_with cups pdftoraster) \
+ $(use_with unicode libidn) \
+ $(use_with tiff system-libtiff) \
+ $(use_with X x)
+
+# if use djvu ; then
+# sed -i -e 's!$(DD)bbox.dev!& $(DD)djvumask.dev $(DD)djvusep.dev!g' \
+# "${S}"/Makefile || die "sed failed"
+# fi
+
+ cd "${S}/ijs" || die
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake so all
+
+ cd "${S}/ijs" || die
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-so install
+
+# use djvu && dobin gsdjvu
+
+ # move gsc to gs, bug #343447
+ # gsc collides with gambit, bug #253064
+ mv -f "${ED}"/usr/bin/{gsc,gs} || die
+
+ cd "${S}/ijs" || die
+ emake DESTDIR="${D}" install
+
+ # rename the original cidfmap to cidfmap.GS
+ mv "${ED}/usr/share/ghostscript/${PVM}/Resource/Init/cidfmap"{,.GS} || die
+
+ # install our own cidfmap to handle CJK fonts
+ insinto /usr/share/ghostscript/${PVM}/Resource/Init
+ doins \
+ "${WORKDIR}/fontmaps/CIDFnmap" \
+ "${WORKDIR}/fontmaps/cidfmap"
+ for X in ${LANGS} ; do
+ if use l10n_${X} ; then
+ doins "${WORKDIR}/fontmaps/cidfmap.${X/-/_}"
+ fi
+ done
+
+ # install the CMaps from poppler-data properly, bug #409361
+ dosym /usr/share/poppler/cMaps /usr/share/ghostscript/${PVM}/Resource/CMap
+
+ use static-libs || prune_libtool_files --all
+
+ if ! use l10n_de; then
+ rm -r "${ED}"/usr/share/man/de || die
+ fi
+}
diff --git a/app-text/ghostscript-gpl/metadata.xml b/app-text/ghostscript-gpl/metadata.xml
index 503a83f6bcfb..842d89a95167 100644
--- a/app-text/ghostscript-gpl/metadata.xml
+++ b/app-text/ghostscript-gpl/metadata.xml
@@ -8,4 +8,7 @@
<upstream>
<remote-id type="sourceforge">djvu</remote-id>
</upstream>
+ <use>
+ <flag name="unicode">Add support for unicode passwords via <pkg>net-dns/libidn</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 68151afae52d..202b47757a64 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -44,10 +44,10 @@
# https://wiki.gentoo.org/wiki/Project:Python/distutils-r1
case "${EAPI:-0}" in
- 0|1|2|3)
+ 0|1|2|3|4)
die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}"
;;
- 4|5|6)
+ 5|6)
;;
*)
die "Unsupported EAPI=${EAPI} (unknown) for ${ECLASS}"
diff --git a/eclass/python-r1.eclass b/eclass/python-r1.eclass
index a117a5a82ff2..702fa288096e 100644
--- a/eclass/python-r1.eclass
+++ b/eclass/python-r1.eclass
@@ -30,23 +30,9 @@
# https://wiki.gentoo.org/wiki/Project:Python/python-r1
case "${EAPI:-0}" in
- 0|1|2|3)
+ 0|1|2|3|4)
die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}"
;;
- 4)
- # EAPI=4 is only allowed on legacy packages
- if [[ ${CATEGORY}/${P} == dev-python/pyelftools-0.2[123] ]]; then
- :
- elif [[ ${CATEGORY}/${P} == sys-apps/file-5.22 ]]; then
- :
- elif [[ ${CATEGORY}/${P} == sys-apps/i2c-tools-3.1.1 ]]; then
- :
- elif [[ ${CATEGORY}/${P} == sys-libs/cracklib-2.9.[12] ]]; then
- :
- else
- die "Unsupported EAPI=${EAPI:-4} (too old, allowed only on restricted set of packages) for ${ECLASS}"
- fi
- ;;
5|6)
# EAPI=5 is required for sane USE_EXPAND dependencies
;;
diff --git a/eclass/python-single-r1.eclass b/eclass/python-single-r1.eclass
index 16102816f148..db08cab1e85c 100644
--- a/eclass/python-single-r1.eclass
+++ b/eclass/python-single-r1.eclass
@@ -32,29 +32,9 @@
# https://wiki.gentoo.org/wiki/Project:Python/python-single-r1
case "${EAPI:-0}" in
- 0|1|2|3)
+ 0|1|2|3|4)
die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}"
;;
- 4)
- # EAPI=4 is only allowed on legacy packages
- if [[ ${CATEGORY}/${P} == app-arch/threadzip-1.2 ]]; then
- :
- elif [[ ${CATEGORY}/${P} == media-libs/lv2-1.8.0 ]]; then
- :
- elif [[ ${CATEGORY}/${P} == media-libs/lv2-1.10.0 ]]; then
- :
- elif [[ ${CATEGORY}/${P} == sys-apps/paludis-1* ]]; then
- :
- elif [[ ${CATEGORY}/${P} == sys-apps/paludis-2.[02].0 ]]; then
- :
- elif [[ ${CATEGORY}/${P} == sys-apps/util-linux-2.2[456]* ]]; then
- :
- elif [[ ${CATEGORY}/${P} == */gdb-7.[78]* ]]; then
- :
- else
- die "Unsupported EAPI=${EAPI:-4} (too old, allowed only on restricted set of packages) for ${ECLASS}"
- fi
- ;;
5|6)
# EAPI=5 is required for sane USE_EXPAND dependencies
;;
diff --git a/media-libs/lv2/Manifest b/media-libs/lv2/Manifest
index b78f428feec2..a662ef553307 100644
--- a/media-libs/lv2/Manifest
+++ b/media-libs/lv2/Manifest
@@ -1,4 +1,3 @@
DIST lv2-1.10.0.tar.bz2 422018 SHA256 e80c8e4b45d4de3b09f26d76e39d454739b6aff3f444ea1dabe466ab530fa4d5 SHA512 e7704101a3ef95a235e76fde862c94c605769c862e4ffd059e4059245f1a1402e4c2b0e7265797fefb5cfc67d3724c815acf6ef3a31d5eab52162a62a303ee5c WHIRLPOOL 50e1bf06c294391fbab85d0ba276730900e5758b0056a210438c785f387648921093f82dc25081aef09378098166b318600eedd8d1a551bc985f71e60bdd4d62
DIST lv2-1.12.0.tar.bz2 399666 SHA256 7a4a53138f10ed997174c8bc5a8573d5f5a5d8441aaac2de6cf2178ff90658e9 SHA512 acc5e05eeeb5291fe5b64e30b5c00a6ef7136922fab7846efc05ccacdeff4d7714f705e632d5b3f6a5314cb3a7b847528fd717fc9ebb5d6f39653c53ac261f85 WHIRLPOOL 063b0c6b7d42f010bc6b6914902c00b7e79f534a2dd8100b88010460cee88bb61d10820f537fa035fb358e60ae760de2a66b32bd9de4b34cbda35ace229fdde6
DIST lv2-1.14.0.tar.bz2 386438 SHA256 b8052683894c04efd748c81b95dd065d274d4e856c8b9e58b7c3da3db4e71d32 SHA512 6991d848ed9f04a48ca3070efc15af83431f680aa8a8559a02b1666f7b8d43af8e089f78c3b14ad3345dac32fd1c8ad0faf3a3f56dddc07c6f0e0aeef4077498 WHIRLPOOL 11aee5cf54786d11b8095a56fd9a93009c617d61a0da63d9cf49ed4ab3dc5d65a8b04e0c0672f4d9f278c50aa0aa9496abf88ba5ee52ed4bbf622083dbde2736
-DIST lv2-1.8.0.tar.bz2 439609 SHA256 a4c90e8f4a8df58c2dd7bc3b9e1a0df94e3c1cc70c95a10da72a40a9deb9b3d7 SHA512 11c80a5c1f81dfa4e43b34859c77b41182f828a27a9f7e539a57320b193f1db6560ee88497051e0f5382bbe77fd496be359c346c5d2534e51c2bdb13737c1845 WHIRLPOOL 3edd51a7f77bf09ec6c0f7287122caee6c6274089fc3ffe804a08a69ba2c7b7177eb741a3cb8eabdd103d79df6de74e61acf363dd7c50043377c07beea4e7b7f
diff --git a/media-libs/lv2/lv2-1.10.0.ebuild b/media-libs/lv2/lv2-1.10.0.ebuild
deleted file mode 100644
index c18152ad9372..000000000000
--- a/media-libs/lv2/lv2-1.10.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-PYTHON_REQ_USE='threads(+)'
-inherit python-single-r1 waf-utils
-
-DESCRIPTION="LV2 is a simple but extensible successor of LADSPA"
-HOMEPAGE="http://lv2plug.in/"
-SRC_URI="http://lv2plug.in/spec/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc plugins"
-
-DEPEND="plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )"
-RDEPEND="${DEPEND}
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/rdflib[${PYTHON_USEDEP}]
- !<media-libs/slv2-0.4.2
- !media-libs/lv2core
- !media-libs/lv2-ui"
-DEPEND="${DEPEND}
- plugins? ( virtual/pkgconfig )
- doc? ( app-doc/doxygen dev-python/rdflib )"
-DOCS=( "README" "NEWS" )
-
-src_configure() {
- waf-utils_src_configure \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- $(use plugins || echo " --no-plugins") \
- $(use doc && echo " --docs" )
-}
-
-src_install() {
- waf-utils_src_install
-
- python_fix_shebang "${D}"
-}
diff --git a/media-libs/lv2/lv2-1.8.0.ebuild b/media-libs/lv2/lv2-1.8.0.ebuild
deleted file mode 100644
index c18152ad9372..000000000000
--- a/media-libs/lv2/lv2-1.8.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-PYTHON_REQ_USE='threads(+)'
-inherit python-single-r1 waf-utils
-
-DESCRIPTION="LV2 is a simple but extensible successor of LADSPA"
-HOMEPAGE="http://lv2plug.in/"
-SRC_URI="http://lv2plug.in/spec/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc plugins"
-
-DEPEND="plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )"
-RDEPEND="${DEPEND}
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/rdflib[${PYTHON_USEDEP}]
- !<media-libs/slv2-0.4.2
- !media-libs/lv2core
- !media-libs/lv2-ui"
-DEPEND="${DEPEND}
- plugins? ( virtual/pkgconfig )
- doc? ( app-doc/doxygen dev-python/rdflib )"
-DOCS=( "README" "NEWS" )
-
-src_configure() {
- waf-utils_src_configure \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- $(use plugins || echo " --no-plugins") \
- $(use doc && echo " --docs" )
-}
-
-src_install() {
- waf-utils_src_install
-
- python_fix_shebang "${D}"
-}
diff --git a/sys-apps/paludis/Manifest b/sys-apps/paludis/Manifest
index ff107172607c..4e2e97488fea 100644
--- a/sys-apps/paludis/Manifest
+++ b/sys-apps/paludis/Manifest
@@ -1,3 +1,2 @@
-DIST paludis-2.0.0.tar.bz2 1787616 SHA256 9e635d86e655658d31adde5813f5fcad2982b5fe8847c3c565eca7d28a1ec639 SHA512 e1df4d0617b4e021d1b63181517c0ecb9ece55669226c6ea0bba318b6899277c09a8d8ccc11ef673a3f27e77302c84702df4ae7568b44a87e0b138e346623728 WHIRLPOOL 90dcd765ebc864d14e569a01071fe3effae3c4424cf7f3004ce1f273c721c512697c6100e3b775d34732640bd770220fe5304f4d2b5e67f2de86c9f04c9ffe97
DIST paludis-2.4.0.tar.bz2 1787689 SHA256 f47b4bb5503dc127022453b15ca811dec22ee2f04c3c3b76ed1c5a83dbe1af1f SHA512 5fbb15d2285c892fdf19288b8838c51ec2439817a9abc685b8692ff4a3ddf76632d3ab51b2e0298c8eacf00f8b00f4e66b47b34db12844cd4eb77cbfb87ca32e WHIRLPOOL d9dc107886b8bf09bb203704d559dd030190b8390607964578c3f2e10a5c5cd4400146ffed894a968143761fc8149796d37597274b34b8414133b26c7252345b
DIST paludis-2.6.0.tar.bz2 1885055 SHA256 bde018c89fce95c2cc793d9171e5a51748ad682d06f839fab394e233257aaf4c SHA512 78a9c0a19703dbbc07934de389b749ab83365454e29b19c323d6c03304162e35ff4d92f7ac1f28067ad853057f2422be43418b3c6a57a193c4b8dd5a4e81eba4 WHIRLPOOL dc4f4ecad0ccbb4b8e6b1b4d0a2c71772b5be244f09dc5456fe42d5510b6b7432ca087f99ae86b2bbbd05b18f70a15371dca1193ead556751faffd01ef227dd6
diff --git a/sys-apps/paludis/files/paludis-2.0.0-fix-format-security.patch b/sys-apps/paludis/files/paludis-2.0.0-fix-format-security.patch
deleted file mode 100644
index 40d2f3ad4953..000000000000
--- a/sys-apps/paludis/files/paludis-2.0.0-fix-format-security.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-commit f777dadef601434550aa3fb411eebab04ad07103
-Author: David Leverton <levertond@googlemail.com>
-Date: Wed Aug 27 21:10:59 2014 +0100
-
- Fix build with -Werror=format-security
-
- Fixes: Gentoo#521326
-
-diff --git a/ruby/paludis_ruby.cc b/ruby/paludis_ruby.cc
-index 587601c..d58a8d0 100644
---- a/ruby/paludis_ruby.cc
-+++ b/ruby/paludis_ruby.cc
-@@ -173,19 +173,19 @@ void paludis::ruby::exception_to_ruby_exception(const std::exception & ee)
- rb_raise(rb_eRuntimeError, "Unexpected paludis::InternalError: %s (%s)",
- dynamic_cast<const paludis::InternalError *>(&ee)->message().c_str(), ee.what());
- else if (0 != dynamic_cast<const paludis::GotASetNotAPackageDepSpec *>(&ee))
-- rb_raise(c_got_a_set_not_a_package_dep_spec, dynamic_cast<const paludis::GotASetNotAPackageDepSpec *>(&ee)->message().c_str());
-+ rb_raise(c_got_a_set_not_a_package_dep_spec, "%s", dynamic_cast<const paludis::GotASetNotAPackageDepSpec *>(&ee)->message().c_str());
- else if (0 != dynamic_cast<const paludis::BadVersionSpecError *>(&ee))
-- rb_raise(c_bad_version_spec_error, dynamic_cast<const paludis::BadVersionSpecError *>(&ee)->message().c_str());
-+ rb_raise(c_bad_version_spec_error, "%s", dynamic_cast<const paludis::BadVersionSpecError *>(&ee)->message().c_str());
- else if (0 != dynamic_cast<const paludis::SetNameError *>(&ee))
-- rb_raise(c_set_name_error, dynamic_cast<const paludis::SetNameError *>(&ee)->message().c_str());
-+ rb_raise(c_set_name_error, "%s", dynamic_cast<const paludis::SetNameError *>(&ee)->message().c_str());
- else if (0 != dynamic_cast<const paludis::PackageNamePartError *>(&ee))
-- rb_raise(c_package_name_part_error, dynamic_cast<const paludis::PackageNamePartError *>(&ee)->message().c_str());
-+ rb_raise(c_package_name_part_error, "%s", dynamic_cast<const paludis::PackageNamePartError *>(&ee)->message().c_str());
- else if (0 != dynamic_cast<const paludis::CategoryNamePartError *>(&ee))
-- rb_raise(c_category_name_part_error, dynamic_cast<const paludis::CategoryNamePartError *>(&ee)->message().c_str());
-+ rb_raise(c_category_name_part_error, "%s", dynamic_cast<const paludis::CategoryNamePartError *>(&ee)->message().c_str());
- else if (0 != dynamic_cast<const paludis::NameError *>(&ee))
-- rb_raise(c_name_error, dynamic_cast<const paludis::NameError *>(&ee)->message().c_str());
-+ rb_raise(c_name_error, "%s", dynamic_cast<const paludis::NameError *>(&ee)->message().c_str());
- else if (0 != dynamic_cast<const paludis::PackageDepSpecError *>(&ee))
-- rb_raise(c_package_dep_spec_error, dynamic_cast<const paludis::PackageDepSpecError *>(&ee)->message().c_str());
-+ rb_raise(c_package_dep_spec_error, "%s", dynamic_cast<const paludis::PackageDepSpecError *>(&ee)->message().c_str());
- else if (0 != dynamic_cast<const paludis::AmbiguousPackageNameError *>(&ee))
- {
- VALUE ex_args[2];
-@@ -198,19 +198,19 @@ void paludis::ruby::exception_to_ruby_exception(const std::exception & ee)
- rb_exc_raise(rb_class_new_instance(2, ex_args, c_ambiguous_package_name_error));
- }
- else if (0 != dynamic_cast<const paludis::NoSuchPackageError *>(&ee))
-- rb_raise(c_no_such_package_error, dynamic_cast<const paludis::NoSuchPackageError *>(&ee)->message().c_str());
-+ rb_raise(c_no_such_package_error, "%s", dynamic_cast<const paludis::NoSuchPackageError *>(&ee)->message().c_str());
- else if (0 != dynamic_cast<const paludis::NoSuchRepositoryError *>(&ee))
-- rb_raise(c_no_such_repository_error, dynamic_cast<const paludis::NoSuchRepositoryError *>(&ee)->message().c_str());
-+ rb_raise(c_no_such_repository_error, "%s", dynamic_cast<const paludis::NoSuchRepositoryError *>(&ee)->message().c_str());
- else if (0 != dynamic_cast<const paludis::ConfigFileError *>(&ee))
-- rb_raise(c_config_file_error, dynamic_cast<const paludis::ConfigFileError *>(&ee)->message().c_str());
-+ rb_raise(c_config_file_error, "%s", dynamic_cast<const paludis::ConfigFileError *>(&ee)->message().c_str());
- else if (0 != dynamic_cast<const paludis::ConfigurationError *>(&ee))
-- rb_raise(c_configuration_error, dynamic_cast<const paludis::ConfigurationError *>(&ee)->message().c_str());
-+ rb_raise(c_configuration_error, "%s", dynamic_cast<const paludis::ConfigurationError *>(&ee)->message().c_str());
- else if (0 != dynamic_cast<const paludis::ActionFailedError *>(&ee))
-- rb_raise(c_action_failed_error, dynamic_cast<const paludis::ActionFailedError *>(&ee)->message().c_str());
-+ rb_raise(c_action_failed_error, "%s", dynamic_cast<const paludis::ActionFailedError *>(&ee)->message().c_str());
- else if (0 != dynamic_cast<const paludis::ActionAbortedError *>(&ee))
-- rb_raise(c_action_aborted_error, dynamic_cast<const paludis::ActionAbortedError *>(&ee)->message().c_str());
-+ rb_raise(c_action_aborted_error, "%s", dynamic_cast<const paludis::ActionAbortedError *>(&ee)->message().c_str());
- else if (0 != dynamic_cast<const paludis::BadVersionOperatorError *>(&ee))
-- rb_raise(c_bad_version_operator_error, dynamic_cast<const paludis::BadVersionOperatorError *>(&ee)->message().c_str());
-+ rb_raise(c_bad_version_operator_error, "%s", dynamic_cast<const paludis::BadVersionOperatorError *>(&ee)->message().c_str());
-
- else if (0 != dynamic_cast<const paludis::Exception *>(&ee))
- rb_raise(rb_eRuntimeError, "Caught paludis::Exception: %s (%s)",
diff --git a/sys-apps/paludis/paludis-2.0.0.ebuild b/sys-apps/paludis/paludis-2.0.0.ebuild
deleted file mode 100644
index ee49cd6e83ae..000000000000
--- a/sys-apps/paludis/paludis-2.0.0.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit bash-completion-r1 eutils python-single-r1 user
-
-DESCRIPTION="paludis, the other package mangler"
-HOMEPAGE="http://paludis.exherbo.org/"
-SRC_URI="http://paludis.exherbo.org/download/${P}.tar.bz2"
-
-IUSE="doc pbins pink python ruby search-index test xml"
-LICENSE="GPL-2 vim"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
-
-COMMON_DEPEND="
- >=app-admin/eselect-1.2.13
- >=app-shells/bash-3.2
- dev-libs/libpcre[cxx]
- sys-apps/file
- pbins? ( >=app-arch/libarchive-3.1.2 )
- python? (
- ${PYTHON_DEPS}
- >=dev-libs/boost-1.41.0[python,${PYTHON_USEDEP}] )
- ruby? ( dev-lang/ruby:1.9 )
- search-index? ( >=dev-db/sqlite-3 )
- xml? ( >=dev-libs/libxml2-2.6 )"
-
-DEPEND="${COMMON_DEPEND}
- >=app-text/asciidoc-8.6.3
- app-text/htmltidy
- app-text/xmlto
- >=sys-devel/gcc-4.7
- doc? (
- || (
- >=app-doc/doxygen-1.5.3
- <=app-doc/doxygen-1.5.1 )
- python? (
- dev-python/sphinx[${PYTHON_USEDEP}] )
- ruby? ( dev-ruby/syntax )
- )
- virtual/pkgconfig
- test? ( >=dev-cpp/gtest-1.6.0-r1 )"
-
-RDEPEND="${COMMON_DEPEND}
- sys-apps/sandbox"
-
-PDEPEND="app-eselect/eselect-package-manager"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != buildonly ]]; then
- if id paludisbuild >/dev/null 2>/dev/null ; then
- if ! groups paludisbuild | grep --quiet '\<tty\>' ; then
- eerror "The 'paludisbuild' user is now expected to be a member of the"
- eerror "'tty' group. You should add the user to this group before"
- eerror "upgrading Paludis."
- die "Please add paludisbuild to tty group"
- fi
- fi
- fi
-
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4
- || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ) ]]
- then
- eerror "Paludis requires at least gcc 4.7 to build. Please switch the active"
- eerror "gcc version using gcc-config."
- die "Paludis requires at least gcc 4.7"
- fi
- fi
-}
-
-pkg_setup() {
- enewgroup "paludisbuild"
- enewuser "paludisbuild" -1 -1 "/var/tmp/paludis" "paludisbuild,tty"
-
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # The package explicitly wants ruby1.9, so fix the script on it.
- # https://bugs.gentoo.org/show_bug.cgi?id=439372#c2
- sed -i -e '1s/ruby/&19/' ruby/demos/*.rb || die
- epatch "${FILESDIR}/${P}-fix-format-security.patch"
-
- epatch_user
-}
-
-src_configure() {
- local myconf=(
- --htmldir=/usr/share/doc/${PF}/html
-
- $(use_enable doc doxygen)
- $(use_enable test gtest)
- $(use_enable pbins)
- $(use_enable pink)
- $(use_enable python)
- $(use python && use_enable doc python-doc)
- $(use_enable ruby)
- $(use ruby && use_enable doc ruby-doc)
- $(use_enable search-index)
- $(use_enable xml)
-
- --enable-vim
- --enable-visibility
- --with-config-framework=eselect
- --with-environments=default,portage
- --with-vim-install-dir=/usr/share/vim/vimfiles
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- prune_libtool_files
-
- dobashcomp bash-completion/cave
-
- insinto /usr/share/zsh/site-functions
- doins zsh-completion/_cave
-}
-
-src_test() {
- # Work around Portage bugs
- local -x PALUDIS_DO_NOTHING_SANDBOXY="portage sucks"
- local -x BASH_ENV=/dev/null
-
- if [[ ${EUID} == 0 ]] ; then
- # hate
- local -x PALUDIS_REDUCED_UID=0
- local -x PALUDIS_REDUCED_GID=0
- fi
-
- if ! nonfatal emake check ; then
- eerror "Tests failed. Looking for files for you to add to your bug report..."
- find "${S}" -type f -name '*.epicfail' -or -name '*.log' | while read a ; do
- eerror " $a"
- done
- die "Make check failed"
- fi
-}
-
-pkg_postinst() {
- local pm
- if [[ -f ${ROOT}/etc/env.d/50package-manager ]] ; then
- pm=$( source "${ROOT}"/etc/env.d/50package-manager ; echo "${PACKAGE_MANAGER}" )
- fi
-
- if [[ ${pm} != paludis ]] ; then
- elog "If you are using paludis or cave as your primary package manager,"
- elog "you should consider running:"
- elog " eselect package-manager set paludis"
- fi
-}
diff --git a/www-apps/scgi/scgi-1.14.ebuild b/www-apps/scgi/scgi-1.14-r1.ebuild
index 46542e14a6cb..8bd6927c6527 100644
--- a/www-apps/scgi/scgi-1.14.ebuild
+++ b/www-apps/scgi/scgi-1.14-r1.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+EAPI=6
-inherit distutils
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
DESCRIPTION="A Python package for implementing SCGI servers"
HOMEPAGE="https://pypi.python.org/pypi/scgi http://python.ca/scgi/ http://www.mems-exchange.org/software/scgi/"
@@ -22,10 +21,6 @@ DEPEND=""
RDEPEND=""
pkg_postinst() {
- distutils_pkg_postinst
-
- elog
elog "This package does not install mod_scgi!"
elog "Please install www-apache/mod_scgi if you need it."
- elog
}
diff --git a/www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899.ebuild b/www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899-r1.ebuild
index 5919028edef3..0611467c4ad4 100644
--- a/www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899.ebuild
+++ b/www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899-r1.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=3
+EAPI=6
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_COMPAT=( python2_7 )
-inherit distutils
+inherit distutils-r1
MY_PN="TracMercurial"
MY_P="${MY_PN}-${PV/_pre/dev-r}"
@@ -22,8 +20,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/setuptools"
-RDEPEND=">=www-apps/trac-0.12
- >=dev-vcs/mercurial-1.1"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=www-apps/trac-0.12[${PYTHON_USEDEP}]
+ >=dev-vcs/mercurial-1.1[${PYTHON_USEDEP}]"
S="${WORKDIR}/${MY_P}"
diff --git a/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206.ebuild b/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild
index 4158f02d78ac..6989df50ac58 100644
--- a/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206.ebuild
+++ b/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_COMPAT=( python2_7 )
-inherit distutils mercurial
+inherit distutils-r1 mercurial
MY_PN="TracMercurial"
MY_P="${MY_PN}-${PV/_pre/dev-r}"
@@ -23,8 +21,8 @@ SLOT="0"
# KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/setuptools"
-RDEPEND=">=www-apps/trac-1.0
- >=dev-vcs/mercurial-1.1"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=www-apps/trac-1.0[${PYTHON_USEDEP}]
+ >=dev-vcs/mercurial-1.1[${PYTHON_USEDEP}]"
S="${WORKDIR}/${MY_P}"
diff --git a/www-apps/trac-tags/trac-tags-0.6.ebuild b/www-apps/trac-tags/trac-tags-0.6-r1.ebuild
index 1e0e31202366..6f090a0e8606 100644
--- a/www-apps/trac-tags/trac-tags-0.6.ebuild
+++ b/www-apps/trac-tags/trac-tags-0.6-r1.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=3
+EAPI=6
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_COMPAT=( python2_7 )
-inherit distutils
+inherit distutils-r1
MY_REV="9901"
MY_DIR="tagsplugin/tags/${PV}"
@@ -23,11 +21,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-CDEPEND=">=dev-python/genshi-0.6"
+CDEPEND=">=dev-python/genshi-0.6[${PYTHON_USEDEP}]"
DEPEND="${CDEPEND}
- dev-python/setuptools
+ dev-python/setuptools[${PYTHON_USEDEP}]
app-arch/unzip"
RDEPEND="${CDEPEND}
- >=www-apps/trac-0.11"
+ >=www-apps/trac-0.11[${PYTHON_USEDEP}]"
S="${WORKDIR}/${MY_DIR}"