summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-03-19 10:44:03 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-03-19 10:44:03 +0300
commit5862e0c0c1e38f3a2dc3d24ed440236231bb3f03 (patch)
treec02d6a33d86646b9886d7fc2f28468e547d59720
parentapp-portage/porthole: remove last-rited pkg (diff)
downloadgentoo-5862e0c0c1e38f3a2dc3d24ed440236231bb3f03.tar.gz
gentoo-5862e0c0c1e38f3a2dc3d24ed440236231bb3f03.tar.bz2
gentoo-5862e0c0c1e38f3a2dc3d24ed440236231bb3f03.zip
dev-python/gnuplot-py: remove last-rited pkg
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--dev-python/gnuplot-py/Manifest1
-rw-r--r--dev-python/gnuplot-py/files/gnuplot-py-1.7-mousesupport.patch75
-rw-r--r--dev-python/gnuplot-py/gnuplot-py-1.8-r2.ebuild35
-rw-r--r--dev-python/gnuplot-py/metadata.xml21
4 files changed, 0 insertions, 132 deletions
diff --git a/dev-python/gnuplot-py/Manifest b/dev-python/gnuplot-py/Manifest
deleted file mode 100644
index f665d9828bfc..000000000000
--- a/dev-python/gnuplot-py/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST gnuplot-py-1.8.tar.gz 118828 BLAKE2B 880062169b2fa047d60318cc7dc556c60794bfd81317681395329a56712506f7e406efecb79f37cd98103e76a6feb8b635e55fe056c3ce5bee0c670c8bcaf7a8 SHA512 748dc95ea53acd362f67c821a3cc7cf23b6329c2dd13c130c91e1c9f89afe1ffd84619ed321923c65455adf86ee58976dd6dd187881ee3ede5e0f5f551fb027d
diff --git a/dev-python/gnuplot-py/files/gnuplot-py-1.7-mousesupport.patch b/dev-python/gnuplot-py/files/gnuplot-py-1.7-mousesupport.patch
deleted file mode 100644
index 2eaf6ae379ed..000000000000
--- a/dev-python/gnuplot-py/files/gnuplot-py-1.7-mousesupport.patch
+++ /dev/null
@@ -1,75 +0,0 @@
---- _Gnuplot.py.orig 2003-10-17 16:28:10.000000000 +0200
-+++ _Gnuplot.py 2004-10-28 14:39:20.000000000 +0200
-@@ -18,6 +18,27 @@
-
- import gp, PlotItems, termdefs
-
-+def test_mouse():
-+ """Return whether mouse support is present or not.
-+
-+ The detection is done by calling gnuplot with a file containing only the
-+ "set mouse" command. If gnuplot does have mouse support, it should simply
-+ execute the file silently, producing no output."""
-+
-+ import os,tempfile,commands
-+
-+ tmpname = tempfile.mktemp()
-+ tfile = open(tmpname,"w")
-+ tfile.write("set mouse")
-+ tfile.close()
-+ msg = commands.getoutput(gp.GnuplotOpts.gnuplot_command + " " +
-+ tmpname)
-+ os.unlink(tmpname)
-+ if msg: # Gnuplot won"t print anything if it has mouse support
-+ has_mouse = 0
-+ else:
-+ has_mouse = 1
-+ return has_mouse
-
- class _GnuplotFile:
- """A file to which gnuplot commands can be written.
-@@ -152,7 +173,7 @@
- 'output' : 'string',
- }
-
-- def __init__(self, filename=None, persist=None, debug=0):
-+ def __init__(self, filename=None, persist=None, debug=0, mouse=None):
- """Create a Gnuplot object.
-
- Create a 'Gnuplot' object. By default, this starts a gnuplot
-@@ -172,8 +193,19 @@
- 'debug=1' -- echo the gnuplot commands to stderr as well as
- sending them to gnuplot.
-
-+ "mouse=1" -- activate mouse support (officially available as of
-+ gnuplot 4.0 under certain platforms).
-+
- """
-
-+ # The mouse check must be done first, so we can decide whether to use
-+ # inline data and fifos or not (they break mouse support)
-+ if mouse is None:
-+ mouse = test_mouse()
-+ if mouse:
-+ gp.GnuplotOpts.prefer_inline_data = 0
-+ gp.GnuplotOpts.prefer_fifo_data = 0
-+
- if filename is None:
- self.gnuplot = gp.GnuplotProcess(persist=persist)
- else:
-@@ -182,10 +214,14 @@
- 'Gnuplot with output to file does not allow '
- 'persist option.')
- self.gnuplot = _GnuplotFile(filename)
-+
- self._clear_queue()
- self.debug = debug
- self.plotcmd = 'plot'
-- self('set terminal %s' % (gp.GnuplotOpts.default_term,))
-+ # The "set mouse" command MUST be the VERY FIRST command passed to gnuplot
-+ if mouse:
-+ self("set mouse")
-+ self("set terminal %s" % gp.GnuplotOpts.default_term)
-
- def __call__(self, s):
- """Send a command string to gnuplot.
diff --git a/dev-python/gnuplot-py/gnuplot-py-1.8-r2.ebuild b/dev-python/gnuplot-py/gnuplot-py-1.8-r2.ebuild
deleted file mode 100644
index 921b7992021f..000000000000
--- a/dev-python/gnuplot-py/gnuplot-py-1.8-r2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-PYTHON_SINGLE_IMPL=true
-
-inherit distutils-r1
-
-DESCRIPTION="A python wrapper for Gnuplot"
-HOMEPAGE="http://gnuplot-py.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ppc64 ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc"
-
-DEPEND="
- || (
- dev-python/numpy-python2[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- )"
-RDEPEND="${DEPEND}
- sci-visualization/gnuplot"
-
-DOCS=( ANNOUNCE.txt CREDITS.txt FAQ.txt NEWS.txt TODO.txt )
-
-PATCHES=( "${FILESDIR}"/${PN}-1.7-mousesupport.patch )
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/Gnuplot/. )
- distutils-r1_python_install_all
-}
-# testsuite does NOT run unattended, so left out here
diff --git a/dev-python/gnuplot-py/metadata.xml b/dev-python/gnuplot-py/metadata.xml
deleted file mode 100644
index fe1997fa7b08..000000000000
--- a/dev-python/gnuplot-py/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">
- Gnuplot.py is a Python module that interfaces to gnuplot, the popular
- plotting program. It allows you to use gnuplot from within Python to
- plot arrays of data from memory, data files, or mathematical
- functions. If you use Python to perform computations or as `glue' for
- numerical programs, you can use this module to plot data on the fly as
- they are computed. And the combination with Python makes it is easy to
- automate things, including to create crude `animations' by plotting
- different datasets one after another.
- </longdescription>
- <upstream>
- <remote-id type="sourceforge">gnuplot-py</remote-id>
- </upstream>
-</pkgmetadata>